Closed Bug 826845 Opened 9 years ago Closed 8 years ago

techtudo.com.br doesn't recognize B2G UA as mobile

Categories

(Web Compatibility :: Mobile, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: lmandel, Assigned: karlcow)

References

()

Details

(Whiteboard: [country-br] [serversniff][sitewait])

techtudo.com.br serves a desktop site to B2G. Bug 819210 added an UA override for this domain. The override should be removed once the domain serves mobile content to B2G. This bug tracks the evangelism for the site to recognize the B2G UA and the removal of the override at that time.
Summary: techtudo.com.br doesnt recognize B2G UA as mobile → techtudo.com.br doesn't recognize B2G UA as mobile
Duplicate of this bug: 826848
Duplicate of this bug: 826849
Duplicate of this bug: 826850
Duplicate of this bug: 826854
Duplicate of this bug: 826857
Duplicate of this bug: 826859
Duplicate of this bug: 826860
Duplicate of this bug: 826862
Duplicate of this bug: 826842
Duplicate of this bug: 826843
Whiteboard: [uaoverride]
I've contacted them (cc-ed Lawrence) and they told me they've fixed it. Now it should just be a matter of time until the fix hits production.
(In reply to Ricardo Panaggio from comment #11)
> I've contacted them (cc-ed Lawrence) and they told me they've fixed it. Now
> it should just be a matter of time until the fix hits production.

Awesome. Do we know the ETA on when the fix will hit production? Once it hits production, then we can remove the UA override and close this bug.
I asked about an ETA via e-mail.
I've tested on a FXOS Geeksphone dev preview and it's working fine.
It's opening the m. version.
Confirmed. I'll file a UA override bug for this.

Thanks for letting everyone know!
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Blocks: 858602
I still get desktop content after removing the UA override on my Unagi.

Jason - How did you confirm this fix?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Lawrence Mandel [:lmandel] from comment #16)
> I still get desktop content after removing the UA override on my Unagi.
> 
> Jason - How did you confirm this fix?

See https://bugzilla.mozilla.org/show_bug.cgi?id=826330#c8.
The redirection is not done through user agent detection server side. 

→ http GET http://www.techtudo.com.br/ User-Agent:'Mozilla/5.0 (Linux; Android 4.0.4; Galaxy Nexus Build/IMM76B) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.133 Mobile Safari/535.19' | grep -i mobile

<script type="text/javascript" src="http://s.glbimg.com/po/tt/m/tectudo/js/glb.behavior.redirectToMobile.js"></script>
			<a href="http://www.techtudo.com.br/tudo-sobre/mobile.html" class="menu-item-a cor-produto-color-hover cor-produto-border-hover" onclick="_gaq.push(['_trackEvent', 'Menu Principal', 'celulares e tablets', document.location.pathname]);">
                        <a href="http://www.techtudo.com.br/tudo-sobre/mobile.html" class="submenu-aba-n1 cor-produto-color-hover" onclick="_gaq.push(['_trackEvent', 'Menu Principal', 'celulares e tablets', document.location.pathname]);">
		<a href="http://www.techtudo.com.br/tudo-sobre/mobile.html">Celulares e tablets</a>
		<a href="http://www.techtudo.com.br/tudo-sobre/mobile.html" class="ver-mais">ver todos</a>



→ http GET http://www.techtudo.com.br/ User-Agent:'Mozilla/5.0 (Android; Mobile; rv:18.0) Gecko/18.0 Firefox/18.0'  | grep -i mobile


<script type="text/javascript" src="http://s.glbimg.com/po/tt/m/tectudo/js/glb.behavior.redirectToMobile.js"></script>
			<a href="http://www.techtudo.com.br/tudo-sobre/mobile.html" class="menu-item-a cor-produto-color-hover cor-produto-border-hover" onclick="_gaq.push(['_trackEvent', 'Menu Principal', 'celulares e tablets', document.location.pathname]);">
                        <a href="http://www.techtudo.com.br/tudo-sobre/mobile.html" class="submenu-aba-n1 cor-produto-color-hover" onclick="_gaq.push(['_trackEvent', 'Menu Principal', 'celulares e tablets', document.location.pathname]);">
		<a href="http://www.techtudo.com.br/tudo-sobre/mobile.html">Celulares e tablets</a>
		<a href="http://www.techtudo.com.br/tudo-sobre/mobile.html" class="ver-mais">ver todos</a>



→ http GET http://www.techtudo.com.br/ User-Agent:'Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0'  | grep -i mobile

<script type="text/javascript" src="http://s.glbimg.com/po/tt/m/tectudo/js/glb.behavior.redirectToMobile.js"></script>
			<a href="http://www.techtudo.com.br/tudo-sobre/mobile.html" class="menu-item-a cor-produto-color-hover cor-produto-border-hover" onclick="_gaq.push(['_trackEvent', 'Menu Principal', 'celulares e tablets', document.location.pathname]);">
                        <a href="http://www.techtudo.com.br/tudo-sobre/mobile.html" class="submenu-aba-n1 cor-produto-color-hover" onclick="_gaq.push(['_trackEvent', 'Menu Principal', 'celulares e tablets', document.location.pathname]);">
		<a href="http://www.techtudo.com.br/tudo-sobre/mobile.html">Celulares e tablets</a>
		<a href="http://www.techtudo.com.br/tudo-sobre/mobile.html" class="ver-mais">ver todos</a>

The following JavaScript is in charge of the identification of the user agent string and redirect to a different domain name, starting with m.
http://s.glbimg.com/po/tt/m/tectudo/js/glb.behavior.redirectToMobile.js

> 'matcherMobile': /android.*mobile|blackberry|docomo|fennec|htc|ip(?:hone|od)|lge|mot|netfront|nokia|opera\sm(?:ini|obi)|samsung-gt-s8500|skyfire|up\.browser|vx10000|wap|windows\s(?:ce|mobile\s7|phone\sos\s7)/i,
> 'matcherNotMobile': /android.*(gt-(?:p|n)|shw-|sc-01c|sch-i800|f-01d|ct100)|tablet|xoom/i,
> 'matcherMobileReferrer': /m\.techtudo\.com\.br/,

As usual matching "android mobile" "opera mobi" "windows mobile" but not "mobile" alone. They could simplify by adding mobile in the list of strings they are matching. They have an anti-matcher already for tablet.
Whiteboard: [uaoverride] → [uaoverride] [country-br]
looks similar to the js from bug 826335 - might be using same backend or lib as globo.com ?
Good match Hallvord. 

> TechTudo.com.br © Copyright 2010-2013 Globo Comunicação e Participações S.A.
See Also: → 826335
Whiteboard: [uaoverride] [country-br] → [uaoverride] [country-br] [serversniff]
Whiteboard: [uaoverride] [country-br] [serversniff] → [uaoverride] [country-br] [serversniff][contactready]
Techtudo is still desktop on mobile. Through Mike we had a contact on September 18, I will try to contact again.
Hello, I contacted 2 friends from Globo.com Andre Fonseca and Davidson Fellipe. They are web developers and maybe can help us on this.
Assignee: nobody → kdubost
Status: REOPENED → ASSIGNED
As a reminder, we really need to solve this one, because it's just bad sniffing. The site is working perfectly on Firefox Android, so it will work the same on Firefox OS.
Contacted another person on Globo team. We will see.
Whiteboard: [uaoverride] [country-br] [serversniff][contactready] → [uaoverride] [country-br] [serversniff][sitewait]
And this is fixed! \o/ 
Thanks a lot to Techtudo Globo people.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago8 years ago
Resolution: --- → FIXED
Blocks: 978663
Whiteboard: [uaoverride] [country-br] [serversniff][sitewait] → [country-br] [serversniff][sitewait]
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.