If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

dailymotion.com doesn't recognize B2G UA as mobile

VERIFIED FIXED

Status

Firefox OS
Gaia
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: lmandel, Assigned: rik)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap -

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 verified, b2g18-v1.0.1 verified)

Details

(Whiteboard: [uaoverride])

Attachments

(1 attachment)

dailymotion.com serves a desktop site to B2G. Bug 819210 added an UA override for this domain. The override should be removed once the domain serves mobile content to B2G. This bug tracks the evangelism for the site to recognize the B2G UA and the removal of the override at that time.
Blocks: 766938
Whiteboard: [uaoverride]
(Assignee)

Comment 1

5 years ago
I'll try and use Twitter to find a contact.

Here's a pointer to our UA reference: https://developer.mozilla.org/en-US/docs/Gecko_user_agent_string_reference

Specifically, it looks like this: "Mozilla/5.0 (Mobile; rv:15.0) Gecko/18.0 Firefox/18.0"
(Assignee)

Comment 2

5 years ago
Found a contact, an internal ticket is open: https://twitter.com/inside_/status/304967625425952768
(In reply to Anthony Ricaud (:rik) from comment #2)
> Found a contact, an internal ticket is open:
> https://twitter.com/inside_/status/304967625425952768

Awesome. Thanks for the help!
(Assignee)

Updated

5 years ago
Assignee: nobody → anthony

Comment 4

5 years ago
Hi, I amended our UA detection code as per your reference docs, and this has been released to production. I've subscribed to this ticket, but in case I don't see update, feel free to email me at firstname dot lastname at companyname dot com
(Assignee)

Comment 5

5 years ago
Created attachment 719468 [details] [diff] [review]
Proposed patch

Excellent, thank you! I've tested and confirmed the UA detection works on the device.
Attachment #719468 - Flags: review?(etienne)

Updated

5 years ago
Component: Mobile → Gaia
Product: Tech Evangelism → Boot2Gecko
Attachment #719468 - Flags: review?(etienne) → review+
(Assignee)

Comment 6

5 years ago
https://github.com/mozilla-b2g/gaia/commit/50adf819f1b1a98b0943870260651c1f50fe598b

I think there is no risk to land this on all branches so requesting tef+.
Status: NEW → RESOLVED
blocking-b2g: --- → tef?
Last Resolved: 5 years ago
Resolution: --- → FIXED
blocking-b2g: tef? → tef+
v1-train: 4cfed54b3937d9d2510ec5ca766895f5996097cd

This patch seems to already be on v1.0.1:

 $ git cherry-pick 88ad3ded48e01c3afa26b70bc9dac9e435395c5f
# On branch v1.0.1
# You are currently cherry-picking.
#   (all conflicts fixed: run "git commit")
#
nothing to commit (working directory clean)
The previous cherry-pick is now empty, possibly due to conflict resolution.
If you wish to commit it anyway, use:

    git commit --allow-empty

Otherwise, please use 'git reset'
status-b2g18: --- → fixed
status-b2g18-v1.0.1: --- → fixed

Updated

5 years ago
Flags: in-moztrap-
Build: 20130322070202
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/5aacf880400b
Gaia   5a31a56b96a8fc559232d35dabf20411b9c2ca1d
Kernel: Dec 5th

On the build above, I've tested all the areas of Dailymotion.com and even added it to the home page to check in that fashion. It appears in the Mobile format unless you turn off the option for Redirect to Webapp.

Marking as Verified Fixed.
Status: RESOLVED → VERIFIED
status-b2g18-v1.0.1: fixed → verified

Updated

5 years ago
status-b2g18: fixed → verified
Blocks: 890004
You need to log in before you can comment on or make changes to this bug.