Firefox button overlaps the first tab in private windows

VERIFIED FIXED in Firefox 20

Status

()

defect
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: obrufau, Assigned: dao)

Tracking

({regression})

Trunk
Firefox 21
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox19 unaffected, firefox20+ verified, firefox21 verified)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Posted image Bug nightly.gif
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

I opened a new private window and opened some tabs and all seemed normal.

I have tried to reproduce it again but I can't, so I don't know what exactly causes the bug.


Actual results:

I realized that the private button was overlapping the first tab.


Expected results:

It shouldn't be overlapping the first tab.
Version: 17 Branch → 21 Branch
Confirmed and setting to NEW

STR: 
1.  Make sure browser is maximized on Windows (tested using win7 x64)
2.  close browser
3.  Open browser
4.  Ctrl+Shift+P or AppMenu -> Open PB window
5.  Note the APPMenu button overlaps the first tab.

Closing/Reopening PrivateBrowsing Window will now show in proper place.  It ONLY occurs on initial start-up of browser in Maximized View and first launch of PB Window.
Blocks: 749394
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Component: Untriaged → Theme
Hmm, Dao, do you have any idea how this could be happening?  Don't we just let the tabs flow on the right-hand side of this button?
This is happening because the button size changes after tabs have been put in the title bar.
Component: Theme → General
(In reply to comment #3)
> This is happening because the button size changes after tabs have been put in
> the title bar.

Do you know what the best way to fix it is?
Posted patch patch (obsolete) — Splinter Review
Ehsan, can you test this on Windows? I believe this should do it.
Attachment #700124 - Flags: review?(ehsan)
Comment on attachment 700124 [details] [diff] [review]
patch

No, it doesn't, the icon doesn't even show up with this patch.  If I change the browser.css hunk to use list-style-image with the original selector and use the new selector to only set the width and height, the icon shows up but the bug happens as it does in an unpatched build.
Attachment #700124 - Flags: review?(ehsan) → review-
Posted patch patchSplinter Review
Ugh, menu buttons have an extra layer of inner boxes :/
Attachment #700124 - Attachment is obsolete: true
Attachment #700532 - Flags: review?(ehsan)
Comment on attachment 700532 [details] [diff] [review]
patch

Yeah, this fixes the bug.  Thanks!
Attachment #700532 - Flags: review?(ehsan) → review+
(Just as a reminder, please nom this for Aurora as well.)
Duplicate of this bug: 829236
Blocks: PBnGen
https://hg.mozilla.org/integration/mozilla-inbound/rev/be47f975b538
Assignee: nobody → dao
Summary: Nightly private button overlaps the first tab → Firefox button overlaps the first tab in private windows
Version: 21 Branch → Trunk
Comment on attachment 700532 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 749394
User impact if declined: See comment 0
Testing completed (on m-c, etc.): locally
Risk to taking this patch (and alternatives if risky): not very risky
String or UUID changes made by this patch: none
Attachment #700532 - Flags: approval-mozilla-aurora?
Duplicate of this bug: 829930
https://hg.mozilla.org/mozilla-central/rev/be47f975b538
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Duplicate of this bug: 830085
Attachment #700532 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified in Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130113 Firefox/21.0 ID:20130113031019
Status: RESOLVED → VERIFIED
Mozilla/5.0 (Windows NT 5.1; rv:20.0) Gecko/20100101 Firefox/20.0
Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20100101 Firefox/20.0

Verified as fixed using STR from comment 0 and comment 1 on Firefox 20 beta 1 (buildID: 20130220104816), latest Aurora (buildID: 20130220042017) and latest Nightly (buildID: 20130221030952).
Verified as fixed on Firefox 21 beta 2 (build ID: 20130401192816)

Mozilla/5.0 (Windows NT 5.1; rv:20.0) Gecko/20100101 Firefox/20.0
You need to log in before you can comment on or make changes to this bug.