Closed Bug 828892 Opened 7 years ago Closed 7 years ago

Favicons are missing for the default bookmarked pages besides about: ones

Categories

(Firefox for Android :: General, defect)

21 Branch
ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
firefox19 --- affected
firefox20 + verified
firefox21 + verified

People

(Reporter: xti, Assigned: mfinkle)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image screenshot
Firefox 21.0a1 (2013-01-09)
Device: Galaxy S2
OS: Android 4.0.3

Steps to reproduce:
1. Open Firefox for Android using a clean profile
2. Go to Awesomescreen > Top Sites and Bookmarks tabs

Expected result:
All favicons are displayed for the default bookmarked pages.

Actual results:
Just the favicons for the about: pages are displayed.
Can we get a regression window for this issue.
tracking-fennec: --- → ?
We wouldn't block the release on this, but it is worth tracking.
Keywords: qawanted
QA Contact: aaron.train
Duplicate of this bug: 830186
Dupe above mentions Beta
Steps in comment #0
Keywords: qawanted
Looking for a tighter regression range. Unfortunately we mozilla-inbound only has builds from the Dec-17 and later. Needs manual bisection.
MFinkle any idea from the tighter regression range? Not a lot jumping out at me.
Flags: needinfo?(mark.finkle)
Blocks: 715258
bug 715258 is the culript
Flags: needinfo?(mark.finkle)
Attached patch patchSplinter Review
This patch adds back two lines that were removed bug bug 715258. Tested with a fresh profile and I see favicons now.
Assignee: nobody → mark.finkle
Attachment #708456 - Flags: review?(bnicholson)
Attachment #708456 - Flags: review?(bnicholson) → review+
Comment on attachment 708456 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 715258
User impact if declined: missing favicons for some default bookmarks
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): low risk. the images are still in the source repo. the patch just adds them to the APK.
String or UUID changes made by this patch: none

Looks like bug 715258 is on Fx20, so I am not requesting Fx19 uplift.
Attachment #708456 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/a3803aaadbdb
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Duplicate of this bug: 836291
Attachment #708456 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Target Milestone: Firefox 21 → ---
Verified using Asus Transformer TF101 (Android 4.0.3) on:
Nightly 21.0a1(2013-02-07) and Aurora 20.0a2(2013-02-07).
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.