Last Comment Bug 829995 - Favorites with uppercase .URL extension not imported from Internet Explorer
: Favorites with uppercase .URL extension not imported from Internet Explorer
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Migration (show other bugs)
: 18 Branch
: All Windows XP
: -- normal (vote)
: Firefox 21
Assigned To: Matthew N. [:MattN]
:
Mentors:
: 839057 844344 (view as bug list)
Depends on:
Blocks: 825558
  Show dependency treegraph
 
Reported: 2013-01-12 13:19 PST by situmandar@gmail.com
Modified: 2013-02-22 16:17 PST (History)
9 users (show)
MattN+bmo: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v.1 ignore case of the .url extension when migrating (1.21 KB, patch)
2013-01-16 15:08 PST, Matthew N. [:MattN]
felipc: review+
Details | Diff | Splinter Review

Description situmandar@gmail.com 2013-01-12 13:19:51 PST
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130104151925

Steps to reproduce:

Import favorites from Internet Explorer 8


Actual results:

Not all Links were imported into Firefox. Firefox imported only those with extension (.url) in lower case. Ones with upper case (.URL) were not imported.


Expected results:

All favorites links should be imported independent of extension case as it is unimportant on Windows platform.
Comment 1 Matthias Versen [:Matti] 2013-01-13 09:54:27 PST
probably a dupe of bug 825558
Comment 2 Bogdan Maris, QA [:bogdan_maris] 2013-01-16 07:50:20 PST
Can you give me some exemples of links with .URL extension? I saved a few links but for all of them the extension was .url.
Comment 3 Matthew N. [:MattN] 2013-01-16 12:57:13 PST
(In reply to Bogdan Maris [QA] from comment #2)
> Can you give me some exemples of links with .URL extension? I saved a few
> links but for all of them the extension was .url.

I believe it would have the same contents, just rename the extension to be uppercase.
Comment 4 situmandar@gmail.com 2013-01-16 13:31:02 PST
(In reply to Matthew N. [:MattN] from comment #3)
> (In reply to Bogdan Maris [QA] from comment #2)
> > Can you give me some exemples of links with .URL extension? I saved a few
> > links but for all of them the extension was .url.
> 
> I believe it would have the same contents, just rename the extension to be
> uppercase.

Yes you're right. You can rename

someIExplorerFavorite.url to someIExplorerFavorite.URL
Comment 5 Matthew N. [:MattN] 2013-01-16 15:08:46 PST
Created attachment 703060 [details] [diff] [review]
v.1 ignore case of the .url extension when migrating

I could reproduce the issue and the cause is clear in the code. No tests since we don't have the framework for this yet :(
Comment 6 Matthew N. [:MattN] 2013-01-16 18:43:50 PST
Thanks for the report and discovering that the case of the file extension was the issue.

https://hg.mozilla.org/integration/fx-team/rev/4a1b771880d8
Comment 7 situmandar@gmail.com 2013-01-17 14:56:58 PST
(In reply to Matthew N. [:MattN] from comment #6)
> Thanks for the report and discovering that the case of the file extension
> was the issue.
> 
> https://hg.mozilla.org/integration/fx-team/rev/4a1b771880d8

You're welcome. Developers should help each other.
Comment 8 Matthew N. [:MattN] 2013-01-17 16:24:02 PST
https://hg.mozilla.org/mozilla-central/rev/4a1b771880d8
Comment 9 Lars Gusowski [:lagu] 2013-02-11 23:50:08 PST
*** Bug 839057 has been marked as a duplicate of this bug. ***
Comment 10 danemer 2013-02-16 06:58:12 PST
Hi guys,

Still trying to resolve this issue on MY PC but am not sure what to think of this page.
I noticed the "Status: 	RESOLVED FIXED" part but there aren't ANY instructions as to what I (as a user - NOT a programmer) am supposed to do to resolve this on MY system.
Can someone PLEASE help me understand what was not made clear to me here or am I in the wrong area as far as an (under-educated?) user simply trying to resolve an issue?

ps,
THIS IS EXTREMELY FRUSTRATING. SEVERAL DAYS LATER I AM STILL CHASING MY *SS ON THIS ISSUE SIMPLY BECAUSE NO ONE (OF THE PEOPLE THAT CAN SOLVE - OR HAVE SOLVED - THIS ISSUE) SEEMS TO BE CAPABLE OF GIVING ME A STRAIGHT, INFORMATIVE ANSWER.

TIME TO FIND A DIFFERENT TYPE OF BROWSER - THIS ONE IS FOR THE BIRDS!!

Thanks
Comment 11 Matthias Versen [:Matti] 2013-02-16 07:42:00 PST
danemer@hotmail.com: This bug is fixed and it's fixed in the coming FIrefox Version 21 (see the target Milestone header).
There is a simple workaround for this bug: Export the bookmarks in IE as html file and import the file in Firefox.

your ps part is obsolete. This is bugzilla, the developer area of mozilla.org and we don't provide support or help here. Just visit http://support.mozilla.org if you need help.
Comment 12 danemer 2013-02-16 08:42:50 PST
My version is IE 8.0.6001.18702 with Win XP SP3 - fully updated.
I already tried this "Export the bookmarks in IE as html file and import the file in Firefox" but got the same results as the regular import method.

Why does importing now need to add the .url to all of the bookmarks?

This is unnecessary AND annoying.
Older versions of Firefox did not have these issues and were always easy to navigate and were pretty reliable too.

What changed?

Also, the only thing you can get from: http://support.mozilla.org is current instructions for how it is SUPPOSED to work - NOT what to do if it doesn't.

I did also notice one more thing - there seems to be lack a good descriptions of terms/processes they use like "migration".
I couldn't find any descriptive info on this term.

When you click on "Was this article helpful?" - nothing seemed to happen there either.

Thank you for your assistance!
Comment 13 Matthias Versen [:Matti] 2013-02-16 08:51:47 PST
This bug report is limited to the automated import. Everything else is outside the scope of this bug report.

You can open a new bug report if importing the html file doesn't work.
Comment 14 Matthias Versen [:Matti] 2013-02-22 16:17:25 PST
*** Bug 844344 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.