Followup on bug 829170 - When firing a web activity within a trusted UI, we need to minimize the trusted UI, not leave the trusted UI on top of the app the activity goes to

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::System
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: jsmith, Assigned: alive)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Device: Unagi
Build: 1/12/2013 B2G 18

Steps:

1. Launch marketplace
2. Start the persona sign in process with trusted UI
3. Pull down the notification bar and hit the settings icon

Expected:

The trusted UI should be minimized (not closed) and allow the user to move to the settings app.

Actual:

The trusted UI remains on top and can't be closed by hitting the X button.

Additional Notes:

This is a followup on bug 829170, as the patch there doesn't appear to fix the bug.
(Reporter)

Updated

5 years ago
Blocks: 829170, 829392
(Reporter)

Updated

5 years ago
Blocks: 801561
(Reporter)

Updated

5 years ago
blocking-b2g: --- → tef?
tracking-b2g18: --- → ?
(Reporter)

Updated

5 years ago
Blocks: 829176
blocking-b2g: tef? → tef+
tracking-b2g18: ? → +
This works for me.
Open settings app in quick settings is via setDisplayedApp in WindowManager.
I think the patch of bug 829170 does fix this. However, I am still unsure how to do test the purchase described in bug 829170..open settings app and open sms may be different.
(Reporter)

Comment 2

5 years ago
(In reply to Alive Kuo [:alive] from comment #1)
> This works for me.
> Open settings app in quick settings is via setDisplayedApp in WindowManager.
> I think the patch of bug 829170 does fix this. However, I am still unsure
> how to do test the purchase described in bug 829170..open settings app and
> open sms may be different.

Just grabbed a recent build and re-flashed - this isn't working for me or Krupa. Are you absolutely sure you are testing on the right build? I'm testing off of the nightly builds on pvtbuilds, which does not currently show this working over the past few days.
Assignee: nobody → alive
(Reporter)

Comment 3

5 years ago
Strange. Now I can't reproduce on the 1/15 build.
Status: NEW → RESOLVED
blocking-b2g: tef+ → ---
Last Resolved: 5 years ago
tracking-b2g18: + → ---
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.