[Calendar] Blank space instead of "again" displays in offline error message on v1-train & v1.0.1

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: nkot, Assigned: olav)

Tracking

({l12y})

unspecified
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18+ verified, b2g18-v1.0.1 affected)

Details

(Whiteboard: "testrun 5.1", leorun1, inarirun2)

Attachments

(4 attachments)

(Reporter)

Description

6 years ago
Created attachment 701523 [details]
screenshot

Summary: In the offline error message "again" does not show up, see screenshot 

Unagi Build ID:2013-01-12-070202

## STR:
have a calendar previously imported

1. Try to sync without a network connection
2. Observe an error message

## Expected:
"No connection. Check your network configuration and try again."

## Actual:
"No connection. Check your network configuration and try      ."
Although polish, I'd probably still track it.
tracking-b2g18: --- → ?
Keywords: polish
Priority: P3 → --
Whiteboard: [UX-P?]

Updated

6 years ago
Keywords: l12y, late-l10n

Updated

6 years ago
Hardware: x86_64 → ARM

Comment 2

6 years ago
Error message isn't totally readable, and may impact other localizations even worse. Tracking for a future release.

Axel - I don't think this is late-l10n, since we won't change strings.
tracking-b2g18: ? → +
Keywords: late-l10n
Yuren, can you pick this up?

Comment 4

6 years ago
Issue repros on  
Unagi Build ID: 20130225070200
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/3a5a27992a75
Gaia: 5691a16fff8e1403c75ed9d6f3a443b7e58198c6

When trying to sync when offline you get an error message saying "No connection. Check your network configuration and try      ."
Whiteboard: [UX-P?] → [UX-P?] "testrun 5.1"

Updated

6 years ago
Duplicate of this bug: 830712

Updated

5 years ago
status-b2g18-v1.0.1: --- → affected

Comment 6

5 years ago
UX reviewed this today and believes it is resolved in the dupe bug 837012. But, I'm flagging this one for testing to ensure this doesn't ship like this. I've also removed the "polish" keyword because we consider this a blocker (especially if we think of what it might look like in German ;).
Keywords: polish → qawanted
Whiteboard: [UX-P?] "testrun 5.1" → "testrun 5.1"
(In reply to Stephany Wilkes from comment #6)
> UX reviewed this today and believes it is resolved in the dupe bug 837012.
> But, I'm flagging this one for testing to ensure this doesn't ship like
> this. I've also removed the "polish" keyword because we consider this a
> blocker (especially if we think of what it might look like in German ;).

Not a dupe. And that's probably not the bug you meant. And I think you meant to nom, not flag qawanted.
blocking-b2g: --- → tef?
Keywords: qawanted

Comment 8

5 years ago
The issue marked as Duplicates above (https://bugzilla.mozilla.org/show_bug.cgi?id=830712) appears to have addressed the issue reported here.

If nominating this for tef? is the only way for Naoki's team to know to take a gander at it before it goes out, then that will work.
(In reply to Stephany Wilkes from comment #8)
> The issue marked as Duplicates above
> (https://bugzilla.mozilla.org/show_bug.cgi?id=830712) appears to have
> addressed the issue reported here.
> 
> If nominating this for tef? is the only way for Naoki's team to know to take
> a gander at it before it goes out, then that will work.

QA knows this is a confirmed bug, so no need to pull more involvement in here. If UX thinks it's a blocker, that's a case for calling a blocking nom for a release.

Comment 10

5 years ago
Got it. Thanks for your help! :)
Triage decided this isn't a blocker for release - more of polish than a critical user issue.
blocking-b2g: tef? → -

Comment 12

5 years ago
OK - but... :) I do want to go on record as saying that cutting off a message like this is an example of the types of things that is used as an indicator of FF OS "not being ready for the major players." I know this is a very UX-centric concern, but it's a perception we hear a lot about that we're trying to assuage.
Duplicate of this bug: 859111
Bug 859111 is a dupe, but has a patch and is leo+.

Updated

5 years ago
Whiteboard: "testrun 5.1" → "testrun 5.1", leorun1
sorry didn't notice this issue and nominating to leo+ again according comment 14
Assignee: nobody → yurenju.mozilla
blocking-b2g: - → leo?
Created attachment 740718 [details]
https://github.com/mozilla-b2g/gaia/pull/9279

Re-assign to olav since he had a pull request and set r? to me because this looks like a simple css change.
Attachment #740718 - Flags: review?(yurenju.mozilla)
Assignee: yurenju.mozilla → olav
Created attachment 740730 [details]
screenshot 4/23

I can't reproduce it.

nkot, could you try again on current build?
Flags: needinfo?(nkot)

Updated

5 years ago
Keywords: qawanted
We re-evaluated in triage, and really think this is not bad enough to block the release. Would definitely like to see it fixed, but wouldn't hold the release back for it.
blocking-b2g: leo? → -
I can still reproduce this by doing the following on a 4/24 build:

1. With no network connection, try to add an account without a network connection

Result - I get the cut off network connection specified in the bug.
Flags: needinfo?(nkot)
Keywords: qawanted
Oh, I can reproduce it, thank you Jason.
Jason, can't reproduce again on master... Maybe someone fixed this on another bug?

Updated

5 years ago
Duplicate of this bug: 867922
(In reply to Yuren Ju [:yurenju] from comment #21)
> Jason, can't reproduce again on master... Maybe someone fixed this on
> another bug?

Haven't tested on master yet. When I tested this, I was able to reproduce on b2g18 and 1.01.

So yeah, some other bug only fixed on master probably fixed this then if you can't reproduce on master.

Kevin - Do you have any ideas what patch fixed this issue on master?
Flags: needinfo?(kgrandon)
This patch from Bug 830644 appears to fix the issue: https://github.com/mozilla-b2g/gaia/commit/4bf81bf18df57073e4d23852d881f61ce0474249#shared/style/status.css

I'm not sure what the plan is to uplift that stuff. If absolutely necessary I could probably cherry-pick or open up a pull request with a single file.
Depends on: 830644
Flags: needinfo?(kgrandon)
Summary: [Calendar] Blank space instead of "again" displays in offline error message → [Calendar] Blank space instead of "again" displays in offline error message on v1-train & v1.0.1
Comment on attachment 740718 [details]
https://github.com/mozilla-b2g/gaia/pull/9279

this pull request can't solve this problem on v1-train.
Attachment #740718 - Flags: review?(yurenju.mozilla) → review-
Marked this to WONTFIX since this problem was fixed on master and Dietrich said this doesn't block the release.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
(In reply to Yuren Ju [:yurenju] from comment #26)
> Marked this to WONTFIX since this problem was fixed on master and Dietrich
> said this doesn't block the release.

Uhh...just because something doesn't block the release doesn't mean we can't an approval for an uplift here.

As Kevin suggested above, the right way to fix this is to develop a v1-train specific cherry picked patch that fixes the issue, get a r+, and get approval.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Updated

5 years ago
Duplicate of this bug: 869839

Updated

5 years ago
Duplicate of this bug: 869853
Repros on Inari 1.1 commercial RIL.

Build ID: 20130515070208
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/d06cfe7d67c2
Gaia: 0ddb515f15cbc6b74fc2742b7599d6ae74c6413f
Version #: 18.0
Whiteboard: "testrun 5.1", leorun1 → "testrun 5.1", leorun1, Inarirun2
Repros on Inari 1.1 commercial RIL.  "Again" is wrapped to a third line, but the notification only has room for two lines.

Build ID: 20130515070208
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/d06cfe7d67c2
Gaia: 0ddb515f15cbc6b74fc2742b7599d6ae74c6413f
Version #: 18.0

Updated

5 years ago
Whiteboard: "testrun 5.1", leorun1, Inarirun2 → "testrun 5.1", leorun1, inarirun2

Comment 32

5 years ago
Let's revisit this, as we're seeing this as recently as 5/29.  Renomming for Leo.
blocking-b2g: - → leo?
Leo would like to know what it looks like in other languages in order to be able to know if we must block or not.
Keywords: qawanted
(In reply to David Scravaglieri [:scravag] from comment #33)
> Leo would like to know what it looks like in other languages in order to be
> able to know if we must block or not.

Please see the dupes of this bug.
Keywords: qawanted
Duplicate of a leo+
blocking-b2g: leo? → leo+
Kevin - In comment 24 you mention we could cherrypick a fix from bug 830644 to address this. Can you do that for 1.1?
Flags: needinfo?(kgrandon)
It appears that bug 830644 has made it's way to v1-train and this is now resolved.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
status-b2g18: --- → fixed
Flags: needinfo?(kgrandon)
Resolution: --- → FIXED

Updated

5 years ago
Keywords: verifyme
(Reporter)

Comment 38

5 years ago
Created attachment 760512 [details]
screenshot-fixed

verifying fix 
- no connection notification is now displaying correct - see the screenshot
Verified per comment 38.
status-b2g18: fixed → verified
Keywords: verifyme
(Reporter)

Comment 40

5 years ago
in addition to comment 38,

test device info:
Inari
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/8e3f39363c54
Gaia   ce3b99781d182ad550a325206990c249b0dbcf0e
Build  20130610070206
Version 18.0

Updated

5 years ago
Flags: in-moztrap?
You need to log in before you can comment on or make changes to this bug.