Last Comment Bug 83114 - Need to synchronize preferences LDAP's and the addresbook
: Need to synchronize preferences LDAP's and the addresbook
Status: VERIFIED DUPLICATE of bug 125821
:
Product: SeaMonkey
Classification: Client Software
Component: MailNews: Address Book & Contacts (show other bugs)
: Trunk
: All All
-- normal (vote)
: ---
Assigned To: John Marmion
: yulian chang
:
Mentors:
Depends on:
Blocks: 125821
  Show dependency treegraph
 
Reported: 2001-05-29 08:35 PDT by Cuchulainn
Modified: 2004-11-22 17:25 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Cuchulainn 2001-05-29 08:35:30 PDT
Need to ensure that preference updates for LDAP directories
are synchronised with the address book and vice versa
Comment 1 User image Dan Mosedale (:dmose) 2001-05-29 15:55:45 PDT
Srilatha has a bug for the same issue with the addressing widget autocomplete
(bug 79792).  I think the most recent theory was to use an nsIPrefsObserver, but
I'm not sure about that.  She probably has some comments.

By the way, these last few bugs you filed are great -- keeping tracking of this
in bugzilla with this finer resolution is very helpful. It's probably best to
have them assigned to whoever is working on the code for this particular thing,
however, rather than me.
Comment 2 User image Cuchulainn 2001-05-31 03:25:39 PDT
Csaba will probably be working on this bug so I reassigned it to him
Comment 3 User image Paul.Sandoz 2001-05-31 03:46:33 PDT
From my limited understanding on how preference observations work i think care
has to be taken to manage multiple events occuring for an address book instance.
Is this correct? i.e. there is no transactional nature to the preferences and
the ability to get a single event for a particular branch pattern associated
with the "ldap_2.servers.*".

The same issues will occur for outlook related preferences too.

A possible future idea might be for all address book preference manipulation to
occur in the 'abdirectory://' resource, but i don't think this is practical
given the time frame. Then listeners to the nsIAddressBookSession interface will
get notifications for additions and deletions and XUL templates can be used to
display address books on the resource, in addition the view can be limited to
certain types of address book.
However, i don't think all the infrastructure is there for notification of
changes to address book properties.
Comment 4 User image Srilatha Moturi 2001-05-31 11:09:09 PDT
I am planning on using AddObserver and RemoveObserver from nsIPrefBranch to fix 
79792. I believe you can use AddObserver on ldap_2.servers.* but you will get n 
events if n preferences in that branch are changed.
Comment 5 User image Paul.Sandoz 2001-06-01 09:00:16 PDT
How do you propose to manage the multiple event problem? since i am not sure if
this can be avoided when address books are added and removed.
I presume 'changed' means new, delete & modify?
Comment 6 User image fenella 2001-08-15 17:49:04 PDT
LDAP is Yulian's area. Assign it to her.
Comment 7 User image Csaba Borbola 2001-10-15 01:40:47 PDT
Passing the ownership to John Marmion@sun, because I was moved to another
project.
Comment 8 User image Ian Neal 2002-02-20 15:43:21 PST
Seeing this seems to be tied in to all that, maybe a dupe of one of the other
bugs linked to bug 125821
Comment 9 User image Ian Neal 2002-02-20 15:56:28 PST
When you import a profile from NS4.x which already has directory servers setup
then they appear under prefs addressing in mozilla but don't appear in the
address book and can't be made to appear there without deleting and recreating.

Using buildID 2002022009 on windows 2000 SP2
Comment 10 User image John Marmion 2002-02-21 06:26:32 PST
Ian, this bug had disappeared from my radar. It originally was created to
compliment bug #83091. Now that it has been landed and bug #125821 was set up as
a placeholder for outstanding issues and bugs arising from #83091, I agree that
we should close this as a duplicate of #125821.

But even more important is your comment #9, I can confirm that this indeed is a
bug. Because the imported LDAP Directory Server gets created with a filename
suffix of "na2" then it is ignored by the Address Book Factory creation. This is
a bad bug and likely to cause people grief. The AutoCompletion works correctly.
 
I would like to see us close this is a duplicate and spin off a new bug devoted
solely to this issue. It can be tied to #125821 and use the nab-ldap keyword.
Comment 11 User image Ian Neal 2002-02-21 07:17:13 PST
Logged a new bug 127007 for above.
Comment 12 User image John Marmion 2002-02-22 09:42:47 PST
yulian@netscape.com can you close this is a duplicate of bug #125821 ?
Comment 13 User image yulian chang 2002-02-22 11:24:03 PST
dup of bug 125821

*** This bug has been marked as a duplicate of 125821 ***
Comment 14 User image yulian chang 2002-02-22 11:24:46 PST
Verified as dup

Note You need to log in before you can comment on or make changes to this bug.