Last Comment Bug 125821 - code cleanup of LDAP autocomplete pref panel js, addressbook properties js
: code cleanup of LDAP autocomplete pref panel js, addressbook properties js
Status: RESOLVED DUPLICATE of bug 305434
:
Product: SeaMonkey
Classification: Client Software
Component: MailNews: Address Book & Contacts (show other bugs)
: Trunk
: x86 Windows 2000
-- normal with 2 votes (vote)
: ---
Assigned To: mail
:
:
Mentors:
: 83114 (view as bug list)
Depends on: 83114 124057 124059 124061 124064 125823 125831 127007 127110 128340 128342 408613
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-15 17:31 PST by (not reading, please use seth@sspitzer.org instead)
Modified: 2008-09-09 11:49 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image (not reading, please use seth@sspitzer.org instead) 2002-02-15 17:31:33 PST
code cleanup of LDAP autocomplete pref js

there is some autocomplete pref js that is doing stuff that the back end code 
already does.

spefically, we have js to enumerate all ldap servers, for dynamically 
determining the unique "prefname",  for poking the prefs when adding or 
deleting or modifying ldap servers.

instead, we should be using the existing nsIAddressBook interface, to which we 
need to add a modify()

some bugs that relate to this:

124057  nor -- PC srilatha@netscape.com NEW  mozilla0.9.9 nab-ldap when I 
delete addressbooks from the prefs (addressing panel)  
124059  nor -- PC srilatha@netscape.com NEW  --- nab-ldap when I add LDAP 
directories from the prefs (addressing panel  
124061  nor -- PC srilatha@netscape.com NEW  --- nab-ldap when I delete a LDAP 
directory from the addressbook, there a  
124064  nor -- PC srilatha@netscape.com NEW  --- nab-ldap when I add an LDAP 
directory from the addressbook (not imple  
124553  nor -- PC srilatha@netscape.com NEW  --- nab-ldap Changes to LDAP 
properties in Address Book window not reflec
Comment 1 User image (not reading, please use seth@sspitzer.org instead) 2002-02-15 17:41:43 PST
one more bug, #125823 (add modify() to nsIAddressBook.idl and use it.)

there's a lot of code to clean up, we shouldn't be writing or reading from 
prefs directly.

I don't think we need to re-write all the code before 0.9.9 or 1.0, but we 
should start with the code that writes prefs, and later fix the does the 
reading.

the reason we need to fix the write-pref code first, is that it poking prefs 
directly causes bugs that the user can see.
Comment 2 User image yulian chang 2002-02-22 11:24:07 PST
*** Bug 83114 has been marked as a duplicate of this bug. ***
Comment 3 User image (not reading, please use seth@sspitzer.org instead) 2003-03-15 22:30:13 PST
cavin has fixed some of this already.
Comment 4 User image Mark Banner (:standard8) 2008-09-09 11:49:20 PDT
The remaining work on this will be done in bug 305434.

*** This bug has been marked as a duplicate of bug 305434 ***

Note You need to log in before you can comment on or make changes to this bug.