Closed Bug 831971 Opened 12 years ago Closed 12 years ago

Story - Context menu for links

Categories

(Tracking Graveyard :: Metro Operations, defect, P4)

x86_64
Windows 8.1
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: asa, Unassigned)

References

Details

(Whiteboard: feature=story c=context_menus u=metro_firefox_user p=0 status=verified)

Attachments

(1 file, 2 obsolete files)

Attached file UC-146 Context menu for links (obsolete) —
      No description provided.
Priority: -- → P2
Whiteboard: c=Content_features u= p= → c=Content_features u=metro_firefox_user p=
Summary: UC-146 Context menu for links → Story – Context menu for links
Whiteboard: c=Content_features u=metro_firefox_user p= → c=Content_features u=metro_firefox_user feature=story
Attached file UC-146 Context menu for links (obsolete) —
Attachment #703541 - Attachment is obsolete: true
Depends on: 800544
Depends on: 800989
Depends on: 800543
Blocks: metro-contextmenus
No longer blocks: 831565
Whiteboard: c=Content_features u=metro_firefox_user feature=story → c=context_menus u=metro_firefox_user feature=story
OS: Windows 8 → Windows 8 Metro
Whiteboard: c=context_menus u=metro_firefox_user feature=story → feature=story c=context_menus u=metro_firefox_user p=0
Attachment #704729 - Attachment is obsolete: true
Depends on: 782810
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Whiteboard: feature=story c=context_menus u=metro_firefox_user p=0 → feature=story c=context_menus u=metro_firefox_user p=0 status=for_testing
Blocks: metrov1legacy
No longer blocks: metrov1backlog
Tested on 2013-02-21 Nightly built from http://hg.mozilla.org/mozilla-central/rev/d57a813c77a4
- Reopening because the order of the options in the story does not match what appears in the browser.

The story has this order:

Copy link
Open link in new tab
Bookmark link

The browser currently has:
Open Link in New Tab
Bookmark Link
Copy Link

All of the options work as expected.

If this is the intended order, then we can mark this story as verified.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Flags: needinfo?(asa)
Priority: P2 → P4
Depends on: 843806
Re-resolving fixed based on 843806
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → FIXED
Verified with build in comment #3.
Status: RESOLVED → VERIFIED
Flags: needinfo?(asa)
Whiteboard: feature=story c=context_menus u=metro_firefox_user p=0 status=for_testing → feature=story c=context_menus u=metro_firefox_user p=0 status=verified
No longer depends on: 843806
Blocks: metrov1it0
No longer blocks: metrov1legacy
Summary: Story – Context menu for links → Story - Context menu for links
Component: General → Metro Operations
Product: Firefox for Metro → Tracking
Version: unspecified → ---
Depends on: 856264
Depends on: 856267
Verifying for it4 testing. Found two defects when going through the following story. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-03-29-03-09-04-mozilla-central/

- Attached both defects to this ticket
Went through the following "Story" for iteration #8 testing without any issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-06-12-03-11-38-mozilla-central/

- Ensured that the context menu order matches Yuan's specification
- Ensured that tapping will produce the context menu without any issues
- Ensured that right clicking will produce the context menu without any issues
- Ensured that "Open link in new tab" worked without issues
- Ensured that "Copy link" worked without any issues
- Ensured that "Bookmark link" worked without any issues
- Ensured that you can dismiss the context menu by tapping anywhere on the screen
- Ensured that the above test cases also worked in Filled View

Note:

Bug 856264 is still an issue. Reproduced several times with the latest build
Went through the following "Story" for iteration #9 testing without any issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-07-02-11-03-00-mozilla-central/

- Went through the original attached Story without any issues
- Went through the test cases added in comment 7 without any issues

Notes:

Bug 856264 is still an issue. Reproduced several times with the latest build
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130809030203
Built from http://hg.mozilla.org/mozilla-central/rev/e33c2011643e

WFM
Tested on windows 8 using latest nightly for iteration-11. Followed steps provided in user story and got expected result.
Depends on: 904992
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130823030204
Built from http://hg.mozilla.org/mozilla-central/rev/fb2318875cd4

WFM
Tested on windows 8 using latest nightly for iteration-12. Followed steps provided in user story and got expected result.
Depends on: 918172
Went through the following "Story" for iteration #14 with some issues (Failed). Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-09-18-03-02-02-mozilla-central/

Went through the test case(s) and it appears that there's issues with receiving context menu's when tapping on links. Created a bug and blocked this story.
Depends on: 922934
Went through the following "Story" for iteration #15 with some issues (Failed). Used the following build:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-10-01-03-02-04-mozilla-central/

Went through the test case(s) and it appears that there's issues with dismissing the context menu once a user scrolls through the website. Created a bug and blocked this story.
No longer depends on: 904992
No longer depends on: 918172
OS: Windows 8 Metro → Windows 8.1
Product: Tracking → Tracking Graveyard
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: