Defect - Items in the link context menu stay in a highlighted state

RESOLVED DUPLICATE of bug 904204

Status

Firefox for Metro
Browser
RESOLVED DUPLICATE of bug 904204
5 years ago
4 years ago

People

(Reporter: kjozwiak, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 789991 [details]
"Open link in new tab" in a constant highlighted state

When you tap and hold on a link, you will receive a context menu with several items. If you select an item, it will stay highlighted the next time you get receive context menu in the same page.

The best way to reproduce this is selecting some text via the carrot selections and then receiving a link context menu and tapping on the one of the items.

- Attached two screenshots to illustrate the issue

Steps to reproduce the issue:

1) Open Firefox Metro
2) Go to wikipedia.org (Just select some random page so you have several links available)
3) Select some text by tapping and holding, and then dragging the monocles
4) Once you have some text selected, tap and hold on a link until you receive a context menu
5) Select the "Open link in new tab" (let the new page open in a new tab and the Tab App Bar should disappear after a few seconds)
6) Tap and hold on another link in the same page and you'll notice that "Open link in new tab" is still in a highlighted state

Current Behavior:

- Items in the link context menu are left in a highlighted state at times

Expected Behavior:

- Items in the link context menu shouldn't be left in a highlighted state. Once a user selects an item, it should quickly appear highlighted to show the user that it was selected and then return to normal.

Used the following build:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-08-13-03-02-05-mozilla-central/
(Reporter)

Comment 1

5 years ago
Created attachment 789992 [details]
"Bookmark Link" in a constant highlighted state

Updated

5 years ago
Depends on: 904204

Updated

5 years ago
Whiteboard: feature=defect c=context_menus u=metro_firefox_user p=0 → [preview-triage] feature=defect c=context_menus u=metro_firefox_user p=0

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 904204

Updated

5 years ago
Whiteboard: [preview-triage] feature=defect c=context_menus u=metro_firefox_user p=0 → feature=defect c=context_menus u=metro_firefox_user p=0

Updated

4 years ago
No longer blocks: 838081, 831971
Whiteboard: feature=defect c=context_menus u=metro_firefox_user p=0
(Assignee)

Updated

4 years ago
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.