Large cursors obscure tooltips on clickable page elements

RESOLVED DUPLICATE of bug 557754

Status

()

RESOLVED DUPLICATE of bug 557754
6 years ago
4 years ago

People

(Reporter: pnkfelix, Unassigned)

Tracking

({access})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Created attachment 706337 [details]
Screen shot showing where you change the mouse cursor

If one increases the size of a mouse cursor
  via OS X System Preferences.app .. Accessibility .. Display
(see attached "accessibility.jpg") then the popup text will render underneath the mouse cursor.

For example, I used the following code:

<html>
<head>
<title>Popup text demo</title>
</head>
<body>
<a title="Hello from popup" href="nowhere">Hover mouse here</a>
</body>
</html>

and in the result, when my mouse cursor is large, the characters "Hello f" in the popup text are hidden by the cursor (see attached "hello-is-hidden.jpg").
Created attachment 706338 [details]
Screen shot showing cursor hiding text

Comment 2

6 years ago
This doesn't belong in Disability Access APIs, it's a Windows widget problem.
Component: Disability Access APIs → Widget: Win32
Keywords: access
OS: Mac OS X → Windows 7
Not Windows. It is on Mac.
Component: Widget: Win32 → Widget: Cocoa
OS: Windows 7 → Mac OS X
I should be able to get to this eventually (in a few weeks).

Marco, do you have any ideas or suggestions on how to deal with this?  Have you seen something similar before (possibly on other platforms)?
Assignee: nobody → smichaud
Flags: needinfo?(marco.zehe)
The large cursor looks like an arrow most of the time, but changes to a ][ style cursor shape in an editable text box.   Over a clickable element, it changes to the large gloved cartoon hand that is Robert's screenshot.  The hand is down and to the right of the element. If the clickable element has a tooltip, much of the tooltip is obscured by the large cursor "gloved hand".

Possibly the tooltip could show in a considerably offset position if the cursor size has been changed, or there could be an option to flip the pointing hand or start it out flipped to the left in the Accessibility panels.  If the hand became a left hand, it might not obscure clickable elements' tooltips even at the largest size.

The same issue may hold true for the larger cursor arrow and for non-clickable elements that have a tooltip.

Renaming this bug for clarity.
Summary: Popup text renders underneath large cursor → Large cursors obscure tooltips on clickable page elements

Comment 7

6 years ago
Steven, Liz, no I have never heard of this problem. And I obviously never noticed it, because I can't see the mouse. How does this look in other apps? Do they take the cursor size into account when they bring up a tool tip near it?
Flags: needinfo?(marco.zehe)
So ... is this a cross-platform bug?

Does it also happen on Windows and/or Linux?

(I assume, without knowing for sure, that Windows and Linux have system-level "cursor size" settings.)
> So ... is this a cross-platform bug?

If so I'll have to give it up.  I've got too much other Mac-specific stuff to work on.

Comment 10

5 years ago
I believe it's a cross-platform bug. See also bug 557754.

Comment 11

5 years ago
Also bug 753708, which looks like an exact duplicate of this one.

Comment 12

5 years ago
(In reply to Steven Michaud from comment #9)
> So ... is this a cross-platform bug?

Yes, look at https://bugzilla.mozilla.org/show_bug.cgi?id=296191
This was already reported 2005-06-01 (!) and for Windows, too.
Assignee: smichaud → nobody

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 557754
You need to log in before you can comment on or make changes to this bug.