Closed Bug 835766 Opened 8 years ago Closed 5 years ago

Resuming from hibernate/sleep mode causes problems working with folders, eg saving drafts fails, junk mail not going to Junk folder. Only soved by restarting Thunderbird

Categories

(Thunderbird :: Folder and Message Lists, defect)

17 Branch
x86_64
Windows 7
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: davrot, Unassigned)

Details

(Whiteboard: [dupeme?])

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.19 (KHTML, like Gecko) Chrome/25.0.1323.1 Safari/537.19

Steps to reproduce:

Windows 7 64Bit (german) is send into hibernation mode with Thunderbird 17.0.2 still running. Later the computer returns from hibernation and work is resumed with the running Thunderbird session. 


Actual results:

After returning from hibernation it is not possible to save any drafts (new ones as well as existing ones; the save message window does not go away) locally or to the IMAP draft folder. And the automatic junk sorting (Junk identification works fine) into the junk folder stops working. After restarting Thunderbird, both is working again. 


Expected results:

The hibernation shouldn't have any effect...
OS: Linux → Windows 7
so after resume from hibernate
- new messages come in?
- junk messages get marked junk but do not move to junk folder?

does the following correct this problem
1. file | offline | work offline
2. file | offline | work offline
(#2 should put you online)

I think bug 508263 is perhaps the last bug that fixed something in this area
(In reply to Wayne Mery (:wsmwk) from comment #1)
> so after resume from hibernate
> - new messages come in?
Yep.
> - junk messages get marked junk but do not move to junk folder?
Yep.
 
> does the following correct this problem
> 1. file | offline | work offline
> 2. file | offline | work offline
> (#2 should put you online)

No, this doesn't help. :-( The only thing that works is to end Thunderbird before hibernation and to start it, after resuming from hibernation, again. Or to close it and open it again when it is jammed. (But before restarting Thunderbird, it is necessary to wait a moment until everything from Thunderbird is removed from the memory. Or has there something to timeout? In the case when I am too fast with restarting it, the problem remains.). On this computer (which is a HP EliteBook 2760p), it is a perfectly reproducible problem. BTW, this Thunderbird is often switched beween Online/Offline mode on this notebook due to its mobile use.
xref bug 750071

22.0a1 (2013-04-01)
This morning I encountered similar situation, after resume from sleep
- junk marks message as junk and as read, but does not move message to junk folder
- delete marks message as read, but does not move message to trash folder
- attempted to compose new message - it stalled on attempting to copy message to sent folder
- attempts to copy or move mail to any folder fails (except I forgot to test copying to inbox)

interesting though is:
- pretty sure I was able to get new mail

In short, I had to restart thunderbird. Anything not involving moving message to Inbox fail.  Although, silly me, I did not try to manually copy a message from any folder to Inbox. Nor did I check about:memory to see what folders were open. 

No protocol log. but I have a minidump. And the following from console log and windbg


2013-04-08 19:15:33	gloda.index_msg	ERROR	Problem entering folder: aux, skipping. Error was: undefined:634: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgFolder.msgDatabase]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource:///modules/gloda/index_msg.js :: gloda_index_indexerEnterFolder :: line 634"  data: no]


Timestamp: 4/8/2013 10:29:29 PM
Error: [Exception... "'Component is not available' when calling method: [nsIActivityManager::removeActivity]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: resource:///modules/activity/autosync.js :: <TOP_LEVEL> :: line 203"  data: no]
Source File: resource:///modules/activity/autosync.js
Line: 203

Timestamp: 4/8/2013 10:29:42 PM
Error: 2013-04-08 22:29:42	autosyncActivities	ERROR	OnDownloadError: Inbox of wayne.mery@gmail.com


Source File: resource:///modules/gloda/log4moz.js
Line: 688

Timestamp: 4/9/2013 7:00:18 AM
Warning: WARN addons.updates: HTTP Request failed for an unknown reason
Source File: resource://gre/modules/AddonUpdateChecker.jsm
Line: 515


Timestamp: 4/9/2013 7:29:22 AM
Error: DEPRECATION WARNING: Search service falling back to deprecated synchronous initializer.
You may find more details about this deprecation at: https://developer.mozilla.org/en-US/docs/XPCOM_Interface_Reference/nsIBrowserSearchService#async_warning
resource://gre/components/nsSearchService.js 3825 epsSyncInit
resource://gre/components/nsSearchService.js 2588 SRCH_SVC__ensureInitialized
resource://gre/components/nsSearchService.js 3567 null
chrome://messenger/content/webSearch.xml 42 _adjustAcItem
chrome://messenger/content/webSearch.xml 22 
null 0 null

Source File: resource://gre/modules/Deprecated.jsm
Line: 79

Timestamp: 4/9/2013 7:33:12 AM
Error: [Exception... "'Component is not available' when calling method: [nsIActivityManager::removeActivity]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: resource:///modules/activity/autosync.js :: <TOP_LEVEL> :: line 203"  data: no]
Source File: resource:///modules/activity/autosync.js
Line: 203

0:039> g
[JavaScript Error: "TypeError: hdr.folder.GetOfflineMsgFolder(...) is null" {file: "chrome://gmailbuttons/content/gmailbuttonsOverlay.js" line: 665}]
[JavaScript Error: "TypeError: hdr.folder.GetOfflineMsgFolder(...) is null" {file: "chrome://gmailbuttons/content/gmailbuttonsOverlay.js" line: 665}]
[JavaScript Error: "TypeError: hdr.folder.GetOfflineMsgFolder(...) is null" {file: "chrome://gmailbuttons/content/gmailbuttonsOverlay.js" line: 665}]
[JavaScript Error: "TypeError: hdr.folder.GetOfflineMsgFolder(...) is null" {file: "chrome://gmailbuttons/content/gmailbuttonsOverlay.js" line: 665}]
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted
Summary: Hibernate mode causes problems with saving drafts and sorting junk → Resuming from hibernate/sleep mode causes problems working with folders, eg saving drafts and junk not going to junk folder
Whiteboard: [dupeme?]
David, do you still see this problem?
Flags: needinfo?(davrot)
David,
Since 2013 much has changed with regard to hibernate and networking.
On win7 I've not been seeing any problem.
Whiteboard: [dupeme?] → [closeme 2015-10-20][dupeme?]
David seems to be gone. I do a ton of hibertnate/sleep and all WFM here.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(davrot)
Keywords: qawanted
Resolution: --- → WORKSFORME
Summary: Resuming from hibernate/sleep mode causes problems working with folders, eg saving drafts and junk not going to junk folder → Resuming from hibernate/sleep mode causes problems working with folders, eg saving drafts fails, junk mail not going to Junk folder. Only soved by restarting Thunderbird
Whiteboard: [closeme 2015-10-20][dupeme?] → [dupeme?]
You need to log in before you can comment on or make changes to this bug.