Closed Bug 836009 Opened 8 years ago Closed 8 years ago

Work - Integrate tab strip into the Firefox Start Page

Categories

(Firefox for Metro Graveyard :: Browser, defect)

All
Windows 8.1
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: fryn, Unassigned)

References

Details

Aside from edge cases that we might have to address, display the tabs only as part of the Firefox Start screen (accessible via the "plus" button) to solidify the Firefox Start screen as the way to navigate places regardless of whether they are currently open in a tab.

On new platforms, particularly mobile, the concept of something being open -- open as in launched and running, not as in open source -- and manually managing the open state of things is becoming less and less prominent, so this fits the emerging paradigm of not requiring the user to maintain these states in memory.
I think we should wait until v2 for something this different and this novel.
Blocks: 836007
No longer blocks: 836004
This is actually far less complex than I previously thought.
I think we should try it, since it really is essential for the overlay back and plus buttons to work intuitively. If this is not completely done in a state that people are happy with by the next work week, I will be the first to pull it out completely.
Blocks: 836791
No longer blocks: metrov2planning
Summary: Work? - Display tabs as part of the Firefox Start screen → Work - Integrate tab strip into the Firefox Start Page
Assignee: nobody → fyan
Status: NEW → ASSIGNED
No longer blocks: 836007
Duplicate of this bug: 836004
I talked to Stephen and Yuan extensively during the UX summit, and Stephen proposed a different interaction model that doesn't involve this animation. Since we think his proposal is the best to try first, I'm going to implement that and "wontfix" this bug.

If we later discover that we want this after all, we can reopen it at that time. I'm retaining to the dependency tree for that purpose.
Assignee: fyan → nobody
Blocks: 836007
No longer blocks: 836791
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Depends on: 835628
Resolution: --- → WONTFIX
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.