Story - Junior-style back and new tab overlay buttons

VERIFIED FIXED

Status

defect
P2
normal
VERIFIED FIXED
6 years ago
5 months ago

People

(Reporter: asa, Assigned: fryn)

Tracking

Details

(Whiteboard: feature=story c=firefox_app_bar_and_autocomplete u=metro_firefox_user p=5, )

Attachments

(1 attachment, 2 obsolete attachments)

Reporter

Description

6 years ago
No description provided.
Reporter

Updated

6 years ago
Whiteboard: feature=story c=navigation_app_bar_and_autocomplete u=metro_firefox_user → feature=story c=firefox_app_bar_and_autocomplete u=metro_firefox_user
Whiteboard: feature=story c=firefox_app_bar_and_autocomplete u=metro_firefox_user → feature=story c=firefox_app_bar_and_autocomplete u=metro_firefox_user p=0
Depends on: 836799
Priority: -- → P2
Reporter

Updated

6 years ago
Priority: P2 → --
Summary: Story – Junior-style back and forward navigation → Story – Junior-style back and new tab overlay buttons
Whiteboard: feature=story c=firefox_app_bar_and_autocomplete u=metro_firefox_user p=0 → feature=story c=firefox_app_bar_and_autocomplete u=metro_firefox_user p=2
Reporter

Comment 1

6 years ago
Attachment #708638 - Attachment is obsolete: true
Priority: -- → P2
Reporter

Updated

6 years ago
Summary: Story – Junior-style back and new tab overlay buttons → Story - Junior-style back and new tab overlay buttons
Component: General → Metro Operations
Product: Firefox for Metro → Tracking
Version: unspecified → ---
Assignee

Updated

6 years ago
Assignee: nobody → fyan
Status: NEW → ASSIGNED
Assignee

Comment 2

6 years ago
I received a mockup and some design assets for this from Stephen.
Blocks: metrov1it3
No longer blocks: metrov1backlog
QA Contact: jbecerra
Assignee

Comment 3

6 years ago
Posted patch WIP (obsolete) — Splinter Review
WIP from last Wednesday.
Complete patch coming soon.
Blocks: metrov1backlog
No longer blocks: metrov1it3
Stephen, based on the mockup you posted, how would people go forward?

Since the Back button and fav icon are not connected with the URL field, the Australis conditional back button cannot be applied here.
Blocks: metrov1it3
No longer blocks: metrov1backlog
Flags: needinfo?(shorlander)
Blocks: metrov1backlog
No longer blocks: metrov1it3
Blocks: metrov1it4
No longer blocks: metrov1backlog
Blocks: metrov1it5
No longer blocks: metrov1it4
Flags: needinfo?(shorlander)
Assignee

Updated

6 years ago
Depends on: 859950
Assignee

Updated

6 years ago
Depends on: 859997
Assignee

Updated

6 years ago
Depends on: 860081
Assignee

Updated

6 years ago
Depends on: 860084
Assignee

Comment 5

6 years ago
Comment on attachment 723619 [details] [diff] [review]
WIP

This is obsolete now that I have filed the relevant Work bugs and attached complete patches to several of them.
Attachment #723619 - Attachment is obsolete: true
Assignee

Updated

6 years ago
Depends on: 836007
Assignee

Updated

6 years ago
Depends on: 836009
Assignee

Updated

6 years ago
No longer depends on: 836799
Assignee

Updated

6 years ago
Depends on: 860095
Blocks: metrov1backlog
No longer blocks: metrov1it5
Assignee

Updated

6 years ago
No longer depends on: 860084
Assignee

Updated

6 years ago
No longer depends on: 836007
Assignee

Updated

6 years ago
No longer depends on: 836009
Assignee

Updated

6 years ago
No longer depends on: 860081
Assignee

Comment 6

6 years ago
The essential pieces of this have landed.
I think this is sufficient for closing this story.
We will continue to tweak and improve the interactions here as needed, but they need not keep this story open.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Assignee

Updated

6 years ago
Duplicate of this bug: 855422
Whiteboard: feature=story c=firefox_app_bar_and_autocomplete u=metro_firefox_user p=2 → feature=story c=firefox_app_bar_and_autocomplete u=metro_firefox_user p=0
Assignee

Comment 8

6 years ago
I realize that the history of this story is a bit confusing.
Asa created two duplicate story bugs for this. I duped the other to this one.
I don't think the point value of this bug should be changed to zero. There were substantive work bugs (bug 859950, bug 859997, and bug 860095) and additional work not found on Bugzilla (solidifying the interaction model of the buttons) involved in the completion of this story. If anything, I'd say it ended up being at least a 5.

I took the opportunity to being in the same room as Stephen and Yuan to complete this story as part of iteration 5, so I'm marking this as iteration 5. Please let me know if this is incorrect.
Blocks: metrov1it5
No longer blocks: metrov1backlog
Whiteboard: feature=story c=firefox_app_bar_and_autocomplete u=metro_firefox_user p=0 → feature=story c=firefox_app_bar_and_autocomplete u=metro_firefox_user p=5
Temporarily reopening for inclusion in Iteration #5.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Mozilla/5.0 (Windows NT 6.2; rv:23.0) Gecko/20130414 Firefox/23.0 

Used the Nightly version built from http://hg.mozilla.org/mozilla-central/rev/ef802a6418f2

- back and plus buttons are displayed
- back and plus buttons functional

Issues: invoking the app bar (right click) doesn't make the buttons disappear (as specified in the user story). I think this is tracked in bug 861465.

And one question before setting this to verified: is there a way to access elements overlayed by the two buttons? (e.g www.gsp.ro). The green square is unaccessible.
See question from Virgil in Comment #10.
Flags: needinfo?(fyan)
Assignee

Comment 12

6 years ago
(In reply to Virgil Dicu [:virgil] [QA] from comment #10)
> And one question before setting this to verified: is there a way to access
> elements overlayed by the two buttons? (e.g www.gsp.ro). The green square is
> unaccessible.

Not yet. I forgot to file a followup for it. The current plan is to enable the buttons to be moved via drag / touch. This isn't part of the story as written by Asa, so it's not needed to close this bug, but I'm definitely going to fix it ASAP.
Flags: needinfo?(fyan)
Thanks. Setting to verified considering comment 12.
Status: RESOLVED → VERIFIED
Depends on: 867515
Found a "Defect" when going through the following "Story". Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-04-30-03-09-41-mozilla-central/

- Attached the Defect to this Story.
Depends on: 860081
Went through the following "Story" for iteration #8 testing without any issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-06-10-03-11-47-mozilla-central/

- Went through the original story and ensured the buttons worked as described
- Ensured that both the "Back" and "New Tab" junior style buttons are working when opening websites from either "Top Sites", "Bookmarks" or "Recent History"
- Ensured that both the "Back" and "New Tab" junior style buttons are working when opening a new link using the right click context menu
- Ensured that you can press the "Back" junior style button several times without any issues
- Ensured that all of the above test cases also worked in "Filled View" without any issues

Quick Note:

- As per Comment 10, invoking the app bar does not hide the junior buttons as described in the original story. The issue can be found in Bug 861465
User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:25.0) Gecko/20130707 Firefox/25.0
Build ID: 20130707031138

WFM for iteration-9
Tested on Windows 8.1 preview using latest nightly build from ftp://ftp.mozilla.org/pub/firefox/nightly/2013/07/2013-07-07-03-11-38-mozilla-central/
I used same steps given in user story.
I am getting expected result.
Reporter

Updated

6 years ago
Depends on: 880855
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130826074752
Built from http://hg.mozilla.org/mozilla-central/rev/14b1e8c2957e

WFM
Tested on windows 8 using latest nightly for iteration-12. Followed steps provided in user story and got expected result.
Depends on: 911530
Depends on: 941457
Depends on: 953012
Depends on: 970555
OS: Windows 8 Metro → Windows 8.1

Updated

5 months ago
Product: Tracking → Tracking Graveyard
You need to log in before you can comment on or make changes to this bug.