Marionette actor not getting connected to debugger

VERIFIED FIXED in Firefox 21

Status

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: jgriffin, Assigned: dhylands)

Tracking

({dev-doc-needed})

unspecified
mozilla21
dev-doc-needed
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:tef+, firefox19 wontfix, firefox20 wontfix, firefox21 fixed, b2g18 fixed, b2g18-v1.0.0 fixed, b2g18-v1.0.1 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
There's some problem which is causing the Marionette actor not to get connected to the debugger.  Attempting to send any Marionette message results in:

response {u'message': u'Actor "conn4.1" does not recognize the packet type "getMarionetteID"', u'from': u'root', u'error': u'unrecognizedPacketType'}

There have been no recent changes to Marionette or the debugger that would explain this.  In addition, we only see this error on tests running on unagis and pandas.
(Reporter)

Updated

6 years ago
Blocks: 836745
(Assignee)

Updated

6 years ago
Assignee: nobody → dhylands
(Assignee)

Comment 2

6 years ago
I'm going to propose that if MARIONETTE is enabled, then adb will be always enabled, and disconnected from the remote-debugger setting.

The crux of the problem is that marionette wants adb on, but the remote debugger off.

What this means is that the remote debugger will always default to being off (so more or less reversing the gaia change mentioned in comment 1).

For non-user builds adb will always be on.
For user builds adb will be coupled to the remote debugger setting.
(Assignee)

Comment 3

6 years ago
Nominating for tef? since this blocks bug 836621. Our partners run marionette tests, so they'll need/want this.
Blocks: 836621
blocking-b2g: --- → tef?
We do automated testing on -userdebug fyi.
(Assignee)

Updated

6 years ago
Depends on: 837001
(Assignee)

Updated

6 years ago
Blocks: 837001
No longer depends on: 837001
(Assignee)

Comment 5

6 years ago
Created attachment 708903 [details] [diff] [review]
Forces adb to be on when marionette is enabled (i.e. non-user builds)

This forces adb to be on when marionette is enabled (marionette requires that the remote-debugger be disabled).
Attachment #708903 - Flags: review?(fabrice)
Attachment #708903 - Flags: review?(fabrice) → review+
https://hg.mozilla.org/mozilla-central/rev/c46098d2964c
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
Blocks another tef+ blocker.
blocking-b2g: tef? → tef+
status-b2g18: --- → affected
status-b2g18-v1.0.0: --- → affected
(Assignee)

Updated

6 years ago
Depends on: 836770
https://hg.mozilla.org/releases/mozilla-b2g18/rev/c6ef8bcf0b8d
https://hg.mozilla.org/releases/mozilla-b2g18_v1_0_0/rev/b21f703f1db1
status-b2g18: affected → fixed
status-b2g18-v1.0.0: affected → fixed
status-firefox19: --- → wontfix
status-firefox20: --- → wontfix
status-firefox21: --- → fixed
(Assignee)

Comment 10

6 years ago
dev-doc-needed is to document the fact that adb is always on for non-user builds (i.e. eng and userdebug) and for user (i.e. production/dogfooding) builds adb is controlled via the remote- debugger setting.
Keywords: dev-doc-needed
Verified FIXED; our builds are back and running fine with the fix, thanks!
Status: RESOLVED → VERIFIED
status-b2g18-v1.0.1: --- → fixed
You need to log in before you can comment on or make changes to this bug.