Closed Bug 837001 Opened 7 years ago Closed 7 years ago

Disable remote debugger by default

Categories

(Firefox OS Graveyard :: Gaia, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:tef+, b2g18 fixed, b2g18-v1.0.0 fixed)

VERIFIED FIXED
blocking-b2g tef+
Tracking Status
b2g18 --- fixed
b2g18-v1.0.0 --- fixed

People

(Reporter: dhylands, Assigned: dhylands)

References

Details

Attachments

(1 file)

So it turns out that Marionette needs remote-debugging to be disabled and adb to be enabled.

So when bug 836103 coupled them together, it wound up breaking marionette.

Marionette is enabled for non-user builds.
We want remote-debugging disabled by default for user builds.

So that means that remote-debugging should be disabled by default.

Bug 836973 will change the adb coupling so that adb is only coupled to the remote debugger setting in user builds, and adb will be always on when Marionette is enabled.

This bug was filed separately from bug 836973 because it affects the gaia component. Bug 836973 affects the gecko component.
We should land bug 836973 to the gecko component and branches before landing this bug to gaia.

If this bug lands before 836973 then adb will wind up being permanently off.
No longer blocks: 836973
Depends on: 836973
NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):

We want remote debugging disabled for user builds.
We want remote debugging disabled for marionette builds (non-user builds).

So disable remote debugging by default.
Attachment #708905 - Flags: review?(fabrice)
Attachment #708905 - Flags: approval-gaia-v1?(21)
Attachment #708905 - Flags: review?(fabrice) → review+
Blocking, so go ahead and uplift to v1-train and v1.0.0 when ready.
blocking-b2g: tef? → tef+
Marionette works again with this patch (along with other related patches which have already landed).
https://github.com/mozilla-b2g/gaia/commit/b8b3de7cec0c3975066bdae067c861d1863b032a
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
v1-train: 3c91c12c977753b2f6e936a41e2e8f7576103283
v1.0.0: b9b9c734744c2ca2143e8255c538bac6c1d31846
Verified as fixed.
Remote debugger is disabled by default.
Unagi device, (nightly) build 20130215070202
Dec 5th Kernel
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/a9e4f8912607
Gaia   21ba59d933c66024cb351c2379315301d5352e0c
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.