Firefox hangs when Java Deployment Toolkit is enabled and Java is disabled in browsers with Windows Control Panel

RESOLVED FIXED

Status

defect
--
critical
RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: bugzreportr, Unassigned)

Tracking

({hang})

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130116073211

Steps to reproduce:

I tried to check if the plugins are up-to-date in about:addons (Tools > Add-ons) and then clicked the "Check to see if your plugins are up to date". After 5-6 seconds Firefox crashes because of Java is disabled from Control Panel.


Actual results:

Firefox stopped working and i had to kill the process.


Expected results:

Skip the plugin if possible.
Crashing means closing unexpectedly while hanging means stopping responding.

Does it happen in Safe Mode (see https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode)?
Severity: normal → critical
Flags: needinfo?(bugzreportr)
Keywords: hang
(In reply to Scoobidiver from comment #1)
> Crashing means closing unexpectedly while hanging means stopping responding.
> 
> Does it happen in Safe Mode (see
> https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode)?

I'm sorry to be confusing about hanging and crashing. 
To answer your question: 
 Yes, I just run Firefox in Safe Mode and it does the same thing. It stops responding.
Flags: needinfo?(bugzreportr)
Maybe your profile is corrupted. Does it happen with a new profile (see https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles)?
How did you disable Java in Windows Control Panel?
Please also attach your about:plugins page to this bug.
Flags: needinfo?(bugzreportr)
OK, to clear it up as much as I can:

Java is disabled in the browser. [img: http://i45.tinypic.com/rhon5s.png ]
Java is updated: [img: http://i48.tinypic.com/of2bfl.png ]
(but it doesn't matter what version of java is installed)

Plugins http://i49.tinypic.com/zvqwiw.png

My profile isn't corrupted. If I use java (enabled it browsers) there is no bug, no hang, no nothing. It does what it supposed to do, that is, check if the plugins are up-to-date.
Flags: needinfo?(bugzreportr)
(In reply to bugzreportr from comment #4)
> My profile isn't corrupted.
Please try the new profile to confirm. Indeed, you can have a corrupted profile without any visible symptoms.
Flags: needinfo?(bugzreportr)
(In reply to Scoobidiver from comment #5)

> Please try the new profile to confirm. Indeed, you can have a corrupted
> profile without any visible symptoms.

I just created a new profile, same bug, hangs until I close it.
Flags: needinfo?(bugzreportr)
My thoughts on this:

Firefox loads the plugins and the java-script code (@ /js/plugincheck.js) tries to get the version of Java, but since JAVA is disabled and not loaded in browser, Firefox just tries and tries (loop).

One way is to check if JAVA is enabled and do the version test on it, else, just skip it.
Let's consider it's not a realistic testcase and classify it in the plugincheck component instead of the JavaScript component.
Blocks: 821279
Status: UNCONFIRMED → NEW
Component: Untriaged → plugins.mozilla.org
Ever confirmed: true
Product: Firefox → Websites
QA Contact: cbook
Version: 18 Branch → unspecified
do we have btw a crash report id ?
(In reply to Carsten Book [:Tomcat] from comment #9)
> do we have btw a crash report id ?
There is no hang id.
Summary: Firefox crashes when the plugins are checked and java is disabled → Firefox hangs when the plugins are checked and java is disabled
I can reproduce if Java Deployment Toolkit is enabled but I can't with Java Platform enabled.
Summary: Firefox hangs when the plugins are checked and java is disabled → Firefox hangs when Java Deployment Toolkit is enabled and Java is disabled in browsers with Windows Control Panel
Duplicate of this bug: 839920
Easy to reproduce this bug:

- any Windows (checked with XP 64 Bit Pro and 7 64 Bit Pro)
- install the latest Java JRE 7 Update 13
- enter the Windows Control Panel and disable the Java browser plug-in
- reboot your system
- start Firefox 18.0.2 and head for http://www.java.com/de/download/testjava.jsp
- if the Java plug-in is still enabled in Firefox it will hang now
- the same happens while opening other websites with Java content

I've checked Chrome and Opera too. With these browsers Java just won't run (and Oracle's website will tell you it's not enabled). No hangs. Looks like the fox has a bug.
Update: Firefox 19.0 final hangs too...
Duplicate of this bug: 848711
Update: Firefox 20.0 hangs too.
(In reply to bugzreportr from comment #0)
> User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101
> Firefox/18.0
> Build ID: 20130116073211
> 
> Steps to reproduce:
> 
> I tried to check if the plugins are up-to-date in about:addons (Tools >
> Add-ons) and then clicked the "Check to see if your plugins are up to date".
> After 5-6 seconds Firefox crashes because of Java is disabled from Control
> Panel.
> 
> 
> Actual results:
> 
> Firefox stopped working and i had to kill the process.
> 
> 
> Expected results:
> 
> Skip the plugin if possible.

Why do you have it disable in Control panel?  That just does not make sense to me unless that is of course you are not going to use the Toolkit.
How about using Mozilla Firefox 17.0.9 ESR and see if the bug pops up there.  I am having no trouble on my end with this version and the Java Development Toolkit being disabled.  I have Java 7 Update 45.  I also have Windows NT 6.1 64 bit version.
my videos wont play says i need a plugin but the java deployment toolkit is not not activated how can i by pass this java deployment toolkit ? is there another program that can run my videos
(In reply to onevoicecry@yahoo.com from comment #19)
> my videos wont play says i need a plugin but the java deployment toolkit is
> not not activated how can i by pass this java deployment toolkit ? is there
> another program that can run my videos

Which videos are you trying to play? What format? You should not need Java for that at all. If the site/browser is telling you need a plugin, it is most like the Flash plugin.
there is only one website it is not working the  site is  almost totally run on java but it wont let me install a plugin and my computer says  my flash player is up to date
The latest Java Runtime is 7 Update 45.  Have you removed all previous versions of Java including 6 and earlier.  What Operating System are you running?  What Browser and If Firefox what version of Mozilla Firefox are you running?  Please let us help you by you giving more details about your computer.  Finally, if you feel comfortable let us know the site you are trying to reach but if you don't want to tell us that it can be personal and I understand.
(In reply to onevoicecry@yahoo.com from comment #19)
> my videos wont play says i need a plugin but the java deployment toolkit is
> not not activated how can i by pass this java deployment toolkit ? is there
> another program that can run my videos

I believe your problem is not related to this bug, if you are still experiencing the problem, please see https://bugzilla.mozilla.org/show_bug.cgi?id=990947
(In reply to bugzreportr from comment #0)
> User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101
> Firefox/18.0
> Build ID: 20130116073211
> 
> Steps to reproduce:
> 
> I tried to check if the plugins are up-to-date in about:addons (Tools >
> Add-ons) and then clicked the "Check to see if your plugins are up to date".
> After 5-6 seconds Firefox crashes because of Java is disabled from Control
> Panel.
> 
> 
> Actual results:
> 
> Firefox stopped working and i had to kill the process.
> 
> 
> Expected results:
> 
> Skip the plugin if possible.

bugzreportr, are you still experiencing this problem? If so, which version of Fx are you currently running? Thanks
Flags: needinfo?(bugzreportr)
No longer blocks: 821279
There has been a bunch of new releases of plugincheck and a lot of testing along with this, some of it specifically focused on Java. From all of this, no one has run into this problem so, I am going to close this one as resolved fixed.

If anyone still experience this problem, please feel free to reopen and let me know the details of the problem.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(bugzreportr)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.