Closed Bug 838354 Opened 7 years ago Closed 7 years ago

Remove all capture button reference from nsFileControlFrame

Categories

(Core :: Layout: Form Controls, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla22

People

(Reporter: mounir, Assigned: mounir)

References

Details

Attachments

(1 file)

Attached patch PatchSplinter Review
We do no longer use that. We can just put it into the trash.
Attachment #710405 - Flags: review?(bzbarsky)
Comment on attachment 710405 [details] [diff] [review]
Patch

r=me, but does that mean we can remove the relevant mobile/xul code too?
Attachment #710405 - Flags: review?(bzbarsky) → review+
(In reply to Boris Zbarsky (:bz) from comment #1)
> Comment on attachment 710405 [details] [diff] [review]
> Patch
> 
> r=me, but does that mean we can remove the relevant mobile/xul code too?

We indeed *can* but I consider that code dead so we can also just ignores it. FWIW, the capture was used in mobile/android/ but has been replaced by some proper Android Intent calls roughly a year ago.
Blocks: 838675
Flags: in-testsuite-
Duplicate of this bug: 853475
Comment on attachment 710405 [details] [diff] [review]
Patch

Review of attachment 710405 [details] [diff] [review]:
-----------------------------------------------------------------

Duplicate bug 853475 has a less-bitrotted version of this patch.  Feel free to steal it if it is helpful.  Or see comments below (if they are not addressed by other patches in your queue).

::: layout/forms/Makefile.in
@@ -17,2 @@
>  MODULE		= layout
>  XPIDL_MODULE	= layout_forms

Since this module no longer has any XPIDL files, you can remove XPIDL_MODULE from moz.build and from any package-manifest.in files.

::: layout/forms/nsFileControlFrame.cpp
@@ -45,1 @@
>  #include "nsIFileURL.h"

nsIFileURL.h is no longer used here.

@@ -316,5 @@
> -
> -  // Get Loc title
> -  nsXPIDLString title;
> -  nsContentUtils::GetLocalizedString(nsContentUtils::eFORMS_PROPERTIES,
> -                                     "MediaUpload", title);

Since you are removing this string, you should also remove it from dom/locales/en-US/chrome/layout/HtmlForm.properties.
(In reply to Matt Brubeck (:mbrubeck) from comment #4)
> Comment on attachment 710405 [details] [diff] [review]
> Patch
> 
> Review of attachment 710405 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Duplicate bug 853475 has a less-bitrotted version of this patch.  Feel free
> to steal it if it is helpful.  Or see comments below (if they are not
> addressed by other patches in your queue).
> 
> ::: layout/forms/Makefile.in
> @@ -17,2 @@
> >  MODULE		= layout
> >  XPIDL_MODULE	= layout_forms
> 
> Since this module no longer has any XPIDL files, you can remove XPIDL_MODULE
> from moz.build and from any package-manifest.in files.

That was already done because it wasn't building without this.

> ::: layout/forms/nsFileControlFrame.cpp
> @@ -45,1 @@
> >  #include "nsIFileURL.h"
> 
> nsIFileURL.h is no longer used here.
> 
> @@ -316,5 @@
> > -
> > -  // Get Loc title
> > -  nsXPIDLString title;
> > -  nsContentUtils::GetLocalizedString(nsContentUtils::eFORMS_PROPERTIES,
> > -                                     "MediaUpload", title);
> 
> Since you are removing this string, you should also remove it from
> dom/locales/en-US/chrome/layout/HtmlForm.properties.

Fixed those two locally.

Thanks for having a look at the patch :)
Assignee: nobody → mounir
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla22
https://hg.mozilla.org/mozilla-central/rev/603f80648200
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.