Remove unused nsICapturePicker code from /layout/forms

RESOLVED DUPLICATE of bug 838354

Status

()

RESOLVED DUPLICATE of bug 838354
6 years ago
6 years ago

People

(Reporter: mbrubeck, Assigned: mbrubeck)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

6 years ago
Created attachment 727703 [details] [diff] [review]
patch

nsICapturePicker (see bug 567323 for details) is no longer implemented anywhere.  It was originally used in XUL Fennec; we removed the last copies of that code in bug 831236, bug 730289, and bug 795630.

This patch removes the layout code that attempts to use nsICapturePicker.

I couldn't find a string for the "capture" button label -- am I correct in thinking it was never localized?
Attachment #727703 - Flags: review?(jonas)
(Assignee)

Comment 1

6 years ago
Created attachment 727842 [details] [diff] [review]
patch v2

I forgot to remove layout_forms.xpt from the package-manifest files.
Attachment #727703 - Attachment is obsolete: true
Attachment #727703 - Flags: review?(jonas)
Attachment #727842 - Flags: review?(jonas)
(Assignee)

Comment 3

6 years ago
Comment on attachment 727842 [details] [diff] [review]
patch v2

Adding Jim just for the Metro changes -- just a few lines of CSS we missed in bug 795630.
Attachment #727842 - Flags: review?(jmathies)

Comment 4

6 years ago
Comment on attachment 727842 [details] [diff] [review]
patch v2

my bad, I didn't think to look for css when I removed the main parts.
Attachment #727842 - Flags: review?(jmathies) → review+
Sorry Matt, bug 838354 is doing exactly that. It's part of a patch queue that is blocked by a review. Let me know if you need this to land ASAP, I think I could land that patch separately but hopefully the blocker should be resolved soon.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 838354
Attachment #727842 - Flags: review?(jonas)
(Assignee)

Comment 6

6 years ago
No hurry; I was just doing this for cleanup.  I'll land just the Metro part for now.
You need to log in before you can comment on or make changes to this bug.