<input type="image"> has wrong context menu on Win32.

RESOLVED DUPLICATE of bug 77122

Status

()

Core
XUL
P2
normal
RESOLVED DUPLICATE of bug 77122
17 years ago
10 years ago

People

(Reporter: K Chayka, Assigned: Heikki Toivonen (remove -bugzilla when emailing directly))

Tracking

Trunk
mozilla0.9.7
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
win32 talkback build 2001060120, win98se

Go to the above link, or display any other map at the www.mapquest.com site.
Right click on the map image. No context menu displays, so the map (gif) can be
saved, displayed in a separate window, whatever. Like it's not even recognized
as an image. Can right-click/save the map image in Netscape 6 no problem.

Comment 1

17 years ago
Created attachment 36967 [details]
Shows an <input type="image"> which has no context menu

Comment 2

17 years ago
The image is actually an <input type="image"> element rather than a simpler
<img>, which is why the context menu doesn't appear.
The component should probably be HTML form controls.
See my attached testcase.

Comment 3

17 years ago
So, this regressed (context menu stopped coming up at all when over an <input 
type=image>) between 5/25 am and 5/27 am. I put some dump statements in 
nsContextMenu.js, and can see that the setTarget method is being called, so
at least the initial application setup is working. 

[I noticed that either before or after the 25th, .setTarget() is actually
called three times, twice for the <input type=image> and once with a browser
element [which overwrites the value of this.onImage, and means that no image
options are set for the context menu (see bug 77122) and frameset options are
set]].

Giving this to dr for now. Can you just see which side of the line the 
problem lies (app logic or something with the popup or events). There may be 
some interest in fixing this from Netscape's point of view, since this is 
MapQuest.
Assignee: pinkerton → dr
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: mozilla0.9.2

Updated

17 years ago
Blocks: 77122

Comment 4

17 years ago
linux cvs from yesterday, this works (both the url and testcase)

Comment 5

17 years ago
worksforme too. is there anybody with an up to date tree for whom this still
doesn't work?

Comment 6

17 years ago
Yeah, me. Doesn't work on win32. But, whatever. Minor platform.

Comment 7

17 years ago
So this is windows-only, eh... Ok, 0.9.3. I guess we can see if this can make it
into 0.9.2 when the time comes.
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → mozilla0.9.3

Updated

17 years ago
Priority: P1 → P2

Updated

17 years ago
Summary: can't save mapquest map image - no context menu → [win32] no context menu for <input type=image>

Updated

17 years ago
Summary: [win32] no context menu for <input type=image> → [win32] can't save mapquest map - no context menu for <input type=image>

Updated

17 years ago
Keywords: nsBranch
Summary: [win32] can't save mapquest map - no context menu for <input type=image> → <input type="image"> has no context menu on Win32.

Updated

17 years ago
Target Milestone: mozilla0.9.3 → mozilla0.9.4

Comment 8

17 years ago
[spam] -> 0.9.5
Target Milestone: mozilla0.9.4 → mozilla0.9.5

Comment 9

17 years ago
[spam] dr@netscape.com's bugs subject to redistribution by chofmann. R!
Assignee: dr → chofmann
Status: ASSIGNED → NEW
Priority: P2 → --
Target Milestone: mozilla0.9.5 → ---
Lemme have a look, I fixed some other context menus bugs just recently...
Assignee: chofmann → heikki
Priority: -- → P2
Target Milestone: --- → mozilla0.9.5
Target Milestone: mozilla0.9.5 → mozilla0.9.6

Comment 11

17 years ago
*** Bug 104100 has been marked as a duplicate of this bug. ***

Comment 12

17 years ago
Okay, the context menu shows in current builds on windows, but the items in 
the menu are wrong (e.g., says 'Open frame in new window', 'Show Frame Source'
for the testcase attachment 36967 [details], and does not offer, e.g., 'Copy Link 
Location').

So strange that this is only on windows, though. [Linux/Mac are OK.]
Keywords: mozilla0.9.2
Summary: <input type="image"> has no context menu on Win32. → <input type="image"> has wrong context menu on Win32.
Target Milestone: mozilla0.9.6 → mozilla0.9.7
This is now just a duplicate of bug 77122, no?

Comment 14

16 years ago
I suppose it is a duplicate, but perhaps heikki has an idea of what is wrong
here
Yeah, sure does look like a dupe.

I looked all the places that used to be the cause of problems with context menus
(as far as I could tell) but did not find anything that could cause this bug.

*** This bug has been marked as a duplicate of 77122 ***
No longer blocks: 77122
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.