[MMS][User Story] New message notification when auto-download disabled

RESOLVED DUPLICATE of bug 840090

Status

P1
normal
RESOLVED DUPLICATE of bug 840090
6 years ago
5 years ago

People

(Reporter: pdol, Assigned: steveck)

Tracking

({feature})

unspecified
ARM
Gonk (Firefox OS)
feature
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

(Whiteboard: [LOE:L][NO_UPLIFT])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
UCID: Messages-041

User Story:
As a user I will be notified that I have content waiting for download if I have received an MMS notification and have disabled auto-downloads of MMS messages so I am aware of the new content and can take action as I see fit.
Depends on: 760065
Assignee: nobody → boaz
Assignee: boaz → schung

Updated

6 years ago
Whiteboard: u=user c=messaging s=v1.1-sprint-3
Gaia: LOE: S
Gecko: bug 760065, LOE: L
Whiteboard: u=user c=messaging s=v1.1-sprint-3 → u=user c=messaging s=v1.1-sprint-3 [LOE:L]

Updated

6 years ago
Depends on: 846008

Updated

6 years ago
Whiteboard: u=user c=messaging s=v1.1-sprint-3 [LOE:L] → [LOE:L]
depends on DOM API
Whiteboard: [LOE:L] → [LOE:L] [3/11~3/15]

Comment 3

6 years ago
Gene will create a Bugzilla case for the API, for this case and also for bug 840090.
Depends on: 849741
Depends on: 849742
No longer depends on: 849742
Blocks: 849867
Per partner and release-driver discussions, marking blocking- until all MMS functionality in bug 849867 is complete, allowing it all to be uplifted at once to avoid SMS bustage.
blocking-b2g: leo+ → -
Whiteboard: [LOE:L] [3/11~3/15] → [LOE:L] [target 3/22]
Depends on: 850680
Depends on: 853376
No longer depends on: 853376

Updated

6 years ago
Flags: in-moztrap?
(Assignee)

Comment 5

6 years ago
Hi Ayman, when message app auto-download status is disabled, carrier will send a notification to receiver with content like that:"You have 1 MMS message...., please click here to download the message". When download button clicked, user will receive actuall mms message from sender. I haven't seen any related topic in the wireframe. Could you please update the flow about message notification part? Thanks.
Flags: needinfo?(aymanmaat)
Flags: needinfo?(hi.jorgejuanp)
leo+ as this is a part of MMS. No_UPLIFT for now before the whole MMS is completed
blocking-b2g: - → leo+
Whiteboard: [LOE:L] [target 3/22] → [LOE:L] [target 3/22] NO_UPLIFT
Whiteboard: [LOE:L] [target 3/22] NO_UPLIFT → [LOE:L] [NO_UPLIFT]
Depends on: 844431
No longer depends on: 760065

Comment 7

5 years ago
moztrap #6768
Flags: in-moztrap? → in-moztrap+
Depends on: 840076

Comment 8

5 years ago
This should probably be updated to also display the error state / retry when NOT on automatic download.

Since I'm having some issues with not-downloaded, I'd really like to work on this ticket, can you transfer owner Steve?

Comment 9

5 years ago
(In reply to Steve Chung from comment #5)
> Hi Ayman, when message app auto-download status is disabled, carrier will
> send a notification to receiver with content like that:"You have 1 MMS
> message...., please click here to download the message". When download
> button clicked, user will receive actuall mms message from sender. I haven't
> seen any related topic in the wireframe. Could you please update the flow
> about message notification part? Thanks.

Hi Steve

page 39 of wireframes attached to this bug addresses this. please feel free to ping me if more clarity is required.
Flags: needinfo?(aymanmaat)

Comment 10

5 years ago
Created attachment 741245 [details]
HTML5_SMS-MMSUserStorySpecifications_20130418_V5.0
Flags: needinfo?(hi.jorgejuanp)
Whiteboard: [LOE:L] [NO_UPLIFT] → [LOE:L]

Updated

5 years ago
Assignee: schung → gnarf37
No longer depends on: 867440
(Assignee)

Updated

5 years ago
Assignee: gnarf37 → schung
Whiteboard: [LOE:L] → [LOE:L][NO_UPLIFT]
(Assignee)

Comment 11

5 years ago
Hi Ayman, based on the wireframe you provide p.38. The not downloaded notification text should be the same, but wording in wireframe might need some adjustment because the sender could be operator. I use another wording like "Message is not downloaded yet" in 840090 patch. If you could come out a proper string for general case, I will fire another patch for updating l10n string in this bug, thanks.
Flags: needinfo?(aymanmaat)

Comment 12

5 years ago
(In reply to Steve Chung from comment #11)
> Hi Ayman, based on the wireframe you provide p.38. The not downloaded
> notification text should be the same, but wording in wireframe might need
> some adjustment because the sender could be operator. I use another wording
> like "Message is not downloaded yet" in 840090 patch. If you could come out
> a proper string for general case, I will fire another patch for updating
> l10n string in this bug, thanks.

Hi Steve, 
Thanks for flagging to me. 
I am going to pass this to Tyler (copywriter) to give you the string. 
Attaching the latest wireframe pack as well so all the information is available.
Flags: needinfo?(aymanmaat) → needinfo?(tyler.altes)

Comment 13

5 years ago
Created attachment 750342 [details]
HTML5_SMS-MMSUserStorySpecifications_20130503_V8.0

attached as per #comment 12
(Assignee)

Updated

5 years ago
Attachment #741245 - Attachment is obsolete: true
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 840090

Comment 15

5 years ago
As far as I understand, the text in question appears within the message thread to inform the user that they need to download the received message. If that is correct, and based on the wireframes provided by Ayman, I would put:

"MMS pending download.
It will be available until (expiry_date)."
Flags: needinfo?(tyler.altes)
You need to log in before you can comment on or make changes to this bug.