Closed Bug 840090 Opened 9 years ago Closed 9 years ago

[MMS][User Story] New message notification when auto-download enabled

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:leo+, b2g18 verified)

RESOLVED FIXED
blocking-b2g leo+
Tracking Status
b2g18 --- verified

People

(Reporter: pdol, Assigned: steveck)

References

Details

(Keywords: feature, Whiteboard: [LOE:L])

Attachments

(1 file)

UCID: Messages-042

User Story:
As a user who has automatic downloads enabled, I will only be notified of a new MMS message after the entire message has been downloaded to my device to ensure that all content is available for viewing when I read the message.
Assignee: nobody → schung
Whiteboard: [LOE:L]
depends on DOM API
Whiteboard: [LOE:L] → [LOE:L] [3/11~3/15]
No longer depends on: 849742
Per partner and release-driver discussions, marking blocking- until all MMS functionality in bug 849867 is complete, allowing it all to be uplifted at once to avoid SMS bustage.
blocking-b2g: leo+ → -
Whiteboard: [LOE:L] [3/11~3/15] → [LOE:L] [target 3/22]
No longer depends on: 853376
Flags: in-moztrap?
Since the default mms download mode should be "manual", please modify the "ril.mms.retrival_mode" key to "automitic" in settings.py for testing(and delete profile/make reset-gaia for correct key setting). Manual message download require a clear flow for user to retrieve pending message, so manual download ability is not included in this patch and need UX input for the behavior, thanks.
Attachment #730038 - Flags: review?(fbsc)
leo+ as this is a part of MMS. No_UPLIFT for now before the whole MMS is completed
blocking-b2g: - → leo+
Whiteboard: [LOE:L] [target 3/22] → [LOE:L] [target 3/22] NO_UPLIFT
Whiteboard: [LOE:L] [target 3/22] NO_UPLIFT → [LOE:L] [NO_UPLIFT]
Depends on: 844431
No longer depends on: b2g-mms-dom-api
#6542
Flags: in-moztrap? → in-moztrap+
Depends on: 840076
Whiteboard: [LOE:L] [NO_UPLIFT] → [LOE:L]
No longer depends on: 867440
Whiteboard: [LOE:L] → [LOE:L][NO_UPLIFT]
Patch submit in messaging branch: https://github.com/bocoup/gaia/pull/2
Comment on attachment 730038 [details]
Patch for mms message notification(auto-download mode)

stealing the review
Attachment #730038 - Flags: review?(fbsc) → review?(felash)
:julienw,
you're stealing the review cause you're working on it or hoping to work on it?  just wondering...
Faramarz: I actually stole the review _after_ I reviewed on Github ;) So I changed the flag to reflect that I did it. (as I did it just now again)
Comment on attachment 730038 [details]
Patch for mms message notification(auto-download mode)

r=me

thanks !

I'll merge
Attachment #730038 - Flags: review?(felash) → review+
master: 1a9c1626f6525ae54aac61cd458fa4c6e1060231
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Duplicate of this bug: 840087
Whiteboard: [LOE:L][NO_UPLIFT] → [LOE:L]
v1-train: 74c4294
Issue no longer repros on Leo device 
Build ID: 20130809041203
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/45480132106b
Gaia: c9d0901564cf6f50e375ab48e4124b8378a2e246
Platform Version: 18.1
New message notification when auto-download enabled
You need to log in before you can comment on or make changes to this bug.