Closed Bug 840161 Opened 7 years ago Closed 7 years ago

Re-block AMD Radeon HD 6290/6300/6310/6320 for Direct3D 9/DIRECT2D

Categories

(Toolkit :: Blocklist Policy Requests, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: akeybl, Assigned: jorgev)

References

(Blocks 1 open bug)

Details

(Keywords: qawanted, Whiteboard: [gfx])

Let's roll out the blocks in bug 722538 and bug 755974 again - hopefully they impact the crashes in bug 839270 this time.

+++ This bug was initially created as a clone of Bug #790169 +++

The gfx blocklist has proved its inefficiency to prevent crashes caused by bug 772330. The latest ones happened in 10.0.6esr.
Cancel the Direct3D 9/DIRECT2D blocklist for this set of GPUs.
It should be done only for Firefox 19 and re-evaluate later for Firefox 20.
Blocks: 839270
(In reply to Scoobidiver from comment #1)
> It should be done only for Firefox 19 and re-evaluate later for Firefox 20.

Graphics blocks can't be limited by version.
When we blocklisted globally previously, it wasn't to much fanfare. No reason to think twice this time.

Also, to carry over from an email thread:

"I don't think we need to wait for the full gfxinfo review in '838845 – Full Review of GfxInfo and feature Blocklisting', given the fact that we've rolled out these identical blocks in the recent past."
Blocks 271 and 273 have been staged.
Assignee: nobody → anthony.s.hughes
Whoops.
Assignee: anthony.s.hughes → jorge
QA Contact: anthony.s.hughes
Juan, since you have a machine with one of these cards, can you please verify the staged block?
QA Contact: anthony.s.hughes → jbecerra
This has been verified in staging.
(In reply to juan becerra [:juanb] from comment #7)
> This has been verified in staging.

Let's move forward with pushing to production. Thanks all!
The blocks have been added with IDs 278 and 280.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
From the data we have, it's hard to tell if the blocklisting has helped or not, unfortunately.
9803 is present twice in the block:
                      <device>0x9802</device>
                      <device>0x9803</device>
                      <device>0x9803</device>
                      <device>0x9804</device>
                      <device>0x9805</device>
                      <device>0x9806</device>
                      <device>0x9807</device>
(In reply to Scoobidiver from comment #12)
> 9803 is present twice in the block:
>                       <device>0x9802</device>
>                       <device>0x9803</device>
>                       <device>0x9803</device>
>                       <device>0x9804</device>
>                       <device>0x9805</device>
>                       <device>0x9806</device>
>                       <device>0x9807</device>

Yes, that was copied from bug 722538 comment #10 and I didn't notice. Hopefully it's a duplicate and there's nothing missing there. Joe?
Given <https://bugzilla.mozilla.org/show_bug.cgi?id=722538#c6>, it seems like that's just a duplicate and all's well. Sorry!
I have 6310 (iGPU of AMD E-350), and I force layers-acceleration and haven't noticed a crash neither on Firefox 22 (my main browser) nor on current nightly (opened few times a day for testing).

FWIW, I also tried with forced d2d and didn't have crashes. However, d2d degrades performance of our tab animations. Interestingly, other HTML5 stuff, like here: http://www.wab.com/ gain quite a bit from forcing d2d (20fps without d2d, 60fps with forced d2d).

I think we should at least remove the blocking for layers-accel.

This is my about:support info with forced layer accel but unforced (and blacklisted) d2d accel:

Graphics

        Adapter Description
        AMD Radeon HD 6310 Graphics

        Adapter Drivers
        aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64

        Adapter RAM
        384

        Device ID
        0x9802

        Direct2D Enabled
        Blocked for your graphics card because of unresolved driver issues.

        DirectWrite Enabled
        false (6.2.9200.16571)

        Driver Date
        3-28-2013

        Driver Version
        12.104.0.0

        GPU #2 Active
        false

        GPU Accelerated Windows
        1/1 Direct3D 9

        Vendor ID
        0x1002

        WebGL Renderer
        Google Inc. -- ANGLE (AMD Radeon HD 6310 Graphics)

        AzureCanvasBackend
        skia

        AzureContentBackend
        none

        AzureFallbackCanvasBackend
        cairo
Avi, there have been several versions without those crashes but it may spike again at any time because the underlying problem is not fixed. See bug 772330.
Nevertheless, I agree with you. When crashes spike, the blocklist is not efficient. See comment 11 and bug 790169.
Product: addons.mozilla.org → Toolkit
You need to log in before you can comment on or make changes to this bug.