Activities are broken

VERIFIED FIXED in Firefox 21

Status

Core Graveyard
DOM: Apps
--
critical
VERIFIED FIXED
5 years ago
2 months ago

People

(Reporter: cjones, Assigned: fabrice)

Tracking

({regression, smoketest})

unspecified
mozilla21
x86_64
Linux
regression, smoketest
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(blocking-b2g:tef+, firefox19 wontfix, firefox20 wontfix, firefox21 fixed, b2g18 fixed, b2g18-v1.0.0 fixed, b2g18-v1.0.1 fixed)

Details

Attachments

(1 attachment)

STR
 (1) Follow steps in https://wiki.mozilla.org/index.php?title=B2G/Memory_acceptance_criteria#MW2:_Active_call_stays_active

Neither the gallery nor the camera will launch to "Add image".

Sigh.
Can't choose wallpaper either in bug 840145.
Process buster stopped working too.
Severity: normal → critical
Component: General → DOM: Apps
Product: Boot2Gecko → Core
Summary: Can't pick image in contacts app → Activities are broken
Keywords: regression, regressionwindow-wanted
Blocks: 815348
Duplicate of this bug: 840691
Duplicate of this bug: 840145
Works in cb007bcbaaffacf2e8ea93a60cf7c4ccd1164437, broken in fb102153d75ae635dcb96d85e9be248beadeb7fe.
Bisection failed, but bug 838102 has to be it.
Blocks: 838102
(In reply to Chris Jones [:cjones] [:warhammer] from comment #6)
> Bisection failed, but bug 838102 has to be it.

Sounds like we've got our regression window then. That sounds like the right bug.
Keywords: regressionwindow-wanted
(Assignee)

Updated

5 years ago
Assignee: nobody → fabrice
It's bugs like these that remind me why we need mochitests for the apps API. Thankfully, Dale is closing in on getting the hosted app cases checked in and ferjm is hard at work on the packaged app cases.

When we do get the basic framework checked in, let's jump back to this bug later to get a sanity test here.
Flags: in-testsuite?

Updated

5 years ago
Keywords: smoketest
I wonder if bug 839261 could be related to this as well.
(Assignee)

Comment 10

5 years ago
Created attachment 713128 [details] [diff] [review]
patch

Unbreaking my breakage...
Attachment #713128 - Flags: review?(jones.chris.g)
(In reply to Fabrice Desré [:fabrice] from comment #10)
> Created attachment 713128 [details] [diff] [review]
> patch
> 
> Unbreaking my breakage...

tef+ so that this can land today without approval (basically blocking a blocker). If not a forward fix, a=akeybl to back out bug 838102 for tomorrow's build.
blocking-b2g: tef? → tef+
Comment on attachment 713128 [details] [diff] [review]
patch

Not my front yard, but need to fix asap.  Confirmed this fixes the bug.

>diff --git a/dom/apps/src/Webapps.jsm b/dom/apps/src/Webapps.jsm

>+      // Do a copy of the description object since we don't want to modify

"Make a copy"

>       debug('_createActivitiesToRegister: ' + aApp.manifestURL + ', activity ' +
>           activity + ', description.href is ' + href);

newDesc.href, right?
Attachment #713128 - Flags: review?(jones.chris.g) → review+
(Assignee)

Comment 13

5 years ago
https://hg.mozilla.org/releases/mozilla-b2g18/rev/8c6b6a7e02e9
(Assignee)

Comment 14

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/6228ddc49fc2
Oh goodness.  I spent all day bisecting broken activities (for some reason I needed to do it three times before I got the right result), and then I see that you've already fixed it!

Lesson learned: Next time I'll ask on IRC.

Thanks for fixing this.
https://hg.mozilla.org/mozilla-central/rev/6228ddc49fc2
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21

Updated

5 years ago
Keywords: verifyme
QA Contact: jsmith
https://hg.mozilla.org/releases/mozilla-b2g18_v1_0_0/rev/41c97d59dc30
status-b2g18: --- → fixed
status-b2g18-v1.0.0: --- → fixed
status-b2g18-v1.0.1: --- → fixed
status-firefox19: --- → wontfix
status-firefox20: --- → wontfix
status-firefox21: --- → fixed

Comment 18

5 years ago
Verified fixed.

The following tests pass:

1. Both camera and gallery launch and add the image to contact in test steps on wiki:  https://wiki.mozilla.org/index.php?title=B2G/Memory_acceptance_criteria#MW2:_Active_call_stays_active

2. Wallpaper chooser works as described in bug 840145.

3. Create a new contact with first and last name and a mobile phone number, then from that contact attempt to open sms app.

Notes:
Gaia: 07aa79239ced90a7ca0e8da8829fbcb330c42e9f
Gecko:  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/6fec2938ac1e
Build ID: 20130213071150
Status: RESOLVED → VERIFIED

Updated

5 years ago
Keywords: verifyme

Comment 19

5 years ago
This issue reproducing again on Inari Build ID: 20130515070208

Opened a new ticket, Bug 837210

Environmental  Variables:
Kernel Date: Feb 21
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/d06cfe7d67c2
Gaia: 0ddb515f15cbc6b74fc2742b7599d6ae74c6413f

Comment 20

5 years ago
Sorry, its actually bug 873210

Updated

2 months ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.