Toolbar notification icons don't close on second click on OS X

VERIFIED FIXED in Firefox 21

Status

defect
VERIFIED FIXED
6 years ago
4 months ago

People

(Reporter: MattN, Assigned: markh)

Tracking

({regression})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

The problem from bug 789859 now appears on OS X.  This just started recently so I would guess it's caused by bug 811514.

(Quoting Mark Hammond (:markh) from bug 789859 comment #0)
> * Click once in the toolbar notification area - notification opens
> * Click again in the same area:
> 
> ** Expected: The notification area closes and stays closed.
> ** Actual: The notification area closes, then immediately re-opens.
I didn't see this issue on Windows. We can just back out the patch for bug 811514.
(In reply to Jared Wein [:jaws] from comment #1)
> I didn't see this issue on Windows. We can just back out the patch for bug
> 811514.

Why wouldn't we just fix this for all platforms? I agree with bug 811514 that the panels shouldn't consume outside clicks.
Assignee

Comment 3

6 years ago
I could repro this on linux, and it seems the problem is that we now set consumeoutsideclicks="false" - nsMenuPopupFrame has code that explicitly checks for "false" whereas the lack of an attribute causes it to attempt to "do the right thing" - and the right thing seems to be done as removing the attribute fixes the problem for me on Linux.

Is anyone able to confirm this trivial patch solves the problem on Mac?
Flags: needinfo?
(In reply to Mark Hammond (:markh) from comment #3)
> Is anyone able to confirm this trivial patch solves the problem on Mac?

WFM. r=me if you want it.
Flags: needinfo?
Assignee

Comment 5

6 years ago
Comment on attachment 713805 [details] [diff] [review]
Remove the attribute entirely

Taking r+ from MattN

https://hg.mozilla.org/integration/mozilla-inbound/rev/6df7745580ff
Attachment #713805 - Flags: review+
Assignee

Updated

6 years ago
Assignee: nobody → mhammond
https://hg.mozilla.org/mozilla-central/rev/6df7745580ff
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
I've not seen this for a while, marking verified fixed.
Status: RESOLVED → VERIFIED

Updated

4 months ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.