Closed Bug 840948 Opened 7 years ago Closed 7 years ago

mozilla-central Win64 builds are failing with "Invalid command: ${ResetWin8PromptKeys}"

Categories

(Firefox for Metro Graveyard :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: emorley, Assigned: jimm)

References

Details

Attachments

(1 file)

Current mozilla-central tip is:
https://tbpl.mozilla.org/?noignore=1&rev=84cb7aa96a52

Which is all green (for builds) apart from Win64, which is burning seemingly due to:
https://tbpl.mozilla.org/php/getParsedLog.php?id=19688500&tree=Firefox
{
Invalid command: ${ResetWin8PromptKeys}
Error in script "installer.nsi" on line 286 -- aborting creation process
e:\builds\moz2_slave\m-cen-w64-00000000000000000000\build\toolkit\mozapps\installer\windows\nsis\makensis.mk:45:0: command 'cd instgen && c:/mozilla-build/nsis-2.46u/makensisu-2.46.exe installer.nsi' failed, return code 1
e:\builds\moz2_slave\m-cen-w64-00000000000000000000\build\obj-firefox\browser\installer\windows\Makefile:71:0: command 'C:/mozilla-build/python27/python.exe e:/builds/moz2_slave/m-cen-w64-00000000000000000000/build/build/pymake/pymake/../make.py instgen/setup.exe' failed, return code 2
e:\builds\moz2_slave\m-cen-w64-00000000000000000000\build\obj-firefox\browser\installer\Makefile:152:0: command 'C:/mozilla-build/python27/python.exe e:/builds/moz2_slave/m-cen-w64-00000000000000000000/build/build/pymake/pymake/../make.py -C windows' failed, return code 2
e:\builds\moz2_slave\m-cen-w64-00000000000000000000\build\browser\build.mk:42:0: command 'C:/mozilla-build/python27/python.exe e:/builds/moz2_slave/m-cen-w64-00000000000000000000/build/build/pymake/pymake/../make.py -C browser/installer installer' failed, return code 2
program finished with exit code 2
}

Today's Nightlies are being generated several pushes prior:
https://tbpl.mozilla.org/?noignore=1&rev=161a347bda5b
(which is the last push to have green win64 builds)

In this bug we should fix the Nightly changeset picker script to ignore Win64, and file a followup to fix the Win64 bustage (not urgent, given tier 3).
Attached patch fixSplinter Review
This should fix it, although before I push I'd like to do a local build to confirm. This bug will effect anyone building without --enable-metro.
Assignee: nobody → jmathies
Blocks: elm-merge
Attachment #713358 - Flags: review+
This bug was intended for changing the release engineering "pick a green nightly" changeset (comment 0), but I guess we can morph it, and file another for that.
https://hg.mozilla.org/mozilla-central/rev/b3e65fe37681
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
(In reply to Ed Morley [:edmorley UTC+0] from comment #2)
> This bug was intended for changing the release engineering "pick a green
> nightly" changeset (comment 0), but I guess we can morph it, and file
> another for that.

Sorry, stole your bug. :)
Component: Release Engineering: Automation (General) → General
Product: mozilla.org → Firefox for Metro
QA Contact: catlee
Version: other → Trunk
I already filed on the nightly rev chooser the last time around, bug 835173.
Ah, thanks :-)
Severity: blocker → normal
Depends on: 835173
Summary: mozilla-central nightlies not being generated on tip (likely due to burning hidden win64 builds) → mozilla-central Win64 builds are failing with "Invalid command: ${ResetWin8PromptKeys}"
You need to log in before you can comment on or make changes to this bug.