Closed Bug 842920 Opened 7 years ago Closed 7 years ago

Thunderbird Windows builds are broken due to regression in disable-webRTC

Categories

(Thunderbird :: Build Config, defect)

x86
Windows Vista
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ewong, Assigned: ewong)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #842918 +++

Windows building with --disable-webRTC breaks with the following 
errors:


WMFUtils.obj : error LNK2001: unresolved external symbol _CLSID_CMP3DecMediaObject

WMFUtils.obj : error LNK2001: unresolved external symbol _CLSID_CMSH264DecoderMFT

xul.dll : fatal error LNK1120: 2 unresolved externals
Attachment #715894 - Flags: review?(mbanner)
Pushed to comm-central:
https://hg.mozilla.org/comm-central/rev/3225c78eb19b

Sorry, forgot to push the Suite/ patch to mail/.  This should fix the Windows
builds.
To be honest, I'm not keen on this solution, as it means the functionality is available on different platforms. I'd rather get the core issue fixed as to why --disable-webrtc isn't linking correctly.

Although it looks like even with this patch it isn't linking correctly.
An additional patch in Bug 839031 Comment 22 might help:
"We need link wmcodecdspuuid even if no MOZ_WEBRTC_IN_LIBXUL."
https://tbpl.mozilla.org/php/getParsedLog.php?id=19902340&tree=Thunderbird-Trunk#error0

vp8_impl.obj : error LNK2019: unresolved external symbol _vpx_codec_vp8_cx referenced in function "private: int __thiscall webrtc::VP8EncoderImpl::InitAndSetControlSettings(struct webrtc::VideoCodec const *)" (?InitAndSetControlSettings@VP8EncoderImpl@webrtc@@AAEHPBUVideoCodec@2@@Z)

xul.dll : fatal error LNK1120: 1 unresolved externals

So in m-c http://mxr.mozilla.org/mozilla-central/source/configure.in#5233
We have:

5233 if test -n "$MOZ_WEBRTC"; then
5234     AC_DEFINE(MOZ_WEBRTC)
5235     MOZ_MEDIA=1
5236     MOZ_RAW=1
5237     MOZ_VP8=1
5238     MOZ_VP8_ENCODER=1
5239     MOZ_VP8_ERROR_CONCEALMENT=1

And then in http://mxr.mozilla.org/mozilla-central/source/layout/media/symbols.def.in#42
We have:

42 #ifdef MOZ_VP8_ENCODER
43 vpx_codec_vp8_cx
44 #endif

After this I'm lost.
(In reply to Mark Banner (:standard8) from comment #3)
> To be honest, I'm not keen on this solution, as it means the functionality
> is available on different platforms. I'd rather get the core issue fixed as
> to why --disable-webrtc isn't linking correctly.
> 
> Although it looks like even with this patch it isn't linking correctly.

If you like, I can backout my patches (both on trunk and aurora..)  Aurora
(atm) is WinOpt green..   but anyway.. I was hoping it'd be ok. Just didn't
realize that on top of this bug, there was something else that didn't like
linking. But ignorance isn't an excuse.  ;/
This breaks Windows build of browser for me too.  Worth a separate bug?
(In reply to Honza Bambas (:mayhemer) from comment #7)
> This breaks Windows build of browser for me too.  Worth a separate bug?

If you're talking about Philip's addendum, it'd be Bug 842935.
Please file a new bug on the webrtc disabling issues. Its a core issue and should be fixed anyway.
(In reply to Mark Banner (:standard8) from comment #9)
> Please file a new bug on the webrtc disabling issues. Its a core issue and
> should be fixed anyway.

Should I backout my mail/ patch?  it's more than likely going to 
cause TB to burn on Windows.. with probably the same results as
https://bugzilla.mozilla.org/show_bug.cgi?id=842918#c6.

I backed out the suite/ one and that's exactly what happened.

Or should I just wait until the webrtc disabling issue is fixed before
backing it out?
Flags: needinfo?(mbanner)
I pushed the backout to try:

https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=dee9366f8b1c

If someone does backout that patch,  it needs a clobber.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
I backed this out earlier today:

https://hg.mozilla.org/comm-central/rev/13af57b245bc

I'm currently also investigating about what to do on aurora.
Flags: needinfo?(mbanner)
Attachment #715894 - Flags: review?(mbanner)
You need to log in before you can comment on or make changes to this bug.