Closed Bug 843559 Opened 7 years ago Closed 7 years ago

[Ubuntu] Profiler keyboard shortcut (CTRL+SHIFT+Y) opens Library

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect)

21 Branch
x86
Linux
defect
Not set

Tracking

(firefox20 unaffected, firefox21 affected, firefox22 verified)

VERIFIED FIXED
Firefox 22
Tracking Status
firefox20 --- unaffected
firefox21 --- affected
firefox22 --- verified

People

(Reporter: mihaelav, Assigned: anton)

References

Details

(Keywords: regression)

Attachments

(2 files)

Reproducible on the latest Aurora (BuildID: 20130220042017): Mozilla/5.0 (X11; Linux i686; rv:21.0) Gecko/20130220 Firefox/21.0
Reproducible on the latest Nightly (BuildID: 20130220031126): Mozilla/5.0 (X11; Linux i686; rv:22.0) Gecko/20130220 Firefox/22.0

Steps to reproduce:
1. Open Firefox 
2. Press CTRL+SHIFT+Y

Expected results: Profiler is launched

Actual results: Library is launched

Notes:
1. This issue is Linux only (not reproducible on Win 7 and Mac 10.7.5)
2. This is reproducible ever since the Profiler shortcut was introduced.
3. CTRL+SHIFT+Y is the shortcut for Downloads Manager (since "forever").
Blocks: 830668
Summary: Profiler keyboard shortcut (CTRL+SHIFT+Y) opens Lbrary → [Ubuntu] Profiler keyboard shortcut (CTRL+SHIFT+Y) opens Library
Assignee: nobody → anton
This patch changes the shortcut to Shift-F5. We already use Shift-FN scheme and my manual tests on Windows, Linux and OS X confirmed that the shortcut seems to be unused.
Attachment #726438 - Flags: review?(mihai.sucan)
Attachment #726438 - Flags: review?(dcamp)
Comment on attachment 726438 [details] [diff] [review]
Change Profiler shortcut to Shift-F5

I can't comment on the new keyboard shortcut. It's fine as long as people won't scream at you for the change. :) (keyboard shortcuts tend to cause that)

l10n comment: any time you change a string you also need to rename the string name.

Otherwise r+.
Attachment #726438 - Flags: review?(mihai.sucan) → review+
https://hg.mozilla.org/integration/fx-team/rev/348009ddf96d

> (keyboard shortcuts tend to cause that)

I don't think anyone will be particularly sad about the shortcut change because Profiler is still relatively new.

> l10n comment: any time you change a string you also need to rename the string name.

As for l10n, I talked to Victor (you weren't online) he said that we don't need to change the string name in this case. The whole changing string names is a pretty grey area as far as I can tell from different docs and comments.
Whiteboard: [fixed-in-fx-team]
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/348009ddf96d
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 22
Keywords: regression
Version: Trunk → 21 Branch
Verified that the Shift+F5 shortcut opens the Profiler on latest Firefox 22.0a1 builds across main platforms(Win 7, Mac OS X 10.7 and Ubuntu 12.10).
Could you please land the patch for Firefox 21 - currently Aurora - as well? It should get fixed for that version also before the release.
Status: RESOLVED → VERIFIED
(In reply to Anton Kovalyov (:anton) from comment #3)
> As for l10n, I talked to Victor (you weren't online) he said that we don't
> need to change the string name in this case. The whole changing string names
> is a pretty grey area as far as I can tell from different docs and comments.

Not sure what led to that conclusion - not changing the entity name will mean that localizers that have already localized this string likely won't notice the change, and indeed several haven't:

http://mxr.mozilla.org/l10n-central/search?string=profiler.commandkey
This will ensure that localizers notice the change on trunk.
Attachment #731921 - Flags: review+
Pushed Gavin's followup patch to fx-team: https://hg.mozilla.org/integration/fx-team/rev/0b1907140f8c
Attachment #726438 - Flags: review?(dcamp)
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.