transform:scale(1) on MacOs don't work with <select> and mouse click

VERIFIED FIXED

Status

()

Core
Layout: Form Controls
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Thomas Lütcke, Assigned: tnikkel)

Tracking

({regression})

19 Branch
x86
Mac OS X
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox19 wontfix, firefox20+ verified, firefox21 unaffected, firefox22 unaffected)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Steps to reproduce:

Creating a <select> within a div with a style of "transform:scale(1)"

Actual results:

- The <select> is rendered correctly
- If you click the box it is opened normally
- If you move over an <option> it is highlighted normally
- If you press the enter key, the <option> is selected and the <select> is closed
- If you click an <option> with the mouse nothing happens  => Error

Versions >= 19 for MacOS are NOT working
Versions < 19 for MacOS are working
FF for Windows is working in all Versions
Chrome and Safari are working in all Versions


Expected results:

If you click the <option> it should select the <option> and close the <select>.

Test Case:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
<title>Select Error - Sample page</title>
</head>
<body style="text-align:center;">
	<div style="transform: scale(1)">
		<select>
			<option value="1">Option 1</option>
			<option value="2">Option 2</option>
		</select>	
	</div>
</body>
</html>
Created attachment 716635 [details]
Reporter's testcase
I see the issue in 19 on Mac and in an Aurora build, but it works fine in a nightly.  So presumably this got fixed sometime in the last month.  not sure whether it's something that we can backport easily....
status-firefox22: --- → unaffected
tracking-firefox20: --- → ?
tracking-firefox21: --- → ?
(Assignee)

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

5 years ago
Fixed range
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d8be4bc4fba8&tochange=712eca11a04e
which includes bug 829886 which is what I suspected fixes this.
(Assignee)

Comment 4

5 years ago
Regression range
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a761bfc192b5&tochange=58ebb638a7ea
probably regressed by bug 759993.
Blocks: 759993
Depends on: 829886
(Assignee)

Comment 5

5 years ago
We should probably just up lift bug 829886 to beta, and this bug probably isn't serious enough to get considered for 19 now.
(Assignee)

Comment 6

5 years ago
Bug 829886 is on 21, so 21 should be unaffected.
status-firefox21: --- → unaffected
tracking-firefox21: ? → ---
(Assignee)

Updated

5 years ago
QA Contact: tnikkel

Updated

5 years ago
Keywords: regression
(Assignee)

Updated

5 years ago
Assignee: nobody → tnikkel
QA Contact: tnikkel
(Assignee)

Comment 7

5 years ago
I landed bug 829886 on beta for Firefox 20. I don't think this will get fixed on 19, so I'm tempted to just resolve this bug as fixed because there is nothing else to do.
status-firefox20: --- → fixed
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
status-firefox19: --- → wontfix
tracking-firefox20: ? → +

Updated

5 years ago
Duplicate of this bug: 843569

Updated

5 years ago
Duplicate of this bug: 845561

Comment 10

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20100101 Firefox/20.0

Reproduced with FF 19 beta 5 (Build ID: 20130206083616) by using the test case from comment 1. 
Verified as fixed on FF 20 RC (Build ID: 20130326150557).
Status: RESOLVED → VERIFIED
status-firefox20: fixed → verified
You need to log in before you can comment on or make changes to this bug.