Last Comment Bug 843701 - [es-ES]Library does not open with Ctrl+Shift+B in Firefox19.0
: [es-ES]Library does not open with Ctrl+Shift+B in Firefox19.0
Status: VERIFIED FIXED
:
Product: Mozilla Localizations
Classification: Client Software
Component: es-ES / Spanish (show other bugs)
: unspecified
: All Windows XP
: -- normal (vote)
: ---
Assigned To: Guillermo López :willyaranda (probably SLOW response)
:
:
Mentors:
: 843398 844131 846115 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-21 10:43 PST by Alice0775 White
Modified: 2013-03-20 12:03 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
-
wontfix
+
fixed
+
fixed


Attachments

Description Alice0775 White 2013-02-21 10:43:03 PST
Build Identifier:
http://hg.mozilla.org/releases/mozilla-release/rev/20238b786063
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0 ID:20130215130331

Reported http://forums.mozillazine.org/viewtopic.php?f=38&t=2664983
Ctrl+Shift+B does not open "Library".


In the menu, Marcadores > Mostrar todos los marcadores Ctrl+Mayus.+D",
So I tried, Press Ctrl+Shift+D, then "Bookmark All Tabs" dialog open.


Steps to Reproduce:
1. Attempt to keypress Ctrl+Shift+B
2. Attempt to keypress Ctrl+Shift+D

Actual Results:
Nothing happens at Step 1.
"Bookmark All Tabs" dialog open at Step 2.

Expected Results:
I think "Library" should open at Step 1.

Suspected:
http://hg.mozilla.org/l10n-central/es-ES/rev/3bee60d27aa1
Comment 1 [:rickiees] Ricardo Palomares 2013-02-21 12:24:10 PST
Yes, it is a bug. en-US keeps "b" as the commandkey for Bookmark Manager:

http://hg.mozilla.org/mozilla-central/file/885cde564ff3/browser/locales/en-US/chrome/browser/browser.dtd#l164

Guillermo, your move. :-) I think we should fix it in all three channels.
Comment 2 [:rickiees] Ricardo Palomares 2013-02-21 15:29:12 PST
*** Bug 843398 has been marked as a duplicate of this bug. ***
Comment 3 Guillermo López :willyaranda (probably SLOW response) 2013-02-22 05:32:14 PST
http://hg.mozilla.org/releases/l10n/mozilla-beta/es-ES/rev/54d3922c24f9
http://hg.mozilla.org/l10n-central/es-ES/rev/f01afc967a3b

And Aurora is on the big transplant from central->aurora.

I will verify with tomorrow's nightlies
Comment 4 Alex Keybl [:akeybl] 2013-02-22 12:55:35 PST
Please mark 20/21 as verified when you've tested. Thanks!
Comment 5 Matthias Versen [:Matti] 2013-02-24 07:50:35 PST
*** Bug 844131 has been marked as a duplicate of this bug. ***
Comment 6 [:rickiees] Ricardo Palomares 2013-02-26 10:56:11 PST
Update: Jorge Villalobos has been so kind to write an small extension for Firefox 19 [1] that restores the keyboard shortcut to the original ([Ctrl] + [B]). Those of you using this shortcut very often may want to try it. As the error will be fixed for Firefox 20+, the add-on is marked as compatible only with Firefox 19 and you should uninstall it after April 1st, which is the estimated release date of Firefox 20. Thanks a lot, Jorge! :-)

[1] https://addons.mozilla.org/es/firefox/addon/restaura-atajo-marcadores/
Comment 7 Matthias Versen [:Matti] 2013-02-28 12:39:44 PST
*** Bug 846115 has been marked as a duplicate of this bug. ***
Comment 8 Álvaro G. Vicario 2013-03-01 00:59:21 PST
Jorge's addon doesn't fix the library shortcut at all. After installing it, neither Ctrl+Shift+B nor Ctrl+Shift+D open the library. Additionally, Ctrl+B used to be the bookmark side pane shortcut but the addon associates it "Add to bookmarks".
Comment 9 Jorge Villalobos [:jorgev] 2013-03-01 12:36:16 PST
(In reply to Álvaro G. Vicario from comment #8)
> Jorge's addon doesn't fix the library shortcut at all. After installing it,
> neither Ctrl+Shift+B nor Ctrl+Shift+D open the library. Additionally, Ctrl+B
> used to be the bookmark side pane shortcut but the addon associates it "Add
> to bookmarks".

I misunderstood the requirements for this add-on, so the first version was completely backwards. There's a new version 2.1, which is waiting review that should work correctly.
Comment 10 Sergio 2013-03-01 12:53:02 PST
This plugin works fine, solved the problem in my case.
https://addons.mozilla.org/es/firefox/addon/customizable-shortcuts
Comment 11 [:rickiees] Ricardo Palomares 2013-03-01 13:13:41 PST
(In reply to Jorge Villalobos [:jorgev] from comment #9)
> I misunderstood the requirements for this add-on, so the first version was
> completely backwards. There's a new version 2.1, which is waiting review
> that should work correctly.

I think we're mixing some intended changes with others unintended. es-ES policy is to follow en-US keyboard shortcuts, so I'm trying now different versions of en-US and es-ES in Windows to make a summary that allows us to identify what is wrong and what is right. I'll report back here in half an hour, more or less.
Comment 12 [:rickiees] Ricardo Palomares 2013-03-01 13:30:12 PST
Here is the report:

Firefox 18.0.2 en-US

View -> Sidebar -> Bookmarks | [Ctrl]+[B]
Bookmarks -> Show All Bookmarks | [Ctrl]+[Shift]+[B]
Bookmarks -> Bookmark This Page | [Ctrl]+[D]
Bookmarks -> Bookmark All Tabs  | [Ctrl]+[Shift]+[D]

Firefox 18.0.2 es-ES

Ver -> Panel lateral -> Marcadores | [Ctrl]+[B]
Marcadores -> Mostrar todos los marcadores | [Ctrl]+[Shift]+[B]
Marcadores -> Añadir esta página a marcadores | [Ctrl]+[D]
Marcadores -> Añadir pestañas a marcadores | [Ctrl]+[Shift]+[D]

(so Fx 18.0.2 es-ES matches en-US)

Firefox 19.0 en-US

View -> Sidebar -> Bookmarks | [Ctrl]+[B]
Bookmarks -> Show All Bookmarks | [Ctrl]+[Shift]+[B]
Bookmarks -> Bookmark This Page | [Ctrl]+[D]
Bookmarks -> Bookmark All Tabs  | [Ctrl]+[Shift]+[D]

Firefox 19.0 es-ES

Ver -> Panel lateral -> Marcadores | [Ctrl]+[D]
Marcadores -> Mostrar todos los marcadores | [Ctrl]+[Shift]+[D]
Marcadores -> Añadir esta página a marcadores | [Ctrl]+[D]
Marcadores -> Añadir pestañas a marcadores | [Ctrl]+[Shift]+[D]

(so the difference lies in Sidebar and Bookmark Library shortcuts)

However, I can't see any but just ONE change in L10n DTDs that can affect key shortcuts, so I suspect the same entity is being used for the above two changed keys.

Jorge, do you think this matches your findings and revised add-on?
Comment 13 [:rickiees] Ricardo Palomares 2013-03-01 13:46:22 PST
BTW, the above report is for Windows only. Linux uses different shortcuts. Anyone can report on Mac OS X?
Comment 14 Jorge Villalobos [:jorgev] 2013-03-01 14:25:03 PST
(In reply to Ricardo Palomares from comment #12)
> However, I can't see any but just ONE change in L10n DTDs that can affect
> key shortcuts, so I suspect the same entity is being used for the above two
> changed keys.

Yes, the same entity is used twice: https://mxr.mozilla.org/mozilla-central/search?string=bookmarksCmd.commandkey. It makes sense to keep consistency in the shortcuts.

> Jorge, do you think this matches your findings and revised add-on?

Yes, after I was pointed to this bug, I looked into the patch and the source code to make sure I got it right. When the new version is approved, it will solve the problem correctly.
Comment 15 Ugy 2013-03-01 19:28:17 PST
Please, read my 2 last comments on this bug https://bugzilla.mozilla.org/show_bug.cgi?id=846115

Described the process, manual, to correct the bug in es-ES locale.

It's possible to use in en-US locales.
Comment 16 Guillermo López :willyaranda (probably SLOW response) 2013-03-07 02:25:43 PST
Verified and sign-off done.
Comment 17 chipironsm2 2013-03-20 11:21:22 PDT
For Windows users, the bug is still unfixed.

The process to correct the bug is for Linux only, as shown in https://bugzilla.mozilla.org/show_bug.cgi?id=846115.

There is no langpack-es-ES@firefox.mozilla.org.xpi in Windows 7.
Comment 18 chipironsm2 2013-03-20 12:03:04 PDT
(In reply to chipironsm2 from comment #17)
> For Windows users, the bug is still unfixed.
> 
> The process to correct the bug is for Linux only, as shown in
> https://bugzilla.mozilla.org/show_bug.cgi?id=846115.
> 
> There is no langpack-es-ES@firefox.mozilla.org.xpi in Windows 7.

After spending some more hours, I've found an addon that fixes the bug for Windows users: https://addons.mozilla.org/es/firefox/addon/restaura-atajo-marcadores/ 

The author is the same Jorge Villalobos.

I know pointing to the addon will be welcomed by the next windows users landind here from Google.

And sincerely thanks for the fixing.

Note You need to log in before you can comment on or make changes to this bug.