Last Comment Bug 844175 - Twitter stays on Connecting: Requesting user timelines...
: Twitter stays on Connecting: Requesting user timelines...
Status: RESOLVED FIXED
: regression
Product: Thunderbird
Classification: Client Software
Component: Instant Messaging (show other bugs)
: 21 Branch
: All All
: -- major (vote)
: Thunderbird 22.0
Assigned To: Florian Quèze [:florian] [:flo] (PTO until August 29th)
:
Mentors:
Depends on:
Blocks: 842183
  Show dependency treegraph
 
Reported: 2013-02-22 09:51 PST by Richard Marti (:Paenglab)
Modified: 2013-03-28 05:34 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
+
fixed


Attachments
Sync the two http.jsm files (7.43 KB, patch)
2013-02-28 15:33 PST, Florian Quèze [:florian] [:flo] (PTO until August 29th)
clokep: review+
mconley: review+
standard8: approval‑comm‑aurora+
Details | Diff | Splinter Review
Bustage fix (1.90 KB, patch)
2013-03-06 06:40 PST, Florian Quèze [:florian] [:flo] (PTO until August 29th)
no flags Details | Diff | Splinter Review

Description Richard Marti (:Paenglab) 2013-02-22 09:51:17 PST
Twitter is always in Connecting: Requesting user timelines... state. In console I have this:

Error: Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getCharPref]
Source file: resource://gre/components/imIncomingServer.js
Line: 179

After disconnecting and connecting again I'm seeing this:

Fri Feb 22 2013 18:45:40
Error: NS_ERROR_ILLEGAL_VALUE: Illegal value
Source file: resource://app/modules/http.jsm
Line: 13

Last good was TB 21 from 16.2.2013. Because of build bustage the next build was from 19.2.2013 and this shows the issue. Maybe it has something to do with Bug 842183 which land in this time.

I tried this on Win7 and Linux.
Comment 1 Patrick Cloke [:clokep] 2013-02-22 13:55:15 PST
The second error looks like it's from a fork in http.jsm between chat/ [1] and mail/ [2]:
Mail:
> function doXHRequest(aUrl, aHeaders, aPOSTData, aOnLoad, aOnError, aThis, aMethod)

Chat:
> function doXHRequest(aUrl, aHeaders, aPOSTData, aOnLoad, aOnError, aThis, aLogger)

We now pass aLogger, this gets considered (in Thunderbird) as aMethod and causes that error.

[1] http://mxr.mozilla.org/comm-central/source/chat/modules/http.jsm
[2] http://mxr.mozilla.org/comm-central/source/mail/base/modules/http.jsm
Comment 2 Ra oeai 2013-02-25 04:36:51 PST
Same here - for old accounts that was worked before v21 uodate i got -

requesting user timelines..

but before there was a second dialog asking (usually annoying because i was activating it for mail already) for master password; for the same twi acc. i've created a new kinda account in bird - and i got:

Connecting: initiating authentication process 

but irc is running already in the same time not sure about fb.
Comment 3 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2013-02-28 15:33:07 PST
Created attachment 719723 [details] [diff] [review]
Sync the two http.jsm files
Comment 4 Patrick Cloke [:clokep] 2013-02-28 15:54:51 PST
Comment on attachment 719723 [details] [diff] [review]
Sync the two http.jsm files

These changes look good and should get Twitter back on track.

I don't think I can actually review things in mail/base, however.
Comment 5 Mike Conley (:mconley) - (Needinfo me!) 2013-03-04 16:02:23 PST
Comment on attachment 719723 [details] [diff] [review]
Sync the two http.jsm files

Review of attachment 719723 [details] [diff] [review]:
-----------------------------------------------------------------

I'm alright with this. It blows that we have duplicated http.jsm, though. If both InstantBird and Thunderbird are using it, it belongs in toolkit.
Comment 6 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2013-03-06 02:39:40 PST
https://hg.mozilla.org/comm-central/rev/361ace8a7590
http://hg.instantbird.org/instantbird/rev/237424fae13f
Comment 7 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2013-03-06 06:40:51 PST
Created attachment 721706 [details] [diff] [review]
Bustage fix
Comment 8 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2013-03-06 06:44:09 PST
(In reply to Florian Quèze [:florian] [:flo] from comment #7)
> Created attachment 721706 [details] [diff] [review]
> Bustage fix

https://hg.mozilla.org/comm-central/rev/94f3a8a2bdf7 (rs=mconley over IRC)
Comment 9 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2013-03-06 06:45:44 PST
(In reply to Florian Quèze [:florian] [:flo] from comment #8)
> (In reply to Florian Quèze [:florian] [:flo] from comment #7)
> > Created attachment 721706 [details] [diff] [review]
> > Bustage fix
> 
> https://hg.mozilla.org/comm-central/rev/94f3a8a2bdf7 (rs=mconley over IRC)

And http://hg.instantbird.org/instantbird/rev/2b9937637ece
Comment 10 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2013-03-08 05:00:43 PST
Comment on attachment 719723 [details] [diff] [review]
Sync the two http.jsm files

[Approval Request Comment]
Regression caused by (bug #): bug 842183
User impact if declined: Twitter completely unusable.
Testing completed (on c-c, etc.): Already landed for c-c and Instantbird.
Risk to taking this patch (and alternatives if risky): Taking only the change to twitter.js may be possible, but I'm not sure that would really reduce the risk.

Note: I'm requesting approval on only one attachment, but we need to port both 361ace8a7590 and 94f3a8a2bdf7 to comm-aurora.
Comment 11 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2013-03-08 07:11:30 PST
(In reply to Florian Quèze [:florian] [:flo] from comment #10)

> Note: I'm requesting approval on only one attachment, but we need to port
> both 361ace8a7590 and 94f3a8a2bdf7 to comm-aurora.

Pushed both at once as https://hg.mozilla.org/releases/comm-aurora/rev/0fd17de09e0e

Note You need to log in before you can comment on or make changes to this bug.