Port chat/ changes from Instantbird to comm-central - 5

RESOLVED FIXED in Thunderbird 21.0

Status

Thunderbird
Instant Messaging
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: florian, Assigned: florian)

Tracking

Trunk
Thunderbird 21.0
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

+++ This bug was initially created as a clone of Bug #812921 +++

Instantbird and comm-central's chat/ folders have diverged again. Time for another sync/
Blocks: 842024
Created attachment 714981 [details] [diff] [review]
36 changesets from the Instantbird repository

Bio 1766 - Automatically authenticate when changing the nick to the account nickname, r=clokep.
Bio 1809 - Minor cleanup of IRC usernames, r=aleth.
Bio 1811 - IRC password does not work with ZNC/server password auth, r=aleth.
Bio 1814 - Fix ISUPPORT (Watch/Monitor), r=aleth.
Bio 1818 - "Couldn't parse message" due to trailing spaces, r=aleth.
Bio 1811 - IRC password does not work with ZNC server password auth, followup to fix breakage, r=aleth.
Bio 1817 - Don't disconnect when failing to parse a message, r=aleth.
Bio 1748 - Add NAMESX support (to get all user modes of someone instead of just one), r=aleth.
Bio 1419 - Handle the user's user mode, r=clokep.
Bio 1827 - Add an easy way to copy an account specific debug log, r=clokep.
Bio 1827 - Add an easy way to copy an account specific debug log, IRC protocol, r=fqueze.
Follow-up to bio 1827 (3da2d24bcccc) - fix bustage of the test_tryNewNick.js test, r=clokep.
Bio 1838 - Missing account on ERROR call, r=clokep.
Bio 1830 - Twitter parse error after reconnect caused by a stream error, r=fqueze.
Bio 1839 - Don't log to console unless loglevel is set appropriately, r=fqueze.
Bio 1824 - Add a startDate attribute to prplIConversation, r=fqueze.
Bio 1846 - Changing the status to available while an IRC account is in the disconnecting state doesn't reconnect it, r=fqueze.
Bio 1810 - Fix erroneous nickname error message when nick contains spaces, r=clokep.
Bio 1848 - IRC buddies take longer than other accounts' buddies to be marked as status unknown when disconnecting, r=clokep.
Bio 1855 - Crash [@purpleDebug::ReportMessageWithLocation], r=clokep.
Bio 1846 - follow-up to fix reconnection timers, r=fqueze.
Bio 1840 - Errors in handlers lose their location information, r=fqueze.
Bio 1606 - Update to Mozilla 17, patches part, r=fqueze.
Bio 1812 - IRC accounts should timeout when the connection to the server has stalled, r=fqueze.
Bio 1696 - rewrite Bubbles' timer handling so that timers are used only when actually needed, r=clokep.
Bio 1661 - Reconnecting with IRC causes nicks in ISON messages to duplicate, r=fqueze.
Bio 1753 - IRC says messages are unhandled when they are partially handled, r=aleth.
Bio 1825 - Unhandled IRC message 321, r=aleth.
Bio 1847 - The channel password shouldn't be displayed each time I join a password protected channel, r=aleth.
Bio 1863 - whois replies displayed in conversations should have the noLog flag, r=aleth.
Bio 1690 - /whois in a private irc conversation should support being parameterless, r=aleth.
Bio 1710 - Unhandled IRC message: 335, r=aleth.
Bio 1834 - Handle InfoServ, r=aleth.
Bio 1868 - Twitter accounts shouldn't keep references to all received tweets, r=aleth.
Bug 842024 - Thunderbird Chat can't connect to EuIRC, r=aleth.
Bug 842024 - Thunderbird Chat can't connect to EuIRC, r=fqueze.
Assignee: nobody → florian
Created attachment 715138 [details] [diff] [review]
37 changesets from the Instantbird repository

I missed one changeset in the previous attachment:
Bio 1606, Update to Mozilla 17, port bug 780357, bug 781446, bug 705532, r=fqueze.

(I initially ignored it because it seems to be porting changes from c-c to Instantbird's repository, but there are actually 2 changes there that need to be ported to c-c.)
Attachment #714981 - Attachment is obsolete: true
https://hg.mozilla.org/comm-central/rev/c3d702e9e93e
https://hg.mozilla.org/comm-central/rev/7a9229f07072
https://hg.mozilla.org/comm-central/rev/ed567231bd4f
https://hg.mozilla.org/comm-central/rev/daad988db75f
https://hg.mozilla.org/comm-central/rev/25e1726d6df8
https://hg.mozilla.org/comm-central/rev/b7b1aefc7fd3
https://hg.mozilla.org/comm-central/rev/4d877bc3b994
https://hg.mozilla.org/comm-central/rev/46fd0eac83e7
https://hg.mozilla.org/comm-central/rev/e5e235094adf
https://hg.mozilla.org/comm-central/rev/b174788a4aa9
https://hg.mozilla.org/comm-central/rev/de4aa0d91f76
https://hg.mozilla.org/comm-central/rev/cf9135f5995b
https://hg.mozilla.org/comm-central/rev/720bac01b841
https://hg.mozilla.org/comm-central/rev/d5ed81e22f0c
https://hg.mozilla.org/comm-central/rev/543fbbd02f80
https://hg.mozilla.org/comm-central/rev/68fc944f45f7
https://hg.mozilla.org/comm-central/rev/1801dbd51304
https://hg.mozilla.org/comm-central/rev/a485682a438c
https://hg.mozilla.org/comm-central/rev/d7dc2547a5ec
https://hg.mozilla.org/comm-central/rev/ed456f650deb
https://hg.mozilla.org/comm-central/rev/148c0dea391a
https://hg.mozilla.org/comm-central/rev/fc12e25962d5
https://hg.mozilla.org/comm-central/rev/03bb18a1a7bb
https://hg.mozilla.org/comm-central/rev/d907bc52c6d7
https://hg.mozilla.org/comm-central/rev/484786ffe4df
https://hg.mozilla.org/comm-central/rev/f2b4b9331bc0
https://hg.mozilla.org/comm-central/rev/dd7df5e93b19
https://hg.mozilla.org/comm-central/rev/ce2820dc72c5
https://hg.mozilla.org/comm-central/rev/1706f44805c7
https://hg.mozilla.org/comm-central/rev/447550434aa8
https://hg.mozilla.org/comm-central/rev/98e3aaec39b7
https://hg.mozilla.org/comm-central/rev/64239df00f64
https://hg.mozilla.org/comm-central/rev/aee786d836a5
https://hg.mozilla.org/comm-central/rev/b871590b5fe8
https://hg.mozilla.org/comm-central/rev/015b96371ec6
https://hg.mozilla.org/comm-central/rev/87e8a0c36afe
https://hg.mozilla.org/comm-central/rev/dad38b5c0099
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 21.0
Depends on: 844175
Blocks: 920801
Mapping to BMO bug numbers:

(In reply to Florian Quèze [:florian] [:flo] from comment #1)
> Created attachment 714981 [details] [diff] [review]
> 36 changesets from the Instantbird repository
>
> Bug 955198 - Automatically authenticate when changing the nick to the account
> nickname, r=clokep.
> Bug 955242 - Minor cleanup of IRC usernames, r=aleth.
> Bug 955244 - IRC password does not work with ZNC/server password auth, r=aleth.
> Bug 955247 - Fix ISUPPORT (Watch/Monitor), r=aleth.
> Bug 955251 - "Couldn't parse message" due to trailing spaces, r=aleth.
> Bug 955244 - IRC password does not work with ZNC server password auth,
> followup to fix breakage, r=aleth.
> Bug 955250 - Don't disconnect when failing to parse a message, r=aleth.
> Bug 955179 - Add NAMESX support (to get all user modes of someone instead of
> just one), r=aleth.
> Bug 954854 - Handle the user's user mode, r=clokep.
> Bug 955260 - Add an easy way to copy an account specific debug log, r=clokep.
> Bug 955260 - Add an easy way to copy an account specific debug log, IRC
> protocol, r=fqueze.
> Follow-up to Bug 955260 (3da2d24bcccc) - fix bustage of the test_tryNewNick.js
> test, r=clokep.
> Bug 955271 - Missing account on ERROR call, r=clokep.
> Bug 955263 - Twitter parse error after reconnect caused by a stream error,
> r=fqueze.
> Bug 955272 - Don't log to console unless loglevel is set appropriately,
> r=fqueze.
> Bug 955257 - Add a startDate attribute to prplIConversation, r=fqueze.
> Bug 955279 - Changing the status to available while an IRC account is in the
> disconnecting state doesn't reconnect it, r=fqueze.
> Bug 955243 - Fix erroneous nickname error message when nick contains spaces,
> r=clokep.
> Bug 955281 - IRC buddies take longer than other accounts' buddies to be marked
> as status unknown when disconnecting, r=clokep.
> Bug 955288 - Crash [@purpleDebug::ReportMessageWithLocation], r=clokep.
> Bug 955279 - follow-up to fix reconnection timers, r=fqueze.
> Bug 955273 - Errors in handlers lose their location information, r=fqueze.
> Bug 955036 - Update to Mozilla 17, patches part, r=fqueze.
> Bug 955245 - IRC accounts should timeout when the connection to the server has
> stalled, r=fqueze.
> Bug 955124 - rewrite Bubbles' timer handling so that timers are used only when
> actually needed, r=clokep.
> Bug 955090 - Reconnecting with IRC causes nicks in ISON messages to duplicate,
> r=fqueze.
> Bug 955185 - IRC says messages are unhandled when they are partially handled,
> r=aleth.
> Bug 955258 - Unhandled IRC message 321, r=aleth.
> Bug 955280 - The channel password shouldn't be displayed each time I join a
> password protected channel, r=aleth.
> Bug 955296 - whois replies displayed in conversations should have the noLog
> flag, r=aleth.
> Bug 955118 - /whois in a private irc conversation should support being
> parameterless, r=aleth.
> Bug 955138 - Unhandled IRC message: 335, r=aleth.
> Bug 955267 - Handle InfoServ, r=aleth.
> Bug 955301 - Twitter accounts shouldn't keep references to all received
> tweets, r=aleth.
> Bug 842024 - Thunderbird Chat can't connect to EuIRC, r=aleth.
> Bug 842024 - Thunderbird Chat can't connect to EuIRC, r=fqueze.
You need to log in before you can comment on or make changes to this bug.