Text color is white instead of black on Context Menu -> Site Settings

VERIFIED FIXED in Firefox 21

Status

()

defect
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: andreea.pod, Assigned: wesj)

Tracking

({regression})

21 Branch
Firefox 22
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox21 verified, firefox22 verified, fennec21+)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Posted image clear_site.settings
Firefox for Android
Version: 21.0a2 (2013-02-24)
Device: Acer Iconia A500
OS: Android 3.2.1

Steps to reproduce:
1. Open Fennec
2. Go to a website
3. Long tap on the URL bar 
4. Choose "Site Settings" from the Context Menu

Actual results:
- The text color is the same as its background: white (see attached screenshot)

Expected results:
- The text color should be visible.
Looks fine on Jellybean. Honeycomb issue?
(Reporter)

Comment 2

6 years ago
WesJ fallout from the holo theming?
tracking-fennec: --- → ?
Flags: needinfo?(wjohnston)
Blocks: 832321
tracking-fennec: ? → 21+
Flags: needinfo?(wjohnston)
Keywords: regression
Assignee: nobody → wjohnston
(Assignee)

Comment 4

6 years ago
Posted patch Patch v1 (obsolete) — Splinter Review
Patch. Build with this at:

http://people.mozilla.com/~wjohnston/sitePrefs.apk

Can you test it on a Honeycomb device kbrosnan?
Looks great!
(Assignee)

Updated

6 years ago
Attachment #719727 - Flags: review?(sriram)
(In reply to Wesley Johnston (:wesj) from comment #4)
> Created attachment 719727 [details] [diff] [review]
> Patch v1
> 
> Patch. Build with this at:
> 
> http://people.mozilla.com/~wjohnston/sitePrefs.apk
> 
> Can you test it on a Honeycomb device kbrosnan?

I somehow don't like moving padding to the styles. It breaks the layout file. Could you please move only the "textAppearance" to the styles file? Also, you might want to add "res/values-v14" to RES_DIRS in the Makefile.
(Assignee)

Comment 7

6 years ago
Posted patch Patch v2Splinter Review
Removed the padding stuff. I think this should be in the style files (hence why I moved it, but we can figure that out some other time/place).
Attachment #719727 - Attachment is obsolete: true
Attachment #719727 - Flags: review?(sriram)
Attachment #720161 - Flags: review?(sriram)
Comment on attachment 720161 [details] [diff] [review]
Patch v2

This looks good to me.
Attachment #720161 - Flags: review?(sriram) → review+
https://hg.mozilla.org/mozilla-central/rev/5668dcdcdbdd
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
(Assignee)

Updated

6 years ago
Depends on: 847849
(Assignee)

Comment 11

6 years ago
Comment on attachment 720161 [details] [diff] [review]
Patch v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 832321
User impact if declined: Site settings dialog looks bad
Testing completed (on m-c, etc.): Has been on mc for a few weeks. No regressions
Risk to taking this patch (and alternatives if risky): Low risk. Mostly themeing
String or UUID changes made by this patch: None.
Attachment #720161 - Flags: approval-mozilla-aurora?
Attachment #720161 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Reporter)

Comment 12

6 years ago
Verified fixed on:
-build: Firefox for Android 22.0a1 (2013-03-12)
-device: Acer Iconia A500
-OS: Android 3.2.1
(Reporter)

Updated

6 years ago
(Reporter)

Comment 14

6 years ago
Verified fixed on:
-build: Firefox for Android 21.0a2 (2013-03-14)
-device: Acer Iconia A500
-OS: Android 3.2.1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.