Closed Bug 847849 Opened 8 years ago Closed 8 years ago

Hostname in site settings dialog is misaligned

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox21 verified, firefox22 verified)

VERIFIED FIXED
Firefox 22
Tracking Status
firefox21 --- verified
firefox22 --- verified

People

(Reporter: Margaret, Assigned: Margaret)

References

Details

Attachments

(2 files, 1 obsolete file)

Attached image screenshot
See screenshot.

Also, the ellipsis in the title looks awkward, but this would be fixed if we fix bug 786999.
Duplicate of this bug: 847931
I'm not sure how removing the ellipsis fixes this? Its likely fallout from bug 844834.
Blocks: 844834
I guess I wasn't clear. Removing the ellipsis just fixes the fact that the ellipsis in the title is awkward :)

We still need to do something to fix the host name alignment.
Duplicate of this bug: 848285
The patch in bug 844834 got rid of this padding.

I also found that the title and subtitle are both black on black on gingerbread. That also needs a fix.
Assignee: nobody → margaret.leibovic
Attachment #723702 - Flags: review?(wjohnston)
Comment on attachment 723702 [details] [diff] [review]
put back padding that was removed

The patch at:

https://hg.mozilla.org/mozilla-central/rev/5668dcdcdbdd

has padding on the left and right. I moved them to styles and then supposedly moved them back (which apparently means I didn't move them back). Might as well put both back.
Attachment #723702 - Attachment is obsolete: true
Attachment #723702 - Flags: review?(wjohnston)
Attachment #723705 - Flags: review?(wjohnston)
Comment on attachment 723705 [details] [diff] [review]
put back padding on both sides

Review of attachment 723705 [details] [diff] [review]:
-----------------------------------------------------------------

I realize now what happened. I moved these to styles (where I still think they should live) then I moved them back, but since I was using inheritence in the styles so we didn't have to duplicate this all over, I forgot to add them back here (aka if they were styles this would have been prettier and easier).
Attachment #723705 - Flags: review?(wjohnston) → review+
Comment on attachment 723705 [details] [diff] [review]
put back padding on both sides

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 844834
User impact if declined: site settings dialog title looks bad
Testing completed (on m-c, etc.): just landed on inbound
Risk to taking this patch (and alternatives if risky): low-risk, small style change
String or UUID changes made by this patch: n/a
Attachment #723705 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/905682481543
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
Comment on attachment 723705 [details] [diff] [review]
put back padding on both sides

Approving the low risk uplift of a minor alignment glitch in site settings dialog.
Attachment #723705 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified on Firefox for Android 21.0b7 and Aurora 22.0a2 (2013-05-07) using: Nexus 4 (4.2.2)
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.