bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Temporarily remove homescreen wallpaper feature due to impact on auto updates

VERIFIED FIXED

Status

()

Firefox for Android
General
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: akeybl, Assigned: Margaret)

Tracking

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox20+ verified, firefox21+ verified, firefox22+ verified, firefox23- unaffected)

Details

(Whiteboard: [no-nag])

Attachments

(4 attachments)

(Reporter)

Description

6 years ago
Kevin brought up a new permission being necessary for bug 715736 in FF20. This prevents automatic updates, so we're wondering if we should delay this permissions change till a more major permissions change is made.
tracking-fennec: --- → ?
(Reporter)

Comment 1

6 years ago
Margaret - can you help disable this feature and remove the permission? Nobody has made the case for retaining this feature in FF20, given the impact to updates.

Tracking for FF21 as well, since it's unclear when our next critical permissions change is necessary.
Assignee: nobody → margaret.leibovic
tracking-firefox20: ? → +
tracking-firefox21: --- → +
(Reporter)

Updated

6 years ago
Summary: Homescreen wallpaper feature worth permissions change in FF20? → Temporarily remove homescreen wallpaper feature due to impact on auto updates
(Reporter)

Updated

6 years ago
Whiteboard: [no-nag]
(Assignee)

Comment 2

6 years ago
(In reply to Alex Keybl [:akeybl] from comment #1)
> Margaret - can you help disable this feature and remove the permission?
> Nobody has made the case for retaining this feature in FF20, given the
> impact to updates.

Sure. Just on beta?
(Assignee)

Comment 3

6 years ago
Created attachment 719204 [details] [diff] [review]
patch to disable wallpaper feature (applies on beta)
Attachment #719204 - Flags: review?(wjohnston)
Attachment #719204 - Flags: review?(wjohnston) → review+
(Assignee)

Comment 4

5 years ago
Comment on attachment 719204 [details] [diff] [review]
patch to disable wallpaper feature (applies on beta)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 715736
User impact if declined: permissions change and manual update
Testing completed (on m-c, etc.): local build
Risk to taking this patch (and alternatives if risky): n/a
String or UUID changes made by this patch: n/a
Attachment #719204 - Flags: approval-mozilla-beta?
Have we heard back from Karen and development leads yet? We've already gone to build for beta 2. We should have until next Tuesday mid-day Pacific to land this for beta 3.
R+ on removing the feature until we have a solid "permission batch". Please disable on Aurora too.
(Assignee)

Comment 7

5 years ago
Created attachment 719766 [details] [diff] [review]
patch for aurora

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 715736
User impact if declined: permissions change and manual update
Testing completed (on m-c, etc.): local build
Risk to taking this patch (and alternatives if risky): n/a
String or UUID changes made by this patch: n/a
Attachment #719766 - Flags: approval-mozilla-aurora?
Comment on attachment 719204 [details] [diff] [review]
patch to disable wallpaper feature (applies on beta)

Approving the patch for uplift & request to QA with verification ensuring the feature is disabled .
Attachment #719204 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Updated

5 years ago
Attachment #719766 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

5 years ago
Keywords: verifyme
(Reporter)

Updated

5 years ago
tracking-firefox22: --- → ?
Option is no longer available on Aurora 21.0a2 2013-03-14 and Firefox Mobile 20 beta 5 on the Smasung Galaxy Tab 2 7.0 (Android 4.1.1)
status-firefox20: fixed → verified
status-firefox21: fixed → verified
Keywords: verifyme
(Assignee)

Updated

5 years ago
Depends on: 851170
(Assignee)

Comment 11

5 years ago
Marking this bug as fixed, since it was about disabling the feature on 20/21. I filed bug 851170 as a follow-up.
Status: NEW → RESOLVED
tracking-fennec: ? → ---
Last Resolved: 5 years ago
tracking-firefox22: ? → ---
Resolution: --- → FIXED
(Reporter)

Updated

5 years ago
tracking-firefox22: --- → ?
(Reporter)

Updated

5 years ago
status-firefox22: --- → affected
tracking-firefox22: ? → +
(Reporter)

Comment 12

5 years ago
We haven't decided whether to do this for FF23 again, but we may still want to track for now.
tracking-firefox23: --- → ?
status-firefox23: --- → fixed
tracking-firefox23: ? → +
Target Milestone: --- → Firefox 23
status-firefox23: fixed → affected
Target Milestone: Firefox 23 → ---
The option is active on Firefox Mobile 22 beta 1
Margaret - Can we get this backed out of fx22 (beta) and fx23 (aurora)? And should we move to a build flag?

Updated

5 years ago
Flags: needinfo?(margaret.leibovic)
(Assignee)

Comment 15

5 years ago
(In reply to Mark Finkle (:mfinkle) from comment #14)
> Margaret - Can we get this backed out of fx22 (beta) and fx23 (aurora)? And
> should we move to a build flag?

I guess changing the confvars variable didn't get onto someone's list? Bug 851170 is in 22, so we just need to flip that variable.
Flags: needinfo?(margaret.leibovic)
(Reporter)

Comment 16

5 years ago
Created attachment 751823 [details] [diff] [review]
Disable wallpaper for FF22
Attachment #751823 - Flags: review?(margaret.leibovic)
(Assignee)

Updated

5 years ago
Attachment #751823 - Flags: review?(margaret.leibovic) → review+
(Reporter)

Comment 17

5 years ago
https://hg.mozilla.org/releases/mozilla-beta/rev/285b70591ec6
status-firefox22: affected → fixed
I still see this permission on mozilla-beta, margaret, can you confirm?

http://ftp.mozilla.org/pub/mozilla.org/mobile/candidates/22.0b3-candidates/build1/android/multi/fennec-22.0b3.multi.android-arm.apk
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 19

5 years ago
(In reply to Aaron Train [:aaronmt] from comment #18)
> I still see this permission on mozilla-beta, margaret, can you confirm?
> 
> http://ftp.mozilla.org/pub/mozilla.org/mobile/candidates/22.0b3-candidates/
> build1/android/multi/fennec-22.0b3.multi.android-arm.apk

Yeah, I can confirm this feature isn't disabled here :(

I can see that's akeybl's change is definitely in the beta tree, so I'll need to figure out what's going wrong here. I'm investigating now.
Flags: needinfo?(akeybl)
(Assignee)

Comment 20

5 years ago
Oops, didn't mean to set that needinfo.
Flags: needinfo?(akeybl)
(Assignee)

Comment 21

5 years ago
Created attachment 756229 [details] [diff] [review]
Actually disable wallpaper feature for FF22

I failed at reviewing that last patch. Our tests are for "non-empty value", not truthiness.

This patch is for beta.
Attachment #756229 - Flags: review?(mark.finkle)
Attachment #756229 - Flags: approval-mozilla-beta?
Attachment #756229 - Flags: review?(mark.finkle) → review+
(Reporter)

Updated

5 years ago
Attachment #756229 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(Reporter)

Updated

5 years ago
status-firefox22: fixed → affected
(Assignee)

Comment 22

5 years ago
https://hg.mozilla.org/releases/mozilla-beta/rev/c9a8e2bea80a

This worked for me locally, but let's make sure to verify this once builds are ready.

Is this going to go on some checklist somewhere for things to do on the next uplift to make sure this will be fixed for 23 when it goes to beta?
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
status-firefox22: affected → fixed
Keywords: verifyme
Resolution: --- → FIXED
I fixed your permaorange in https://hg.mozilla.org/releases/mozilla-beta/rev/2507883ac7e4 by disabling testWebContentContextMenu, since we actually disabled in in 23 so that we could run robocop on Pandas (pay no attention to the fact that we're running robocop on Pandas on 22, where it and the other six things we disabled with it are not disabled).

Updated

5 years ago
Status: RESOLVED → VERIFIED
status-firefox22: fixed → verified

Updated

5 years ago
Keywords: verifyme
We're on beta now - Margaret can you check on this and submit a patch for beta uplift?
Flags: needinfo?(margaret.leibovic)
(Assignee)

Comment 25

5 years ago
(In reply to lsblakk@mozilla.com [:lsblakk] from comment #24)
> We're on beta now - Margaret can you check on this and submit a patch for
> beta uplift?

There shouldn't be anything to do, this was fixed by bug 879350. And I just verified that there's no wallpaper permission requested in the Beta installed on my phone.
Flags: needinfo?(margaret.leibovic)
status-firefox23: affected → unaffected
tracking-firefox23: + → -
You need to log in before you can comment on or make changes to this bug.