Closed Bug 879350 Opened 7 years ago Closed 7 years ago

Disable Android Beam and wallpaper support on Firefox 23

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Tracking Status
firefox23 + verified disabled

People

(Reporter: kats, Assigned: kats)

References

Details

Attachments

(1 file, 1 obsolete file)

Product decided to push back the "add new permissions" release to Fx24, so we need to disable the android beam and wallpaper support in Fx 23.
Attached patch Patch for aurora (obsolete) — Splinter Review
This patch is for aurora (Fx23) only.
Attachment #758024 - Flags: review?(mark.finkle)
Attachment #758024 - Flags: approval-mozilla-aurora?
Comment on attachment 758024 [details] [diff] [review]
Patch for aurora

Review of attachment 758024 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/confvars.sh
@@ +19,5 @@
>  # Enable getUserMedia
>  MOZ_MEDIA_NAVIGATOR=1
>  
>  # Enable SET_WALLPAPER permission
> +MOZ_ANDROID_WALLPAPER=0

This doesn't work. It needs to be MOZ_ANDROID_WALLPAPER= (empty). See bug 844935 comment 21. Also, I think we need to make sure to disable tests when landing this.
Attachment #758024 - Flags: review?(mark.finkle) → review-
Attachment #758024 - Flags: approval-mozilla-aurora?
Thanks for catching those problems, margaret. I've pushed a new version to try with the corrected confvars and test hacked to see if it's good: https://tbpl.mozilla.org/?tree=Try&rev=b334b7a561c2
Try build at https://tbpl.mozilla.org/?tree=Try&rev=b334b7a561c2 is clean, and installing that build on my N4 and looking at the permissions shows that it doesn't have wallpaper or NFC permissions.
Attachment #758024 - Attachment is obsolete: true
Attachment #758596 - Flags: review?(margaret.leibovic)
Comment on attachment 758596 [details] [diff] [review]
Patch for aurora v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): product decision
User impact if declined: When 23 goes to beta automatic updates will be disabled because of new permissions. And then it will happen again when 24 goes to beta
Testing completed (on m-c, etc.): locally
Risk to taking this patch (and alternatives if risky): low risk, mobile only
String or IDL/UUID changes made by this patch: none
Attachment #758596 - Flags: approval-mozilla-aurora?
Attachment #758596 - Flags: review?(margaret.leibovic) → review+
Comment on attachment 758596 [details] [diff] [review]
Patch for aurora v2

Please update status to 'disabled' once this lands
Attachment #758596 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.