[OPEN_][Gallery]Two images are overlayed in edit mode.

VERIFIED FIXED

Status

Firefox OS
Gaia::Gallery
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Firefox_Mozilla, Assigned: djf)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18+ fixed, b2g18-v1.0.1 fixed)

Details

(Whiteboard: [triaged:3/1])

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 719366 [details]
Gallery edit mode

Steps to reproduce:
1.Go into Gallery and select a big image to view;
2.Go into edit mode and press the power key;
3.press the power key again to wake up the screen;
4.tap camera key in lock screen;
5.switch to Gallery in camera interface;
6.select another small image to view;
7.Go into edit mode;
Expected results:
1.it is shown normal in edit mode;
Actual results:
1.the big image also in the lower lay. Two images are overlay in edit mode.
(Reporter)

Updated

5 years ago
Blocks: 845223

Comment 1

5 years ago
It looks like a serious problem in Gallery.
blocking-b2g: --- → shira?
tracking-b2g18: --- → +
Whiteboard: [triaged:3/1]
What build was used to reproduce this issue?
blocking-b2g: shira? → shira+
(moving shira+ -> tef+ to simplify tracking)
blocking-b2g: shira+ → tef+
Assignee: nobody → dflanagan

Comment 4

5 years ago
Hi, all,

I have double confirmed this case.
The build: 20130218070201 (Can reproduce)
The latest build: 20130304230203 (Can reproduce, please see attachment)
Thanks!
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

5 years ago
Created attachment 721273 [details]
Overlapped image
(Assignee)

Comment 6

5 years ago
Nice catch. I can reproduce this. It isn't necessary to return to the lockscreen. You can also just go to the homescreen, open camera and switch to gallery that way.

So this is related to how we handle the 'browse' activity.  And it should be an easy fix.

I wonder what the right thing (from a UX standpoint) is to do here: abandon the edit in progress and show the user the list of thumbnails, since they're coming from the camera and probably want to see that.  Or just return the the app where they left it in the middle of an edit?

Casey: sorry to keep needinfo'ing you on these last minute bugs, but I'd like your advice on how to handle this.
Flags: needinfo?(kyee)
(Assignee)

Comment 7

5 years ago
Created attachment 721417 [details]
link to patch on github

Even though I haven't heard from Casey yet, I've decided that allowing the user to lose work (an in progress edit or in-progress selection) isn't good.  So this patch modifies how we handle the browse activity.  Previously we always reverted to displaying the thumbnail list.  Now we only do that if the user was just viewing a photo. If they were editing or selecting, we just open the gallery where they left it.
Attachment #721417 - Flags: review?(jhylands)
Comment on attachment 721417 [details]
link to patch on github

Looks good, tested it and it works.
Attachment #721417 - Flags: review?(jhylands) → review+
(Assignee)

Comment 9

5 years ago
Merged into master: https://github.com/mozilla-b2g/gaia/commit/28276e469cb7f9ee8abdb09fe84189bb9898f2f7

Cancelling the needinfo request for Casey because I think I've finessed the situation sufficiently. When opened from the camera, we go to thumbnail mode if we were displaying a single photo, and only remain out of thumbnail mode if the user had left the gallery in edit mode or select mode.  That is unlikely to happen very often, and I think it is an adequate solution.
(Assignee)

Comment 10

5 years ago
Closing
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(kyee)
Resolution: --- → FIXED
v1-train: 7359be50cc60e737d44ea0d0c0dff29fc2a1a95d
v1.0.1: 364f2074b7df0e9c1442a269d16a57331dacab0d
status-b2g18: --- → fixed
status-b2g18-v1.0.1: --- → fixed

Comment 12

5 years ago
same issue was described in bug #845544
John,

we need to backout this from v1-train and v1.0.1 because this bug depends on Bug 841251 which is not uplifted yet. Could you please do that ?
Flags: needinfo?(jhford)
Depends on: 841251
This is what produced Bug 849290.
backouts:

v1-train: 9d7b1ffaa3478a7ebc66c0aa82c360b58495cd71
v1.0.1: 46c13bcd9cf8c4ac5853bd0f3a1ce846303b011e
status-b2g18: fixed → affected
status-b2g18-v1.0.1: fixed → affected
Flags: needinfo?(jhford)
v1-train: 788e786fc12b7fd8c1ae011160ba870cc2ee8576
v1.0.1: 8e73a77836d5b8a251441fe9e6b3864e37b073d9
status-b2g18: affected → fixed
status-b2g18-v1.0.1: affected → fixed

Comment 17

5 years ago
The issue no longer appears to be occurring on an Unagi device running the following build:

Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/af9270e8f205
Gaia: a78ebf426840b5ef08c0cc3e437ad30aba3e2528
Build: 20130318070202

User is now prompted to close edit mode in order to be able browsing gallery

Verifying as fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.