The default bug view has changed. See this FAQ.

Change - Context menu overlays flyouts

VERIFIED FIXED in Firefox 22

Status

Firefox for Metro
Input
P1
normal
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: jimm, Assigned: rsilveira)

Tracking

Trunk
Firefox 22
x86_64
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: feature=change c=operations u=developer p=1)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Created attachment 719607 [details]
screen cap

See screen shot. We need to move these down in the stack.
Which story or work item does this block Jim?
(Reporter)

Comment 2

4 years ago
Created attachment 719612 [details] [diff] [review]
move flyouts

Flyouts should be at the bottom of pretty much everything I think.
Attachment #719612 - Flags: review?(mbrubeck)
(Reporter)

Comment 3

4 years ago
That patch sucks since it blows away blame. All I've really done is copy flyouts down to the bottom of the stack.
(Reporter)

Updated

4 years ago
Assignee: nobody → jmathies
(Reporter)

Comment 4

4 years ago
(In reply to Marco Mucci [:MarcoM] from comment #1)
> Which story or work item does this block Jim?

Hmm, something flyouts related maybe?
Comment on attachment 719612 [details] [diff] [review]
move flyouts

We need menus to be able to appear over flyoutpanels; for example we use a MenuPopup for the menulist control in the "Startup" section of the Options flyout.  It seems likely that we will also want text selection or context menus within flyoutpanels at some point.

For the case in your screenshot, maybe we should get better about hiding the flyoutpanel when interacting with content (and/or hiding the context menu when showing the flyoutpanel).
Attachment #719612 - Flags: review?(mbrubeck) → review-
(Reporter)

Comment 6

4 years ago
Comment on attachment 719612 [details] [diff] [review]
move flyouts

ah poop. thought it was an easy fix.
Attachment #719612 - Attachment is obsolete: true

Updated

4 years ago
Blocks: 841214
(Reporter)

Updated

4 years ago
Assignee: jmathies → nobody

Comment 7

4 years ago
I think we should be clearing any context menus when the user swipes in the charms bar.
No longer blocks: 841214
(Assignee)

Updated

4 years ago
Assignee: nobody → rsilveira

Updated

4 years ago
Blocks: 850809
Priority: -- → P1
Summary: Context menu overlays flyouts → Change - Context menu overlays flyouts
Whiteboard: feature=change c=tbd u=tbd p=tbd
Created attachment 730251 [details] [diff] [review]
Patch v1
Attachment #730251 - Flags: review?(mbrubeck)
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
Attachment #730251 - Flags: review?(mbrubeck) → review+
Comment on attachment 730251 [details] [diff] [review]
Patch v1

https://hg.mozilla.org/integration/mozilla-inbound/rev/4afb61ad2964
Attachment #730251 - Flags: checkin+
https://hg.mozilla.org/mozilla-central/rev/4afb61ad2964
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22

Updated

4 years ago
Whiteboard: feature=change c=tbd u=tbd p=tbd → feature=change c=operations u=operations p=1
Just reopening for inclusion into Iteration #5.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

4 years ago
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Whiteboard: feature=change c=operations u=operations p=1 → feature=change c=operations u=developer p=1

Updated

4 years ago
Flags: needinfo?(jbecerra)
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:23.0) Gecko/20130404 Firefox/23.0

Verified that context menu, for a selected text on a page, is not accessible when the user swipes in the charms bar and selects an option.
Status: RESOLVED → VERIFIED

Updated

4 years ago
Flags: needinfo?(jbecerra)
Depends on: 861532
Depends on: 861536
Hi Jim, added the issues that I found here as the original "Story" seems to be missing
Flags: needinfo?(jmathies)
(Reporter)

Comment 14

4 years ago
I don't think we need to block in this. Each bug is different.
No longer depends on: 861532, 861536
Flags: needinfo?(jmathies)
Went through the following "Defect" for iteration #7 testing without any issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-05-28-03-09-42-mozilla-central/

- Ensured that selecting "Options", "Sync" or "About" clears the "Context Menu" without any issues
- Ensured that both "Link" & "Image" Context Menu's are dismissed when selecting "Options", "Sync" or "About"
- Ensured that the "Context Menu" is being cleared when creating a new tab using the junior style button
- Ensured that the "Context Menu" is being cleared when creating a new tab using the "+" button under the "Navigation App Bar"
- Ensured that the "Context Menu" is being cleared when selecting the junior style "Back" button
- Ensured that the "Context Menu" is being cleared when sliding in the "Navigation App Bar" from both the bottom & top

Issues still occurring with the Context Menu:

- Bug 861536 (Defect) still an an issue (reproduced several times)
- Bug 861532 (Defect) is still an issue (reproduced several times)

Updated

4 years ago
Blocks: 831958
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.