Closed Bug 847599 Opened 7 years ago Closed 7 years ago

Paris binding for TransitionEvent

Categories

(Core :: DOM: Events, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla22

People

(Reporter: smaug, Assigned: smaug)

References

Details

Attachments

(2 files, 1 obsolete file)

No description provided.
Attached patch patch (obsolete) — Splinter Review
https://tbpl.mozilla.org/?tree=Try&rev=3a5e7b7cf253
Assignee: nobody → bugs
Blocks: 848291
Comment on attachment 721449 [details] [diff] [review]
patch

Bug 848291 is a followup.
Attachment #721449 - Flags: review?(Ms2ger)
Attached patch patchSplinter Review
Attachment #721449 - Attachment is obsolete: true
Attachment #721449 - Flags: review?(Ms2ger)
Attachment #723116 - Flags: review?(Ms2ger)
Comment on attachment 723116 [details] [diff] [review]
patch

Review of attachment 723116 [details] [diff] [review]:
-----------------------------------------------------------------

::: content/events/src/nsDOMTransitionEvent.h
@@ +25,5 @@
>    NS_FORWARD_TO_NSDOMEVENT
>    NS_DECL_NSIDOMTRANSITIONEVENT
>  
> +  virtual JSObject* WrapObject(JSContext* aCx, JSObject* aScope,
> +                               bool* aTriedToWrap)

.

::: dom/webidl/TransitionEvent.webidl
@@ +9,5 @@
> + *
> + * Copyright © 2012 W3C® (MIT, ERCIM, Keio), All Rights Reserved. W3C
> + * liability, trademark and document use rules apply.
> + */
> + 

Trailing whitespace
Attachment #723116 - Flags: review?(Ms2ger) → review+
Attached patch patchSplinter Review
Fun, totally unreproduceable crash here.
Can't reproduce on tryserver either. Could this require a clobber?
(In reply to Olli Pettay [:smaug] from comment #9)
> Can't reproduce on tryserver either. Could this require a clobber?

It's not immediately obvious to me how this could require a clobber, but you're welcome to reland with a change to the CLOBBER file...
I'll try to reland tomorrow.
https://tbpl.mozilla.org/?tree=Try&rev=85dfda2d314c doesn't show problems on windows.
Crossing fingers
https://hg.mozilla.org/integration/mozilla-inbound/rev/cceb495a89d6

I run the tests several times on try and no crashes.
https://hg.mozilla.org/mozilla-central/rev/cceb495a89d6
https://hg.mozilla.org/mozilla-central/rev/a1b34cb6b77e
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla22
You need to log in before you can comment on or make changes to this bug.