Closed Bug 84809 Opened 19 years ago Closed 19 years ago

[RFE] prefs to configure autocomplete behavior

Categories

(SeaMonkey :: Autocomplete, enhancement)

enhancement
Not set

Tracking

(Not tracked)

VERIFIED FIXED
mozilla0.9.4

People

(Reporter: diego, Assigned: hewitt)

References

Details

Attachments

(3 files)

When I type something into the URL bar autocomplete starts and offers me the
option to search for whatever I am typing on my favorite search engine. I do not
want this. There should be some way to disable this, just as I could disable the
search button.

Besides, this is unbearably slow, but that is covered in bug 78757.
This is very annoying. The mere interact with the URL will pop up this thing;
even deleting or a character to the URL bar makes it appear.

Two proposed solutions:

1 (quick) Tie this feature with the "Enable Location bar autocomplete"
preference so it gets enabled/disabled at the same time.

2 (better?) Add a new option in Preferences to disable this thing, maybe in
Navigator -> Internet Search, something like "Enable Search bar autocomplete" or
something like that.
This appears to be a feature people want, so I will confirm this bug now, but
mark it as RFE.

The second alternative proposed by artemis3@cantv.net sounds good.
Severity: minor → enhancement
Summary: pref to disable "Search XYZ for .." in autocomplete wanted → [RFE] pref to disable "Search XYZ for .." in autocomplete wanted
I'm confirming it now, really.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → ASSIGNED
*** Bug 87951 has been marked as a duplicate of this bug. ***
OS: Linux → All
Hardware: PC → All
*** Bug 88508 has been marked as a duplicate of this bug. ***
I am proposing this bug for 0.9.3 and nsCatFood since older computers (PII
350MHz class) have trouble updating the text in the location bar and force users
to slow down typing. This is extremely annoying, immediately visible and likely
to keep people from using mozilla.
The following patch will add a button the the Smart Browsing pref panel which
opens a dialog that lets you choose the following autocomplete prefs:

[] - select matching text as you type
[] - show autocomplete popup
[] - show search engine item

The patch also fixes the annoying white space bug.
Summary: [RFE] pref to disable "Search XYZ for .." in autocomplete wanted → [RFE] prefs to configure autocomplete behavior
Keywords: mozilla0.9.3
Target Milestone: --- → mozilla0.9.4
Attached patch patchSplinter Review
r=matt
The patch seems to look for autocomplete-autofill-on.gif, which doesn't appear
to exist in my tree...
Hewitt, could you add autocomplete-autofill-on.gif as an attachment to this
bug?  I'd really like to try this patch, but my build breaks since I don't 
have this file.
sr=blake, including the other changes in this patch not directly related to this
bug...
fixed
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
verified on 2001081003.  Minor nit, the Advanced button should be disabled if
the "Enable location bar autocomplete" checkbox is not checked.  I'll file that
as a separate bug sometime.
Status: RESOLVED → VERIFIED
I filed bug 95159 about your proposal, Dean.
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.