Closed Bug 848317 Opened 7 years ago Closed 6 years ago

Screen corruption on dismissal of Android action-bar

Categories

(Firefox for Android :: Theme and Visual Design, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 24
Tracking Status
firefox22 --- unaffected
firefox23 --- verified
firefox24 --- verified
fennec 22+ ---

People

(Reporter: aaronmt, Assigned: sriram)

References

Details

(Keywords: regression, reproducible)

Attachments

(3 files)

On dismissal of the address-bar's action-bar there is a quick graphical glitch; see screenshot. 

--
Nightly (03.06)
LG Nexus 4 (Android 4.2.2)
Looks like another one of those GL state corruption bugs.
Component: Graphics, Panning and Zooming → Graphics
OS: Mac OS X → Android
Product: Firefox for Android → Core
Hardware: x86 → All
Assignee: nobody → bugmail.mozilla
tracking-fennec: ? → 22+
Same issue that Lucas is working on
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 849573
Duplicate of this bug: 853676
Fixed on Nightly (03/22)
Status: RESOLVED → VERIFIED
I still see this on Nightly (03/27) on my Nexus 4.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
bnicholson commented that this is an entirely different activity to the main app that bug 716403 affects, so this may well be unrelated - removing blocker status.
No longer blocks: dynamic-toolbar
Duplicate of this bug: 856993
This looks terrible on Honeycomb http://youtu.be/7rzLDM4ui4E
Status: REOPENED → NEW
I can also reproduce on a Galaxy Tab.
The regression window for this issue is:

good build: 27.02.2013  
bad build:  28.02.2013 

possible pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e7632ab657e5&tochange=b0e08db3bc2a
(In reply to Aaron Train [:aaronmt] from comment #12)
> http://hg.mozilla.org/mozilla-central/rev/29de190ac31c ?

Yup. That removed the background for the window. Which might have caused this problem. The easiest way is to add the background back (and we will be breaking the AwesomeBar soon). However, we might face the same problem in BrowserApp, as BrowserApp too doesn't have a background.
Flags: needinfo?(sriram)
Assignee: bugmail.mozilla → sriram
Component: Graphics → Theme and Visual Design
Product: Core → Firefox for Android
Sriram, do you know how to proceed here?
This was fixed. However Aaron reported that this breaks in Nexus 4.
Actually you're in luck; testing on 04/11 this seems fixed for me on my Nexus 4. Something recent fixed this.
Status: NEW → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → WORKSFORME
Nevermind, I still see this on 04/15.

STR: Long tap on the URL bar, see action bar, tap selected text and see action-bar glitch off
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
This was never fixed.
Status: REOPENED → ASSIGNED
Lucas - Can you take a look at this?
Assignee: sriram → lucasr.at.mozilla
Back to Sriram. This is on beta, can you take a look soon?
Assignee: lucasr.at.mozilla → sriram
^
Flags: needinfo?(sriram)
I have two options in hand:
1. Set a color to window background before hiding action bar so that it wouldn't cause corruption
  - I highly doubt that the window invalidates itself to change the color before the animation starts. This might/might not work.
2. Forget about overdraw and add a color for window-background.
  - This will ensure that there is no corruption. And anyways AwesomeBar is going to go away.
Flags: needinfo?(sriram)
(In reply to Sriram Ramasubramanian [:sriram] from comment #22)
> I have two options in hand:
> 1. Set a color to window background before hiding action bar so that it
> wouldn't cause corruption
>   - I highly doubt that the window invalidates itself to change the color
> before the animation starts. This might/might not work.

Options 1 → Failure: http://cl.ly/image/1W3o2t1v1L1o
Option 2 → Success!
Attached patch PatchSplinter Review
This is patch for option 2.

(Sorry romainguy, we can't make you happy all the time!)
Attachment #754994 - Flags: review?(mark.finkle)
Comment on attachment 754994 [details] [diff] [review]
Patch

Prepare for uplift!
Attachment #754994 - Flags: review?(mark.finkle) → review+
Comment on attachment 754994 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Removing overdraw for AwesomeBar.
User impact if declined: Screen corruption.
Testing completed (on m-c, etc.): Landed in m-i on 05/28
Risk to taking this patch (and alternatives if risky): None. This adds the windowBackground which none would see. It's the same color as url-bar.
String or IDL/UUID changes made by this patch: None.
Attachment #754994 - Flags: approval-mozilla-beta?
Attachment #754994 - Flags: approval-mozilla-aurora?
Re-landing as the failure is not due to this one-liner:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c381730a8bbf
Attachment #754994 - Flags: approval-mozilla-beta?
Attachment #754994 - Flags: approval-mozilla-beta+
Attachment #754994 - Flags: approval-mozilla-aurora?
Attachment #754994 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/c381730a8bbf
Status: ASSIGNED → RESOLVED
Closed: 7 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
This applies fine to aurora but needs help for beta.
Flags: needinfo?(sriram)
Is this required in beta? We never fixed overdraw for Awesomebar in beta.
AwesomeBar should have a white background (as it inherits from Light theme) and hence shouldn't be corrupted.
Flags: needinfo?(sriram)
(In reply to Sriram Ramasubramanian [:sriram] from comment #34)
> Is this required in beta? We never fixed overdraw for Awesomebar in beta.
> AwesomeBar should have a white background (as it inherits from Light theme)
> and hence shouldn't be corrupted.

Who's this a question for? Can you check?
I am unable to reproduce the issue on the the Samsung Galaxy S2 (Android 4.0.4) or LG Nexus 4 (Android 4.2.2) on the Firefox Mobile 22 beta 4. However on the Acer Iconia A500 (Android 3.2) the area of the copy/paste UI remains white when the bar is dismissed, but I believe this was covered in another bug.

Videocapture on Honeycomb: http://youtu.be/Vx930E2R3Io
(In reply to Alex Keybl [:akeybl] (out till 6/10) from comment #35)
> (In reply to Sriram Ramasubramanian [:sriram] from comment #34)
> > Is this required in beta? We never fixed overdraw for Awesomebar in beta.
> > AwesomeBar should have a white background (as it inherits from Light theme)
> > and hence shouldn't be corrupted.
> 
> Who's this a question for? Can you check?

This was for Aaron :)
But this issue is not seen in Beta. We don't have to track this bug for beta.
Fx22 is not affected.
You need to log in before you can comment on or make changes to this bug.