Private downloads don't update

RESOLVED FIXED in seamonkey2.19

Status

SeaMonkey
Download & File Handling
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: neil@parkwaycc.co.uk)

Tracking

(Blocks: 1 bug)

unspecified
seamonkey2.19
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.18 fixed, seamonkey2.19 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Although starting a private download opens a progress dialog, the dialog never updates. Also when it does update it will automatically close when done, which is inconvenient as there is no way to reopen it.
(Assignee)

Comment 1

4 years ago
Created attachment 723008 [details] [diff] [review]
Proposed patch

The addPrivacyAwareListener is the change that makes the dialog update correctly.

I opted to hide the checkbox if the download is private.

If properties for an already finished download are opened from the download manager then the dialog will not close automatically. If you think this is outside the scope of the bug then I will remove that part of the patch.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #723008 - Flags: review?(iann_bugzilla)
Attachment #723008 - Flags: feedback?(philip.chee)

Comment 2

4 years ago
Hm. Should we even open a progress dialog for a PB download?
(Assignee)

Comment 3

4 years ago
(In reply to Philip Chee from comment #2)
> Should we even open a progress dialog for a PB download?

They don't appear in the Download Manager, so what choice do we have?
(Assignee)

Updated

4 years ago
status-seamonkey2.18: --- → affected
status-seamonkey2.19: --- → affected

Comment 4

4 years ago
Comment on attachment 723008 [details] [diff] [review]
Proposed patch

Works if I save a web page. If I use the context menu "Save Link Target As..." the Download Manager opens and the download is not private. Need to fix nsContextMenu.js

See Bug 792517 and:
http://hg.mozilla.org/mozilla-central/rev/cb64683950d9
Attachment #723008 - Flags: feedback?(philip.chee) → feedback-

Comment 5

4 years ago
Comment on attachment 723008 [details] [diff] [review]
Proposed patch

f=me any remaining issues to be fixed in Bug 851304
Attachment #723008 - Flags: feedback- → feedback+

Updated

4 years ago
Attachment #723008 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 6

4 years ago
Pushed comm-central changeset 386c0f15fcd6.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Target Milestone: --- → seamonkey2.19
(Assignee)

Updated

4 years ago
status-seamonkey2.19: affected → fixed
(Assignee)

Comment 7

4 years ago
Comment on attachment 723008 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: Unable to monitor the progress of a private download
Testing completed (on m-c, etc.): Merged to c-a
Risk to taking this patch (and alternatives if risky): 
String changes made by this patch: None
Attachment #723008 - Flags: approval-comm-beta?

Updated

4 years ago
Attachment #723008 - Flags: approval-comm-beta? → approval-comm-beta+

Updated

4 years ago
Blocks: 460895
(Assignee)

Comment 8

4 years ago
http://hg.mozilla.org/releases/comm-beta/rev/f3408ba1247a
status-seamonkey2.18: affected → fixed
You need to log in before you can comment on or make changes to this bug.