nsContextMenu.js save as handler creates a channel without regard for privacy status

RESOLVED FIXED in seamonkey2.19

Status

SeaMonkey
Download & File Handling
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: neil@parkwaycc.co.uk)

Tracking

(Blocks: 1 bug)

unspecified
seamonkey2.19

SeaMonkey Tracking Flags

(seamonkey2.18 fixed, seamonkey2.19 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
+++ This bug was initially created as a clone of Bug #792517 +++

Ratty spotted this while reviewing bug 849440.
(Assignee)

Comment 1

4 years ago
Created attachment 725123 [details] [diff] [review]
Proposed patch
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #725123 - Flags: review?(iann_bugzilla)
Attachment #725123 - Flags: feedback?(philip.chee)

Comment 2

4 years ago
Comment on attachment 725123 [details] [diff] [review]
Proposed patch

f=me
Attachment #725123 - Flags: feedback?(philip.chee) → feedback+

Updated

4 years ago
Attachment #725123 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 3

4 years ago
Pushed comm-central changeset 808981a7dd77.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Target Milestone: --- → seamonkey2.19
(Assignee)

Updated

4 years ago
status-seamonkey2.18: --- → affected
status-seamonkey2.19: --- → fixed
(Assignee)

Comment 4

4 years ago
Comment on attachment 725123 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: Potential information leak
Testing completed (on m-c, etc.): Uplifted to c-a
Risk to taking this patch (and alternatives if risky): Low
String changes made by this patch: None
Attachment #725123 - Flags: approval-comm-aurora?
(Assignee)

Comment 5

4 years ago
Comment on attachment 725123 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: Potential information leak
Testing completed (on m-c, etc.): Uplifted to c-a
Risk to taking this patch (and alternatives if risky): Low
String changes made by this patch: None
Attachment #725123 - Flags: approval-comm-aurora? → approval-comm-beta?

Updated

4 years ago
Attachment #725123 - Flags: approval-comm-beta? → approval-comm-beta+

Updated

4 years ago
Blocks: 460895
(Assignee)

Comment 6

4 years ago
http://hg.mozilla.org/releases/comm-beta/rev/161dfb7785ac
status-seamonkey2.18: affected → fixed
You need to log in before you can comment on or make changes to this bug.