Closed Bug 849690 Opened 8 years ago Closed 7 years ago

Adding a Switch to Metro feature to Desktop Firefox

Categories

(Firefox :: Shell Integration, defect)

x86_64
Windows 8.1
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 924914

People

(Reporter: kjozwiak, Unassigned)

References

Details

(Whiteboard: [parity-chrome])

Think it would be a good idea to add a "Switch to Metro/Switch to Desktop" feature similar to the one that is currently available in Chrome. If a user was using the Metro browser, he could switch into Desktop mode and vice versa.

Actual Behavior:
- Feature currently doesn't exist

Expected Behavior:
- User in Metro mode could switch over to Desktop by selecting "Switch to Desktop" mode
- User in Desktop mode could switch over to Metro by selecting "Switch to Metro" mode
Summary: adding "Switch to Metro/Switch to Desktop" feature → Adding a Switch to Metro feature to Desktop Firefox
Remaining is just the switch to Metro feature.
Whiteboard: p=3
Flags: needinfo?(asa)
In Chrome this feature is also persistent across launches; it affects which UI is launched when you use the Windows Start tile.  Very handy.
Whiteboard: p=3 → [parity-chrome] p=3
See Also: → 831608
With all the keyboard detaching / reattaching win8 devices I can see people wanting to switch back and forth for a better experience depending on what they are currently using as their primary input means.

I think the behavior mentioned in comment 2 should be controlled by a pref (re: bug 771176).
See Also: → 771176
Not for v1. Maybe for v2.
Blocks: metrov2planning
No longer blocks: metrov1triage
Flags: needinfo?(asa)
Whiteboard: [parity-chrome] p=3 → [parity-chrome]
Component: Shell → Shell Integration
Product: Firefox for Metro → Firefox
Version: unspecified → Trunk
Duplicate of this bug: 921903
A lot of people I have spoken with ask for the ability to send single pages or an entire session over to Metro.

Like  Brian R. Bondy's insightful comment:
"With all the keyboard detaching / reattaching win8 devices I can see people wanting to switch back and forth for a better experience depending on what they are currently using as their primary input means."

To be most efficient, that could call for maybe even a Nav-Bar button to switch over a session or a single page.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 924914
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.