Closed Bug 849942 Opened 7 years ago Closed 7 years ago

update windows 2008R2 MDT task sequence with new known_hosts

Categories

(Infrastructure & Operations :: RelOps: General, task)

x86
macOS
task
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kmoir, Assigned: q)

References

Details

We need to add an entry for the new symbol fqdn in bug 804357 in the known_hosts of the windows builders. 

See https://bug804357.bugzilla.mozilla.org/attachment.cgi?id=721679 

I think this applies to just w64-ix-slave* and mw32-ix-slave*
Kim: I believe you guys control these with OPSI?  The w64 builders and w32 builders are not under any sort of configuration management control on the IT side (though it's on our radar to redo w64 builders after we finish replacing the talos test infrastructure so that they, too, are bound to the domain and we can use GPO and eventually puppet on them). We can do a complete rebuild of every affected system, but I doubt that's what you want.  

What we can and should do on the IT side is take a new snapshot of the w32 systems after you guys update the ref image (please either comment in this bug when that's done or open a specific bug), and we can add it to the installation task sequence of the w64 machines.
Right, I was just going to update the existing build machines but I wanted the ref image to be updated with the new file.

I talked to Armen about this earlier today and he said to open a bug with IT to take a new image.  Armen where is the ref image that I need to update?
Flags: needinfo?(armenzg)
We don't control w64 ix machines with OPSI.
We just need it to be added to the win64 task sequence.
There's no win64 ref machine (as you know).

We don't reimage anymore win32 machines so there is no need to update the snapshot AFAIU.

arr, I don't know about task sequence but isn't just replacing the known_hosts that gets deployed with task sequence with this new one? I don't have a deep insight about when this happens.

AFAIK we only touch the contents of ~/.ssh if the machine is for staging or try:
https://wiki.mozilla.org/ReferencePlatforms/Win64#Post-reimaging_steps
Flags: needinfo?(armenzg)
Armen/Kim: We'll add it to the w64 task sequence.
Armen: We still have a ref machine and w32 slaves.  Are we never going to reimage those again (even in the case of hardware failure or loaning to a dev or something)?
Assignee: server-ops-releng → q
(In reply to Amy Rich [:arich] [:arr] from comment #4)
> Armen: We still have a ref machine and w32 slaves.  Are we never going to
> reimage those again (even in the case of hardware failure or loaning to a
> dev or something)?

We are moving away from those w32 slaves. We don't have jobs running on them that push symbols. In other words, having an updated known_hosts is not necessary.
armen: rgr, thanks for the clarifications!
What's the status for this bug ? Some of the hosts have the updated known_hosts (eg w64-ix-slave81) but others don't (eg w64-ix-slave88), so we're hitting intermittent issues on production jobs (bug 853347).
Blocks: 853347
This bug is only to update the task sequence.  It won't have any impact on running machines.
Summary: update windows builder images with new known_hosts → update windows 2008R2 MDT task sequence with new known_hosts
(In reply to Amy Rich [:arich] [:arr] from comment #8)
> This bug is only to update the task sequence.  It won't have any impact on
> running machines.

I think nthomas was trying to get that info from kmoir.

kmoir, what is the status of known_hosts for win64_builders?
Flags: needinfo?(kmoir)
I updated all of the production machines before landing the changes for bug 804357. Somehow w64-ix-slave88 was missed.  I just re-verified all the w64-ix-slave build machines and also fixed 87 and 100.  If machine is reimaged, the known hosts will have to be updated until the task sequence is updated, that's my understanding.
Flags: needinfo?(kmoir)
I posted on the wrong bug:
(In reply to Armen Zambrano G. [:armenzg] from comment #2)
> I've created this post reimaging steps section:
> https://wiki.mozilla.org/ReferencePlatforms/
> Win64#Deploy_the_lastest_known_host
> 
> Do you mind adding what is needed until this bug is fixed?
> 
> Thanks!
wiki updated :-)
Pulled the correct known_hosts file from hg. There seems to be some extra detritus in the file in the MDT setup I am going to sort that out and commit it into the TS, hopefully today.
Blocks: 853824
The new known_hosts file is now copied over during the WDS install for the builders.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Component: Server Operations: RelEng → RelOps
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.