Closed Bug 850339 Opened 7 years ago Closed 7 years ago

releases.mozilla.org doesn't track SeaMonkey anymore

Categories

(SeaMonkey :: Website, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: andr55, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:18.0) Gecko/20100101 Firefox/18.0 SeaMonkey/2.15.2
Build ID: 20130203000123

Steps to reproduce:

1. attempted to download french langpack by minor click
2. regular click didn't work either


Actual results:

error message saying that releases.mozilla.org not found.

The url attempted is :
http://releases.mozilla.org/pub/mozilla.org/seamonkey/releases/2.16.1/langpack/seamonkey-2.16.1.fr.langpack.xpi


Expected results:

The french langpack should have been downloaded.
(Also attempt to install is option 2.)
I believe they were having issues of late with releases.mozilla.org (the bouncer or whatnot, perhaps switching to IDN or something or the other), but it looks to be working now.

If there are issues (there are for some languages) with your language pack, there is a 2.16.2 release pending & that should contain corrected language packs.  (Not all languages were affected. I /believe/ fr was OK?)
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 843468
** reopening **
This problem occurs again with seamonkey 2.17.1

The full package downloads fine, but attempting to download the french language pack gives the following error message :

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>404 Not Found</title>
</head><body>
<h1>Not Found</h1>
<p>The requested URL /pub/mozilla.org/seamonkey/releases/2.17.1/langpack/seamonkey-2.17.1.fr.langpack.xpi was not found on this server.</p>
</body></html>


For the previous version I never succeeded in downloading the language pack.
Is the url correct ?
Or is the server down ?

Note that the url for the full package is at "https://download.mozilla.org/?product=seamonkey-2.17.1&os=linux&lang=fr"
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
It would be really nice if Mozilla gave alternate mirrors, like some other large open source sites, to avoid this type of problem.
AFAICT, SeaMonkey isn't followed by releases.mozilla.org anymore; in particular, the directory http://releases.mozilla.org/pub/mozilla.org/seamonkey/ is empty (also when accessed by FTP instead of HTTP).

I personally don't know if this is intentional or not, but I'm adding to the CC people who (I think) should know.

In the meantime, use ftp.mozilla.org instead; and don't worry about the motd with the menacing warning at the end saying

230-   Attempts to download high traffic release files from this server will get a
230-   "550 Permission denied." response.

-- SeaMonkey releases aren't (yet) very high-traffic, and the French localized releases, though not marginal, see less traffic than the en-US ones anyway.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: seamonkey download page -- langpacks not downloadable. → releases.mozilla.org doesn't track SeaMonkey anymore
OS: Linux → All
Hardware: x86 → All
Version: SeaMonkey 2.15 Branch → SeaMonkey 2.17 Branch
Thanks for the link info :)

For others, the full link for langpacks is (for version 2.17.1)
ftp://ftp.mozilla.org/pub/seamonkey/releases/2.17.1/langpack/

Maybe that could be used for langpack links on the Seamonkey release web page ... if Seamonkey has control over it, at least.
Due to the way releases are done now (via CDN from what I've been told), 
releases.mozilla.org will no longer track SeaMonkey.

I'm closing this as a WontFix.
Status: NEW → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → WONTFIX
(In reply to andré from comment #7)
> Thanks for the link info :)
> 
> For others, the full link for langpacks is (for version 2.17.1)
> ftp://ftp.mozilla.org/pub/seamonkey/releases/2.17.1/langpack/
> 
> Maybe that could be used for langpack links on the Seamonkey release web
> page ... if Seamonkey has control over it, at least.

I've filed bug 871120 as a followup bug, to fix the links to releases.mozilla.org on the seamonkey-project.org site.
Component: General → www.seamonkey-project.org
Product: SeaMonkey → Websites
Version: SeaMonkey 2.17 Branch → unspecified
Duplicate of this bug: 864142
Product: Websites → SeaMonkey
You need to log in before you can comment on or make changes to this bug.