Closed Bug 871120 Opened 8 years ago Closed 8 years ago

SeaMonkey URLs pointing to releases.mozilla.org need to be redirected to ftp.mozilla.org

Categories

(SeaMonkey :: Website, defect)

defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: tonymec, Assigned: InvisibleSmiley)

References

()

Details

Attachments

(2 files)

Bug 850339 comment #8:
> Due to the way releases are done now (via CDN from what I've been told),
> releases.mozilla.org will no longer track SeaMonkey.
> 
> I'm closing this as a WontFix.

See also bug 850339 comment #7.

The above means that all URLs pointing to releases.mozilla.org for SeaMonkey must be redirected to ftp.mozilla.org. I have already identified the following:
- All langpacks at http://www.seamonkey-project.org/releases/#langpacks
- All URLs for Linux64 at http://www.seamonkey-project.org/releases/#contrib

I haven't checked the links found on the pages for beta and older releases but I suspect they too must be edited.

I'm setting the Severity to major because as long as those links aren't fixed they'll give Error 404 or the equivalent.
See Also: → 850339
See Also: → 851028
See Also: 851028867926
Attached patch disabling patchSplinter Review
Just in case this needs to be reverted (and to know how) I've disabled releases.mozilla.org instead of removing/replacing it.

Checking in lib/config.tmpl;
/www/seamonkeyproject-org/lib/config.tmpl,v  <--  config.tmpl
new revision: 1.164; previous revision: 1.163
done
Checking in lib/release.tmpl;
/www/seamonkeyproject-org/lib/release.tmpl,v  <--  release.tmpl
new revision: 1.20; previous revision: 1.19
done
Assignee: nobody → jh
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
VERIFIED by checking the langpack & L64 links on the "All Platforms and Languages" pages for the 2.17.1 and 2.18b4 releases, plus a random selection of older releases.

Feel free to REOPEN with details (or maybe open a followup bug) if "wrong" links are still found at places I didn't check.
Status: RESOLVED → VERIFIED
Turns out I broke (at least) seamonkey_versions.json which I didn't even know existed. The cause was in config.tmpl which is structured a bit differently than release.tmpl, requiring the first of the two commenting techniques explained on <http://www.template-toolkit.org/docs/manual/Syntax.html#section_Comments>. Funnily I could probably have avoided all this if I had removed the download_allfiles part completely since it seems it's not used anymore (but I'm not sure).


use comments according to Template Toolkit rules

Checking in lib/config.tmpl;
/www/seamonkeyproject-org/lib/config.tmpl,v  <--  config.tmpl
new revision: 1.165; previous revision: 1.164
done
See Also: → 1003635
See Also: 1003635
Product: Websites → SeaMonkey
You need to log in before you can comment on or make changes to this bug.