Last Comment Bug 852095 - [RFE] Add a feature to compress received attachments
: [RFE] Add a feature to compress received attachments
Status: RESOLVED DUPLICATE of bug 595629
:
Product: Thunderbird
Classification: Client Software
Component: Untriaged (show other bugs)
: 16 Branch
: x86_64 All
: -- enhancement (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://superuser.com/questions/562236...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-18 04:17 PDT by Ruben
Modified: 2014-04-25 04:47 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Ruben 2013-03-18 04:17:29 PDT
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307122903

Steps to reproduce:

I get lots of mails with uncompressed attachments (*.txt, *.bmp, ...) from my customers.


Actual results:

The IMAP folder is getting very big


Expected results:

Like deleting or detaching attachments from a message there should be another option "compress attachment"

This should detach the original attachment and compress it with an appropriate tool (zip for textfiles, png for images,...) and attach that compressed version to the message instead.
Comment 1 Ruben 2013-03-18 06:15:55 PDT
Maybe this Addon shows some hints how to implement it:
EditEmailSubject 2.0.2 
https://addons.mozilla.org/de/thunderbird/addon/edit-email-subject/?src=ss

It can change the subject retrospectively.
code:
http://pastebin.com/fLgHs7BZ
Comment 2 :aceman 2013-03-20 09:42:06 PDT
There is an "Auto compress file" addon, but that seems to only compress when sending msgs out...

Maybe you could contact the author to add this feature on incoming messages?
Comment 3 Wayne Mery (:wsmwk, use Needinfo for questions) 2014-04-25 04:33:47 PDT

*** This bug has been marked as a duplicate of bug 12865 ***
Comment 4 Wayne Mery (:wsmwk, use Needinfo for questions) 2014-04-25 04:37:46 PDT
wrong bug

*** This bug has been marked as a duplicate of bug 9309 ***
Comment 5 Ruben 2014-04-25 04:46:50 PDT
That is not a Duplicate at all! bug 9309 is about detaching attachments automatically

I want something completely different here:

I would like to keep the attachments in my mail but zip them inside my IMAP folder automatically 

1. detach it
2. zip it
3. re-attach it to the original email
Comment 6 Wayne Mery (:wsmwk, use Needinfo for questions) 2014-04-25 04:47:24 PDT
hopefully third time is the charm.  bug 595629 is better

*** This bug has been marked as a duplicate of bug 595629 ***

Note You need to log in before you can comment on or make changes to this bug.