mozilla hangs when sending mail

VERIFIED DUPLICATE of bug 85304

Status

MailNews Core
Composition
--
major
VERIFIED DUPLICATE of bug 85304
17 years ago
10 years ago

People

(Reporter: Mike Gratton, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
As far back as at least the 2001-06-07 nightlies, Mozilla has stopped being able
to send mail. After composing a message and hitting send, the status says
"Sending message..." but the message is never sent, and Mozilla refuses to load
any mail messages or *web pages* afterwards, even if the message is canceled.
The UI still works (scrolling, menus, etc), however.

I'm still seeing this in today's nightly, 2001061109.

The following appears in the console when composing and sending a message:


Compose: ComposeStartup
[nsIMsgIdentity: id1],[nsIMsgIdentity: id2],[nsIMsgIdentity: id3]
replacing child in comp fields 2 recips 
Warning prev sibling is not in our list!!!
set focus on the recipient
SendMessage from XUL
GenericSendMessage from XUL
Identity = [nsIMsgIdentity: id1]
attachments = 
msgCompose.CheckAndPopulateRecipients failed: [Exception... "Component returned
failure code: 0xd381e4a5 [nsIMsgCompose.CheckAndPopulateRecipients]"  nsresult:
"0xd381e4a5 (<unknown>)"  location: "JS frame ::
chrome://messenger/content/messengercompose/MsgComposeCommands.js ::
DetermineHTMLAction :: line 1693"  data: no]
Reporter:
Can you try this:
Edit/Mail News Account Settings/outgoing server
and then "Use secure connection (SSL)"= Never ?

(Reporter)

Comment 2

17 years ago
Ahh, that fixed it, thanks Matti.

I guess this is a dupe or something then.

Comment 3

17 years ago
I have seen this problem since the 2001-06-08 nightlies up until the current
one, 2001-06-11. Setting Use Secure Connection (SSL) to None did not make the
problem go away. I am using Linux (Red Hat 7.1 on an x86).
(Reporter)

Comment 4

17 years ago
csmith, you may want to check under the Advanced tab and ensure all the SMTP
servers listed under there also are set to None. That list is a bit buggy right
now, but if you use multiple servers, you'll want them all not using SSL (unless
of course, they require it 8).

Comment 5

17 years ago
*** Bug 85379 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
Setting SSL to "never" should not be considered a fix for this bug. I don't know
what SSL does, but anything with the word "secure" in it makes me feel..well..
more "secure :)

I've tried testing this workaround and have discovered that switching back and
forth between "never" and "when available" without restarting mozilla yields
*inconsistent results* (sometimes i can send, sometimes not <- when set to "never").

SPAM: This is a highly disturbing bug with an inconsistent workaround and really
should have:
 SEVERITY:   critical or blocker
 Target MS:  mozilla0.9.2
 Keywords (mike@vee.net):   4xp, mail4, mozilla0.9.2, nsbeta1, nsCatFood, regression
This is a dupe of bug 84731.

Please open a new bug if you can't fix your mail send bug with SSL=never

Plairo: 
Keyword : 4xp is wrong since this is a bug and not a feature.
And I ask because I want to know if this is a dupe.


*** This bug has been marked as a duplicate of 84731 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 8

17 years ago
this is actually a dup of bug 74387
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 9

17 years ago
this is dup of bug 74387

*** This bug has been marked as a duplicate of 74387 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 10

17 years ago
verified as dup
Status: RESOLVED → VERIFIED
Sorry for this SPAM
reopening, bug 74387 is wrong.
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---
Duping to the correct bug.
Bug 84731 changed from "broken SSL" to "change SSL = never in the preferences".

*** This bug has been marked as a duplicate of 85304 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 13

17 years ago
verified as dup 
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.